• System hangs at ROOT\_ANTERGOS: recovering journal


    I recently performed a system update through PacmanXG. My system appears to halt after booting Antergos from the grub bootloader.

    ROOT\_ANTERGOS: recovering journal  
    ROOT\_ANTERGOS: clean, X/Y files, X/Y blocks
    

    Sometimes, the prompt will provide additional information:

    :exclamation:Sorry, this attachment is unavailable.

    I’ve tried repairing the file system using [i:128vp7n0]fsck[/i:128vp7n0] in a live CD. Also, I can still access the files on my SSD using the live CD. Any advice would be greatly appreciated.

  • I recently performed a system update through PacmanXG. My system appears to halt after booting Antergos from the grub bootloader.

    ROOT\_ANTERGOS: recovering journal  
    ROOT\_ANTERGOS: clean, X/Y files, X/Y blocks
    

    Sometimes, the prompt will provide additional information:

    :exclamation:Sorry, this attachment is unavailable.

    I’ve tried repairing the file system using [i:128vp7n0]fsck[/i:128vp7n0] in a live CD. Also, I can still access the files on my SSD using the live CD. Any advice would be greatly appreciated.

  • I apologize for the long response time. I know how frustrating boot issues are. I’m sure we can figure it out though!
    Add “systemd.unit=multi-user.target” to the end of that line after “quiet” like this:

    linux /boot/vmlinuz-linux root=UUID=a-lot-of-numbers-and-letters-here rw quiet systemd.unit=multi-user.target
    

    Now continue boot, I believe its F10, it will list the keys at the bottom of the screen though. If successful you will be at a terminal login prompt. After logging in, switch to root and run “pacman -Syyu”. Take note of any error messages. After that completes run “mkinitcpio -p linux”. Also for good measure let’s update grub’s menu with “grub-mkconfig -o /boot/grub/grub.cfg”. Finally reboot with “systemctl reboot”.

    Hopefully you are looking at your desktop now, if not please post details.

    Regards,

  • Thanks for the help, Dustin. Yesterday, I unsuccessfully attempted to run “pacman -Syyu” while chrooted. I was successfully able to enter the terminal commands you provided. However, the problem still persists. I really like the way I have Antergos configured, so I’m definitely willing to be patient in attempting to rescue my installation.

    Though the image generation was successful, I received the following warnings while running “mkinitcpio -p linux”:

    WARNING: Possibly missing firmware for module: aic94xx  
    WARNING: Possibly missing firmware for module: bfa  
    WARNING: Possibly missing firmware for module: smsmdtv
    

    I don’t know if the following will help, but I’ve provided my grub and fstab configurations:

     load\_video  
    set gfxpayload=keep  
    insmod gzio  
    insmod part\_msdos  
    insmod ext2  
    set root='hd0,msdos1'  
    if [ x$feature\_platform\_search\_hint = xy ]; then  
    search --no-floppy --fs-uuid --set=root --hint-bios=hd0,msdos1 --hint-efi=hd0,msdos1 --hint-baremetal=ahci0,msdos1 e217ed92-305b-40c0-8bed-40a497867779  
    else  
    search --no-floppy --fs-uuid --set=root e217ed92-305b-40c0-8bed-40a497867779  
    fi  
    echo 'Loading Linux ...'  
    linux /vmlinuz-linux-lts root=UUID=e79af4dc-273f-4218-a652-9ea82ab42432 rw quiet  
    echo 'Loading initial ramdisk ...'  
    initrd /initramfs-linux-lts.img
    
    \# <file system\> <mount point\> <type\> <options\> <dump\> <pass\>  
    \#  
    \#UUID=e217ed92-305b-40c0-8bed-40a497867779 /boot ext2 defaults 0 0  
    UUID=e79af4dc-273f-4218-a652-9ea82ab42432 / ext4 rw,relatime,data=ordered 0 1  
    LABEL=Plex /mnt/Plex auto nosuid,nodev,nofail,x-gvfs-show 0 0  
    LABEL=Storage /mnt/Storage auto nosuid,nodev,nofail,x-gvfs-show 0 0  
    UUID=e217ed92-305b-40c0-8bed-40a497867779 /boot ext2 defaults 0 2
    

    Again, thanks for all your help so far.

  • You are making me think really hard on this one lol

    Once you log in, grab the journals from the current, last, and 2nd to last boots like this:

    sudo journalctl -b \> ~journal.current  
    sudo journalctl -b -1 \> ~journal.last  
    sudo journalctl -b -2 \> ~journal.2last
    

    I believe you have access to the partition from a livecd or other OS, correct? The easiest way to grab the journal files will probably be to mount your /home from outside the installation. I will check in later this evening to see if you were able to post them.

    Best Regards,

  • Thanks for responding. I’ve put the journal files in an archive for you to look at. I wasn’t able to switch VTs, but had to boot with the command you provided previously.

    :exclamation:Sorry, this attachment is unavailable.

    I’m still trying my luck browsing the Arch user forums for related issues.

  • Ok, not as useful as I had hoped but that’s ok. Are you using a usb modem or usb ethernet device? If you are try to boot without it plugged in. There is an error related to something that is connected via usb but I am not sure what. Better yet, could you post the output of “lsusb” command? Another message points to xorg related issues. If you could grab any xorg log files from /var/log/ (Xorg.0.log, Xorg.1.log, etc) that would be helpful.

    Oh, and as always before anything else perform a system update “pacman -Syyu”.(By booting into multi-user.target) With a rolling release like Arch, you never know when these things might just fix themselves (so to speak)

Posts 7Views 1920
Log in to reply