• Antergos-2015.08.18


    @pyUser 2nd that 👍 install finished this time 👌

    i actually un selected everything but printer support. the download to me even seemed to go much faster i noticed.

    so that was a long day 😁 glad to be back up and running though.

  • @megaman

    You had some bad luck today lol.

    Manually partitioned my drives and edited the package list (For Plasma) to personal preference and didn’t receive an issue lol.

  • @Wyn lol 😆 thats a understatement

    i also manually partitioned. i think the nvidia bug is what got me.

    what is your card?

  • @megaman
    Here are the commands for installing Nvidia proprietary driver if you don’t know how

    For GeForce 400 series cards and newer

    sudo pacman -S nvidia nvidia-utils nvidia-libgl
    

    For GeForce 8000/9000 and 100-300 series cards

    sudo pacman -S nvidia-340xx nvidia-340xx-utils nvidia-340xx-libgl 
    

    If you want to install google fonts

    sudo pacman -S ttf-google-fonts
    

    And if you want the Libreoffice

    sudo pacman -S libreoffice-fresh
    

    Hope this helps

  • @megaman

    Sli gtx 770’s. I assumed the installer used the open sourced drivers so I didnt touch them. Guess I lucked out :)

  • @pyUser

    i have an experience about installing Nvidia driver, yesterday i try to install it.
    using this command:

    sudo pacman -Syy nvidia nvidia-utils lib32-nvidia-utils nvidia-libgl
    

    but after i reboot my computer its has white blank screen just the cursor is appearance.

  • @pyUser thanks for the commands. do we need to uninstall the opensource drivers 1st?

    i actually just bought a GT 720. finally gave up on AMD. i was thinking of trying out the nvidia opensource for a while but already noticed some tearing watching youtube. although not as bad as AMD open source.

  • @megaman I don’t remove anything before installing the nvidia proprietary driver

    @zero At the bootloader grub window press e and add " rcutree.rcu_idle_gp_delay=1" at the end of the line and then press b to boot
    https://wiki.archlinux.org/index.php/NVIDIA#Blackscreen_at_X_startup_with_new_driver

  • @pyUser

    thank for sharing, if i had same problem i will use it,
    i decided to re install windows 7 and then try install antergos again,
    ridiculous right? because i new in linux and yesterday i had an important job so that is my solution as newbie

    cheers

  • Just wanted to report more tests’ results. Sorry for the long post.

    With Antergos-2015.08.18, I was mainly interested in testing the new “Graphic drivers (Proprietary)” option (GDP) on Nvidia Optimus (hybrid) cards. I don’t use simple Nvidia cards.

    Confirm that the libcl problem is formally solved. At least, tt doesn’t brake the installation immediately. Installations starts.

    Cnchi

    Apparently, Cnchi is at 0.10.7 right now. Installations, which use it, terminate well. But sometimes, with connection established and working, Cnchi autoupgrades to 0.10.6. And states it’s at the most recent version. Sometimes it doesn’t autoupgrade, remains at 0.10.1. And states that the user has the latest version and may proceed with the installation.

    If the user doesn’t know that 0.10.7 is currently is available, there’s no clue for him to discover it.

    Optimus

    As expected, GDP doesn’t work on Nvidia Optimus. It maight work on AMD or simple Nvidia, but not here. When the option is disabled, installation finishes. When the option is enabled, installation starts, downloads everything, but then hangs forever on “Checking inter conflicts…” stage:

    antergos-20150818-gnome-interconflicts.png

    It corresponds to last few lines in /tmp/cnchi.log:

    ...
    [2015-08-20 05:54:23] [pac] DEBUG: finished resolving dependencies
    [2015-08-20 05:54:23] [pac] DEBUG: started resolving dependencies
    [2015-08-20 05:54:23] [pac] DEBUG: checkdeps: package gnome-shell-extension-status-menu-buttons-0.2-1
    [2015-08-20 05:54:23] [pac] DEBUG: checkdeps: missing dependency 'gnome-shell-extensions' for package 'gnome-shell-extension-status-menu-buttons'
    [2015-08-20 05:54:23] [pac] DEBUG: checkdeps: missing dependency 'lightdm' for package 'gnome-shell-extension-status-menu-buttons'
    [2015-08-20 05:54:23] [pac] DEBUG: checkdeps: missing dependency 'xscreensaver' for package 'gnome-shell-extension-status-menu-buttons'
    [2015-08-20 05:54:23] [pac] DEBUG: checkdeps: missing dependency 'light-locker' for package 'gnome-shell-extension-status-menu-buttons'
    [2015-08-20 05:54:23] [pac] DEBUG: finished resolving dependencies
    [2015-08-20 05:54:23] [pac] DEBUG: looking for conflicts
    [2015-08-20 05:54:23] [pac] DEBUG: check targets vs targets
    [2015-08-20 05:54:23] [pac] DEBUG: check targets vs targets
    [2015-08-20 05:54:23] [pac] DEBUG: package lib32-nvidia-libgl conflicts with lib32-mesa-libgl (by lib32-libgl)
    [2015-08-20 05:54:23] [pac] DEBUG: conflicting packages in the sync list: 'lib32-nvidia-libgl' <-> 'lib32-mesa-libgl'
    [2015-08-20 05:54:23] [pac] ERROR: unresolvable package conflicts detected
    [2015-08-20 05:54:23] [slides] INFO: Checking inter conflicts...
    
    

    This happens in all DEs, which manage to arrive up to the “Checking inter conflicts…” stage.

    That’s because proprietary Nvidia installation on Optimus is VERY different from those on plain Nvidia. If the latter is applied on Optimus, the most common result is unbootable system.

    Kde

    As reported earlier, Kde4 (with GDP disabled) installation terminates correctly. Then, the system boots, kernel loads,but the session doesn’t finish to load. The first icon on KDE splash screen appears, and then… nothing else happens. The splash screen, with the first icon in it, remains displayed forever.

    Mate

    The installation stops immediately:

    antergos-20150818-mate-fails.png

    Seems like the offending package is mate-media-pulseaudio now:

    ...
    [2015-08-20 07:02:53] [pac] DEBUG: loading package cache for repository 'local'
    [2015-08-20 07:02:53] [pac] DEBUG: added 0 packages to package cache for db 'local'
    [2015-08-20 07:02:53] [pac] DEBUG: loading group cache for repository 'extra'
    [2015-08-20 07:03:00] [metalink] ERROR: Can't find these packages: mate-media-pulseaudio
    [2015-08-20 07:03:00] [download] ERROR: Error creating metalink for package mate-media-pulseaudio. Installation will stop
    [2015-08-20 07:03:00] [process] ERROR: "Can't create download package list. Check log output for details"
    [2015-08-20 07:03:00] [process] ERROR: Traceback (most recent call last):
    
    [2015-08-20 07:03:00] [process] ERROR:   File "/usr/share/cnchi/cnchi/installation/process.py", line 176, in run
        self.run_installation()
    
    [2015-08-20 07:03:00] [process] ERROR:   File "/usr/share/cnchi/cnchi/misc/misc.py", line 175, in helper
        return func(*args, **kwargs)
    
    [2015-08-20 07:03:00] [process] ERROR:   File "/usr/share/cnchi/cnchi/installation/process.py", line 366, in run_installation
        self.download_packages()
    
    [2015-08-20 07:03:00] [process] ERROR:   File "/usr/share/cnchi/cnchi/installation/process.py", line 423, in download_packages
        self.settings)
    
    [2015-08-20 07:03:00] [process] ERROR:   File "/usr/share/cnchi/cnchi/download/download.py", line 102, in __init__
        raise InstallError(_("Can't create download package list. Check log output for details"))
    
    [2015-08-20 07:03:00] [process] ERROR: misc.misc.InstallError: "Can't create download package list. Check log output for details"
    
    [2015-08-20 07:03:13] [slides] INFO: Installing using the 'advanced' method
    [2015-08-20 07:03:13] [slides] INFO: Updating core database
    [2015-08-20 07:03:13] [slides] INFO: Updating extra database
    [2015-08-20 07:03:13] [slides] INFO: Updating community database
    [2015-08-20 07:03:13] [slides] INFO: Updating multilib database
    [2015-08-20 07:03:13] [slides] INFO: Updating antergos database
    [2015-08-20 07:03:13] [slides] INFO: Getting package list...
    [2015-08-20 07:03:13] [slides] INFO: Creating the list of packages to download...
    [2015-08-20 07:03:13] [show_message] ERROR: "Can't create download package list. Check log output for details"
    

    Cinnamon

    Installs (without GDP), boots, runs correctly.

    Conclusion

    • “Graphic drivers (Proprietary)” option doesn’t permit installation to finish on Nvidia Optimus

    • Cnchi still behaves strangely

    • Kde 4 installs (without GDP) but not loads

    • Mate has a problem with mate-media-pulseaudio , so doesn’t install

    • Cinnamon beats them all and is rock-solid (without GDP)

    That’s the current state of things here. Sorry for the tedious post.

  • @just

    Sorry for the tedious post.

    ¿¿¿??? That was a really useful post. Thanks.

    Yes, this wasn’t intended to run on Optimus, sorry to not have stated it clearly. It just installs the proprietary driver (depending on your card, it should choose the correct version) and that’s it. If you need special configuration Cnchi won’t do it. Having said that, it should not block itself because a conflict between lib32-nvidia-libgl and lib32-mesa-libgl, thats a bug for sure.

    I tested KDE myself, and it works here. I’ll test it again with Cnchi 0.10.7 (or the latest available) to see if I can reproduce your problem.

    I’ll have to check MATE packages because there seems to be some changes there.

    And last but not least, we’re struggling to find a good method to update cnchi when running the livecd. If you have patience, it will update itself, but it seems that sometimes it doesn’t. We’ve been unable to pinpoint what’s the problem when this happens (to tell you the truth, we have not experienced this issue ourselves, so it’s been very difficult to check what’s going on).

  • the nvidia opensource drivers i think were freezing my system. kept freezing and crashing after 15 minutes of use. installed nvidia official drivers and no freezing anymore.

  • @megaman Happy to hear that

    I always install the official drivers first and then install Neverball to test how the fun addictive game works with the driver

  • I tried today with using new iso same problems as op errors at very start of setup well when it comes to copying files will try again in a few days see if its maybe a problem with arch repo … was installing mate

  • @rocky how many of the antergos install options are you using?

    cnchi09_lts.png

  • @megaman hi i was trying the lts kernel and aur support on the installer

  • A little update seems it installs fine on virtualbox will try on my system again in morning was there an update to cnchi am now running cnchi installer version 0.10.25 am sure it was .23 or 24 when tried installing earlier

  • @rocky yes the cnchi update might help but also might want to try unchecking all the options. you can always have those options after install.

  • @megaman tried it again on my main system gets so far then error appears i may try
    changing the mirrors used could be a fault there but very strange it worked in virtualbox
    with no hickups

  • @rocky unchecked all the options?

Posts 42Views 16901
Log in to reply
Bloom Email Optin Plugin

Looks like your connection to Antergos Community Forum was lost, please wait while we try to reconnect.