• [solved] System will not boot after update!


    Last night there was a notification about updates and I updated. This morning when I start the computer system will not start. I get dropped into an untouchable shell and have no other option then to shut down.
    Is the best option to reinstall?

  • Was it Kernel-panic or a broken system or just Xorg? total neeb here but from my experience a rescue is always better than a reinstall unless you know you got on the wrong foot of something and want to start all over. also try booting Antergos in failsafe mode as that can sometimes be your easy way out (under advanced options in the boot menu)

  • Being an Arch system in nature, is fairly easy to downgrade packages. What did you upgrade? Was it the kernel?

  • @Jakob-Greve
    Fail safe reboot gives the same result unfortunately!

  • @Rolando-E.-Rolon

    It was just befor I went to bed but the problem is that I was trying to install the prop. catalyst legcy driver and downgrade xorg earlier. It didnt work because xorg116 was unreachable. It is probably both kernel and xorg.

  • I am an old newbie and I didnt have the system up for more than 2 days so I will do a reinstall.

  • reinstall of the whole seems like huge overkill to me. 1. you can reinstall the opensource drivers quite easily.

    also when dealing with fglrx/catalyst always run aticonfig --initial from a terminal otherwise blackscreen of death is guaranted…

    You need to run this command also when a system update makes changes to xorg. I had like 38 backup files of xorg on my old system and I’m not that heavy a user.

  • @Jakob-Greve
    As the beginner I am I couldn´t get into anything! All ttys blocked! Maybe I could have used the live-system to chroot in to the system but that would have taken me a couple of days to figure out! My system is up and running within minutes now!

  • Glad you’re there, the way you like it. For me it’s even a full out of the box system like Antergos does take some time

    like remove antril
    install acroread, spotify spideroak
    fetch backup and set new backup
    set opendns
    setup vpn
    remove galculator
    install gnome-calculator
    show desktop icons
    etc etc etc.

    Glad you’re back in the game the opensource drivers are quite functionel these days. to me It’s more like which has the best fancontrol, which I guess is the case if you’re not doing much gaming through steam or otherwise.

  • I have been thinking of this alot at work today! I will go on with the open-source driver. I will try games on Steam with Antergos on my MacBookPro (just pre-retina) instead.
    One other thing. I noticed that during boot there is problem with vconsole. I do not notice anything wrong but maybe I have to take a look at it?

  • @womp

    Check the contents of the file /etc/vconsole.conf

Posts 11Views 1948
Log in to reply