• Antergos not printing to shared printers


    Hi.

    I’m trying to configure the Antergos (my computer) to print to other computers on the network LAN, these other computers work with Ubuntu and only one of them is with Windows 7. Before migrating to the Antergos I used Ubuntu and it worked very well, however, using the Antergos printers work only locally.

    To try to solve the problem I tried to follow this tutorial in the Arch Linux Wiki https://wiki.archlinux.org/index.php/CUPS. The forbidden error fell off the CUPS configuration page localhost:631, but the network printing still does not work.

    Before I could print over the network by typing this URI in printer setup http://172.16.67.237:631/printers/Deskjet-F4100-series.

    I searched on Google for tutorials or solutions to this problem, but it seems that nobody has posted something that would help.

    One of the printers is Samsung, for HP printers I’ve managed to install the Hplip and all plugins. I believe the problem is configuration of the CUPS.

    Thanks.

  • What do the CUPS logs say?

  • @karasu I believe that the log file is </var/log/cups/error_log >. Unfortunately the computer that accuses error is where I work. I will post it next Monday, I don’t remember in detail what it said.

  • @karasu cups.7z
    Hi again. The log files are very large, if you need to I cleaned them and post again. Thank you.

  • Hi,

    Just in case, in CUPS:

    • In Antergos, remember to activate the option “Show printers shared by other systems”
    • In Ubuntu, remember to activate the option “Share printers connected to this system”

    This could be helpful, too:
    https://wiki.archlinux.org/index.php/CUPS#Remote_printer_access

    And these commands can help you to pinpoint the issue:
    https://wiki.archlinux.org/index.php/CUPS#Controlling_CUPS_from_the_Terminal

    Well, having a look at your log, there are some printers that can’t be found, but I do not know if they are old setups or what. For instance:

    FindDeviceById failed: org.freedesktop.ColorManager.NotFound:device id 'cups-HP-LaserJet-1020-Larissa' does not exist
    FindDeviceById failed: org.freedesktop.ColorManager.NotFound:device id 'cups-Hewlett-Packard-HP-LaserJet-Pro-MFP M127fn' does not exist
    FindDeviceById failed: org.freedesktop.ColorManager.NotFound:device id 'cups-HP-Photosmart-c4400' does not exist
    

    Client attempts to print end with a broken connection, as if the CUPS server from the Ubuntu host does not respond (or breaks the connection):

    [Client 255] HTTP_STATE_WAITING Closing for error 32 (Broken pipe)
    [Client 255] Closing connection.
    

    I hope something of this will help a bit. Tell us if it does or not.

    Cheers!

  • @karasu Thanks, Karasu, but the problem persists. Today I did a clean install on another computer to test, I did all the procedures in the Arch wiki and still the problem persists. In the Xubuntu that already use about three years works, has another computer that uses openSUSE, the same procedure for installation is made on him and also works.
    Does anyone else with Antergos here uses CUPS to print remotely? Or is there a better way to do this? I really like the Antergos because of the low consumption of RAM running on XFCE, mostly with old hardware, I’ve done this installation with Xubuntu and openSUSE, all are good but use much more memory than the Antergos.

  • Problem solved. After updates hplip and hp-plugin, HP Printer returned to work. There was also an error in the /etc/samba/smb.conf file, I needed just rename the file smb.conf.default to smb.conf and printers via Windows back to work.

    I appreciate the help of admins and staff engaged in problem solving and evolution of the OS Antergos.

cups11 shared printer1 cups not workin2 Posts 9Views 2318
Log in to reply