• Upgrade failure


    HI Folks,

    I’m having an upgrade failure and wondering what is the easiset way to fix it. I have had n o luck in finding an easy answer searching for a solution. Here’s what I see when I try to update via pacman:

    [[email protected] ~]$ sudo pacman -Syu
    [sudo] password for ash:
    :: Synchronizing package databases…
    core is up to date
    extra is up to date
    community is up to date
    multilib is up to date
    antergos 427.0 KiB 1145K/s 00:00 [######################################] 100%
    atlassian is up to date
    :: Starting full system upgrade…
    resolving dependencies…
    looking for conflicting packages…

    Packages (73) antergos-keyring-20150806-1 binutils-2.25.1-2 bluez-5.33-1 bluez-libs-5.33-1 bluez-utils-5.33-1
    broadcom-wl-6.30.223.248-11 chromaprint-1.2-1 chromium-44.0.2403.155-1 cmake-3.3.1-1
    cython-0.23-1 dropbox-3.8.6-1 evolution-data-server-3.16.5-1 exiv2-0.25-1 firefox-40.0.2-1
    flashplugin-11.2.202.508-1 fontconfig-2.11.1-2 fribidi-0.19.7-1 gcc-5.2.0-2 gcc-libs-5.2.0-2
    glibc-2.22-1 gnome-color-manager-3.16.0-2 gnupg-2.1.7-1 gparted-0.23.0-1 graphite-1:1.3.0-1
    gsfonts-20150808-1 hplip-3.15.7-1 imagemagick-6.9.1.10-1 iso-codes-3.60-1 jsoncpp-1.6.5-1
    ldns-1.6.17-3 lib32-gcc-libs-5.2.0-2 lib32-glibc-2.22-1 lib32-harfbuzz-1.0.1-1
    lib32-libcups-2.0.4-1 lib32-libdbus-1.8.20-1 lib32-libdrm-2.4.63-1 lib32-libpng-1.6.18-1
    lib32-mesa-10.6.4-1 lib32-mesa-libgl-10.6.4-1 lib32-sqlite-3.8.11.1-1 lib32-systemd-224-1
    lib32-v4l-utils-1.6.3-1 libdrm-2.4.63-1 libgusb-0.2.6-1 libinput-0.21.0-1 libpng-1.6.18-1
    libreoffice-fresh-5.0.0-1 libsystemd-224-1 linux-4.1.4-1 linux-api-headers-4.1.4-1
    man-pages-4.02-1 mesa-10.6.4-1 mesa-libgl-10.6.4-1 mesa-vdpau-10.6.4-1 mpg123-1.22.3-1
    openssh-7.0p1-1 os-prober-1.66-1 package-query-1.6.2-2 pacman-mirrorlist-20150811-1
    pamac-2.3.3-3 ppp-2.4.7-2 python-pycups-1.9.73-1 python-setuptools-1:18.1-2
    python2-beaker-1.7.0-2 s-nail-14.8.4-1 sqlite-3.8.11.1-2 systemd-224-1 systemd-sysvcompat-224-1
    thunderbird-38.2.0-1 ttf-google-fonts-20150805.r201-1 tzdata-2015f-1 vala-0.28.1-1
    virtualbox-host-modules-5.0.0-2

    Total Download Size: 196.01 MiB
    Total Installed Size: 1855.42 MiB
    Net Upgrade Size: 22.88 MiB

    :: Proceed with installation? [Y/n]
    :: Retrieving packages …
    broadcom-wl-6.30.223.248-11-x86_64 2.6 MiB 1579K/s 00:02 [######################################] 100%
    ttf-google-fonts-20150805.r201-1-any 145.8 MiB 1604K/s 01:33 [######################################] 100%
    dropbox-3.8.6-1-x86_64 47.3 MiB 1726K/s 00:28 [######################################] 100%
    package-query-1.6.2-2-x86_64 23.6 KiB 2.30M/s 00:00 [######################################] 100%
    pamac-2.3.3-3-x86_64 302.0 KiB 1678K/s 00:00 [######################################] 100%
    (73/73) checking keys in keyring [######################################] 100%
    (73/73) checking package integrity [######################################] 100%
    error: broadcom-wl: signature from “Antergos Build Server (Automated Package Build System) [email protected]” is unknown trust
    :: File /var/cache/pacman/pkg/broadcom-wl-6.30.223.248-11-x86_64.pkg.tar.xz is corrupted (invalid or corrupted package (PGP signature)).
    Do you want to delete it? [Y/n]
    error: ttf-google-fonts: signature from “Antergos Build Server (Automated Package Build System) [email protected]” is unknown trust
    :: File /var/cache/pacman/pkg/ttf-google-fonts-20150805.r201-1-any.pkg.tar.xz is corrupted (invalid or corrupted package (PGP signature)).
    Do you want to delete it? [Y/n]
    error: dropbox: signature from “Antergos Build Server (Automated Package Build System) [email protected]” is unknown trust
    :: File /var/cache/pacman/pkg/dropbox-3.8.6-1-x86_64.pkg.tar.xz is corrupted (invalid or corrupted package (PGP signature)).
    Do you want to delete it? [Y/n]
    error: package-query: signature from “Antergos Build Server (Automated Package Build System) [email protected]” is unknown trust
    :: File /var/cache/pacman/pkg/package-query-1.6.2-2-x86_64.pkg.tar.xz is corrupted (invalid or corrupted package (PGP signature)).
    Do you want to delete it? [Y/n]
    error: pamac: signature from “Antergos Build Server (Automated Package Build System) [email protected]” is unknown trust
    :: File /var/cache/pacman/pkg/pamac-2.3.3-3-x86_64.pkg.tar.xz is corrupted (invalid or corrupted package (PGP signature)).
    Do you want to delete it? [Y/n]
    error: failed to commit transaction (invalid or corrupted package)
    Errors occurred, no packages were upgraded.

  • I had a similar problem with his recently, packets that the pacman accused were error “ttf-google-fonts 20150805.r201-1” and “pamac-2.3.3-3-x86_64.pkg.tar.xz”. Managed to install these updates via pamac-updater, I was installing the packages one by one and left it to the end with error packets, at the end I tried to install them and it worked.

    Try this.

  • @cgrif said:

    …I’m having an upgrade failure and wondering what is the easiset way to fix it…

    Seems like @karasu 's suggestion helped to solve the upgrade problem.

    If that’s true, could you mark the topic as [Solved}? They allow easily find a solution for known problems. Thank you.

  • @cgrif Do you think that the topic is [Solved] for you? Could you mark it as such? Thank you.

upgrade failure3 Posts 5Views 2440
Log in to reply
Bloom Email Optin Plugin

Looks like your connection to Antergos Community Forum was lost, please wait while we try to reconnect.