• Antergos Install Error "connection reset"


    I’m currently trying to install Antergos on my machine, and whenever downloading through cnchim, about half-way through it cancels and says “enrr connection reset by peer”

  • Have you edited the mirrorlist?

  • @Rolando-E.-Rolon
    No, how would I do so?

  • Same here. Installation is impossible since the last 24 hours. Very frustrating.

  • @Wehomir Yeah, this is really bad.

  • Any problems with the mirrors?

  • @Wehomir
    I don’t know, I just keep getting connection reset and now I just have a blank harddrive and a live usb, which I cant even install because of this.

  • Same problem here. But I need a running Gnome3/Numix-installation on my laptop soon. Ubuntu Gnome? CentOS? Debian? No, I will wait and hope that Antergos get things fixed soon. Never had such a beautiful Gnome3 system…

  • @Wehomir I’m currently trying to download the KDE4 environment one. I feel your pain.

  • There are two mirror lists, one of Antergos and one for Arch. The CnChi installer uses the Arch mirrors to download the Arch system and Antergos’ mirrors for the rest.
    Now, you must edit those files in order to leave just the mirrors closest to your location. I’m from Argentina, so I used mirrors from Brasil (right next to my country).
    If for some reason the installer uses a mirror for a server on the opposite side of the planet, connections take so long that it times out.
    I no longer have the Antergos OS (using Manjaro now), so I don’t remember the exact location of each file.
    I’ll go check and update this thread.

  • @Rolando-E.-Rolon Alright thanks, I’ve been waiting all day to try to find a solution.

  • Go chase /etc/pacman.d/antergos-mirrorlist (Antergos) and /etc/pacman.d/mirrorlist (Arch)

    In Antergos list, there’s the first of all that is supposed to detect the fastest mirrors, don’t delete that one or install will fail. Actually, don’t delete enything, just add “#” in the beginning of the lines you want to disable.
    Hope this works, even with the fastest mirrors it took like 2 hours to install for me, I wish you better luck. :D

  • This post is deleted!
  • You’re welcome.
    I’ll be around if you need anything else. :)

  • @Rolando-E.-Rolon Nice, I’m still getting the error. ;-;

  • What mirrors do you have enabled?

  • Why bother about mirrors? Let Arch | Antergos find the best 16 ones for your current geographical location:

    sudo reflector --age 8 --fastest 64 --latest 32 --number 16 --sort rate --save /etc/pacman.d/mirrorlist
    

    Any upgrade runs nicely after that:

    $ sudo pacman -Syu
    :: Synchronizing package databases...
     core is up to date
     extra is up to date
     community is up to date
     multilib is up to date
     antergos is up to date
    :: Starting full system upgrade...
    warning: python2: ignoring package upgrade (2.7.9-1 => 2.7.10-1)
     there is nothing to do
    $ 
    
  • @just Yeah, thank you!
    Installation worked for me after I updated the mirrorlist with reflector.
    And I never installed Antergos that fast. :grinning:

  • @just Thanks this solved my problem!

Posts 22Views 5568
Log in to reply