• error installing steam


    I have followed the wiki to the letter I even did a clean install today and did it again still does the same thing. I have all new hardware z97 motherboard xeon cpu 8gb ram ssd gtx 780 so I am not sure why this is not working on basic hardware. And yes I have installed the NVidia driver as per the wiki still get the error.

  • Testing did not know what a back tick was sorry.

  • Pretty sure that the mesa-libgl were in confllct with nvidia-libgl when installing NVidia drivers so during the installation it removes them. Not sure about the otherlibdrm how can I check?

  • Yes, mesa-libgl is for the open driver, you need nvidia-libgl, so that’s ok.
    Check that you have the 32bit version, too:
    sudo pacman -S lib32-nvidia-libgl
    For libdrm:
    sudo pacman -S libdrm lib32-libdrm

  • Oh, check this out, it might help:
    http://askubuntu.com/questions/541343/problems-with-libgl-fbconfigs-swrast-through-each-update

    Check the output of these commands:

    export LIBGL_DEBUG=verbose
    glxgears
    

    Cheers!

  • [sudo] password for toxicode: 
    resolving dependencies...
    looking for conflicting packages...
    :: lib32-nvidia-libgl and lib32-mesa-libgl are in conflict (lib32-libgl). Remove lib32-mesa-libgl? [y/N] 
    
  • [sudo] password for toxicode: 
    warning: libdrm-2.4.62-1 is up to date -- reinstalling
    warning: lib32-libdrm-2.4.62-1 is up to date -- reinstalling
    resolving dependencies...
    looking for conflicting packages...
    
    Packages (2) lib32-libdrm-2.4.62-1
                 libdrm-2.4.62-1
    
  • Okay running the commands above I was able to get steam to launch. Not sure if any games will play as I have none downloaded yet. But now I have a defferent problem it seems to have broke my screen resolution, everything is huge on my screen how do I fix this ?

Posts 28Views 6595
Log in to reply