• error installing steam


    Okay I followed the instructions per the wiki and it does not work for me. Not sure why I keep getting the message error: target not found: steam .
    I have enabled the multilib repository becouse I am on 64 bit. Update multilib then go to install steam and that is when I get the error.

    Toxicode

  • Did you do Syy after enabling multilib?

    I7 [email protected]/32GB Ram/3440 x 1440 + 1440p/EVGA 1080 FTW/512GB SSD/2TB HD/Antergos Base w/ Plasma

  • Yes I sure did !

  • Only comment out the multilib not the multilib-testing correct?

  • @Toxicode

    Correct.

    #[multilib]
    #Include = /etc/pacman.d/mirrorlist
    

    Should be:

    [multilib]
    Include = /etc/pacman.d/mirrorlist
    

    After saving do sudo pacman -Syy

    If multilib shows during the force sync it would have worked correctly.

    I7 [email protected]/32GB Ram/3440 x 1440 + 1440p/EVGA 1080 FTW/512GB SSD/2TB HD/Antergos Base w/ Plasma

  • Wouldn’t it be -Syu and not -Syy?

  • @Toxicode

    Nope, Syu does not force a sync, Syy does. It’s needed the first time to sync multilib.

    I7 [email protected]/32GB Ram/3440 x 1440 + 1440p/EVGA 1080 FTW/512GB SSD/2TB HD/Antergos Base w/ Plasma

  • Can I paste the output of sudo nano /etc/pacman.conf here ?

  • Here is what I commented out.

    #[multilib]
    Include = /etc/pacman.d/mirrorlist

    Then I sudo pacman -Syy

    Then sudo pacman -Syy steam

    And that is when the error comes up.

  • Could it be added throught the package manager steam-native AUR ?

  • @Toxicode said:

    Wouldn’t it be -Syu and not -Syy?

    The best bet is -Syyu, especially after adding a new repo.

    Do it right after enabling [multilib] and without installing any new package. You’ll see a dozen of packages being immediately installed/upgraded.

    Another thing. The [multilib] repo here

    #[multilib]
    Include = /etc/pacman.d/mirrorlist

    remains disabled (commented out by hash # char). Nothing has changed for pacman.

    To summarize

    1. enable the repo

      [multilib]  <-- the initial # is removed
      Include = /etc/pacman.d/mirrorlist
      
    2. force sync and upgrade the system, without installing new packages

      sudo pacman -Syyu
      
    3. try to install steam

      sudo pacman -S steam
      

    Could it be added throught the package manager steam-native AUR ?

    Independently where you’re adding steam from, it requires 32bit-architecture support. [multilib] must be enabled even if steam is added from AUR.

  • Still says error target not found steam ? What could possibly be wrong I uncommented the multilib and did everything just as the wiki said to do and still have this error ? I am stumped as to why this is not working Do I need to install NVidia drivers firt possibly ?

  • Can you post back here the full output of two commands

    sudo pacman -Syyu
    sudo pacman -S steam
    

    It should look like

    $ sudo pacman -Syyu
    [sudo] password for just: *********
    :: Synchronizing package databases...
     core                     121.2 KiB  1036K/s 00:00 [######################] 100%
     extra                   1752.8 KiB  3.09M/s 00:01 [######################] 100%
     community                  2.7 MiB  3.47M/s 00:01 [######################] 100%
     multilib                 126.2 KiB  1088K/s 00:00 [######################] 100%
     antergos                 423.1 KiB   751K/s 00:01 [######################] 100%
    :: Starting full system upgrade...
     there is nothing to do
    
    $ sudo pacman -S steam
    resolving dependencies...
    looking for conflicting packages...
    
    Packages (1) steam-1.0.0.50-1
    
    Total Download Size:   2.59 MiB
    Total Installed Size:  2.61 MiB
    
    :: Proceed with installation? [Y/n] No, thanks. 
    $ 
    

    …Do I need to install NVidia drivers firt possibly ?

    Absolutely not.

  • Thank you all so very much this community is great and I appreciate all the help you have given me. I figured out the problem was an error on my part I did not comment out both lines on the multilib problem solved sorry if I was a pain in the butt lol…

    Toxicode

  • @Toxicode

    :+1:

    I7 [email protected]/32GB Ram/3440 x 1440 + 1440p/EVGA 1080 FTW/512GB SSD/2TB HD/Antergos Base w/ Plasma

  • Okay so steam finally did install but now there is another problem. It will not launch! Now I get this when I type steam into the terminal.
    [[email protected] ~]$ steam
    /home/toxicode/.local/share/Steam/steam.sh: line 161: VERSION_ID: unbound variable
    /home/toxicode/.local/share/Steam/steam.sh: line 161: VERSION_ID: unbound variable
    Running Steam on antergos 64-bit
    /home/toxicode/.local/share/Steam/steam.sh: line 161: VERSION_ID: unbound variable
    STEAM_RUNTIME is enabled automatically
    Installing breakpad exception handler for appid(steam)/version(0)
    libGL error: No matching fbConfigs or visuals found
    libGL error: failed to load driver: swrast

    And when I click on the steam icon absolutely nothing happens. Any suggestions? Please help I do not want to go back to windows …

  • @Toxicode

    Which graphics card are you using? Do you have direct rendering enabled?
    Install mesa-demos sudo pacman -S mesa-demos and check with glxinfo | grep render
    You should see something like this:

    direct rendering: Yes
    

    Also, check that you have the libgl installed (the name of the package might depend on the graphic driver you’re using).

    Cheers!

  • Is it okay to post terminal outputs her ? I know some forums they do not like it .Anyways it says yes direct rendering=yes and below that are a list of open gl renderer strings.

  • @karasu said:

    glxinfo | grep render

    Here is the full output of that command.

    [[email protected] ~]$ glxinfo | grep render
    direct rendering: Yes
    OpenGL renderer string: GeForce GTX 780/PCIe/SSE2
        GL_ARB_compute_variable_group_size, GL_ARB_conditional_render_inverted, 
        GL_KTX_buffer_region, GL_NVX_conditional_render, GL_NVX_gpu_memory_info, 
        GL_NV_compute_program5, GL_NV_conditional_render, 
        GL_NV_path_rendering, GL_NV_pixel_data_range, GL_NV_point_sprite, 
        GL_ARB_compute_variable_group_size, GL_ARB_conditional_render_inverted, 
        GL_KTX_buffer_region, GL_NVX_conditional_render, GL_NVX_gpu_memory_info, 
        GL_NV_compute_program5, GL_NV_conditional_render, 
        GL_NV_path_rendering, GL_NV_pixel_data_range, GL_NV_point_sprite, 
        GL_EXT_render_snorm, GL_EXT_robustness, GL_EXT_sRGB, 
        GL_NV_conditional_render, GL_NV_copy_buffer, GL_NV_copy_image, 
        GL_NV_path_rendering, GL_NV_pixel_buffer_object, GL_NV_polygon_mode, 
        GL_OES_element_index_uint, GL_OES_fbo_render_mipmap,
    
  • Is it okay to post terminal outputs here ?

    It is. Just remember to put the text using three back ticks to start and three more at the end (I already did it for you in your post).

    Back to your issue, have you checked that you have mesa-libgl installed? Check also libdrm.

    By the way, are you using nouveau or nvidia driver?

Posts 28Views 6331
Log in to reply