• [Windows 7][dual boot] EFI partition checklist parameter does not get checked even after creating a required partition


    Hello,

    I started on installing Antergos on my PC, wherein I have a Windows 7 installed. I don’t plan on removing Win7, so selected to dual-boot Antergos.
    I have created partitions for root, /home, /boot/efi and a swap partition. All of them are ext4 partition systems, except for swap.
    For the respective sizes, please refer to the attached screenshot.
    Screenshot from 2015-08-10 04-42-47.jpg
    Can anyone tell me why can’t I proceed with the installation if I have selected one of the paritions as /boot/efi and yet the checklist marker says I haven’t?
    Is there something I have missed out or am I interpreting something wrong?

  • /boot/efi should has fat32 filesystem and not ext4, shouldn’t it?

  • efi partition should be fat32. But if you want to dual-boot with Windows 7, you should have a efi partition if windows 7 is installed in UEFI mode. You have to use same efi partition as windows 7. Just mount that partition but don’t format it!!.

  • I’ll give that a check. Thanks for the quick reply, guys!

  • Hello guys,
    I checked the boot environment for Win7 and it happens so that windows boots in BIOS rather using a UEFI env. (Not a good sign!)
    So if I created a separate EFI partition (FAT32 this time) for Antergos, will it be possible for both the boot partitions to coexist?
    Or should I meddle with the BIOS and try converting it to UEFI, not sure how but there must be a way?
    Any other ideas to tackle this are welcome :)
    Thanks

  • Sorry, what bios does the computer have? Is it Legacy BIOS (simply BIOS) or UEFI?

  • It’s Legacy BIOS.

  • Then you should consider yourself a lucky guy! Why on Earth you’d like to fall into UEFI nightmare?!

    …windows boots in BIOS rather using a UEFI env. (Not a good sign!)

    It’s an excellent sign.

    Win7 boots perfectly on BIOS. It doesn’t require UEFI. Antergos boots perfectly on BIOS and doesn’t need UEFI. No Linux at all needs UEFI.

    …Or should I meddle with the BIOS and try converting it to UEFI, not sure how but there must be a way?..

    Fortunately, there’s no way to “convert” BIOS to UEFI.

    Do not create /boot/efi partition. You don’t need it. It is not needed neither by win7 nor by any Linux. Including Antergos. It is needed on computers with UEFI only.

  • @just Thanks for that positive reply :+1:
    One thing though, I can’t proceed with the installation since the efi partition checklist marker (as seen in the screenshot above) showing me a mandatory condition requiring me to create an /boot/efi partition.
    How do I get around that? Is there an option installation menu to do that?

  • @Sylar said:

    …One thing though, I can’t proceed with the installation since the efi partition checklist marker (as seen in the screenshot above) showing me a mandatory condition requiring me to create an /boot/efi partition.
    How do I get around that? Is there an option installation menu to do that?

    Oops, sorry, forgot about it.

    That is strange. I don’t remember to see EFI checkobx when Antergos installer runs on Legacy BIOS computers here. Will try to re-run the installation now, with antergos-2015.07.01-x86_64.iso stable release to confirm that.

    Did you create /boot/efi partition by hand, before starting the installation? If so, maybe its presence fools the installer somehow? If you have a backup of the entire disk (Clonezilla), I’d suggest to delete /boot/efi partition and retry the Antergos installation.

  • @just said:

    …Will try to re-run the installation now, with antergos-2015.07.01-x86_64.iso stable release to confirm that.

    Yes, can confirm that now. As expected, there’s no EFI checkbox in Cnchi running on the computer with Legacy BIOS and without preexisting /boot/efi partition on the disk - the absolutely correct installer’s behaviour

    antergos-no-efi.png

    Sorry for self-quoting.

  • @just said:

    Did you create /boot/efi partition by hand, before starting the installation? If so, maybe its presence fools the installer somehow? If you have a backup of the entire disk (Clonezilla), I’d suggest to delete /boot/efi partition and retry the Antergos installation.

    I created an ext4 partition for that (before knowing that a FAT32 would be required) and then set it as /boot/efi during the installation itself.

  • @Sylar said:

    …I created an ext4 partition for that (before knowing that a FAT32 would be required) and then set it as /boot/efi during the installation itself.

    Delete it and retry the installation. In a clean situation there’s no EFI checkbox in Cnchi - see my reply 2 posts above this one.

  • @just Alright. Thanks. I’ll try that one tonight :+1:

  • Update: I tried installing again after deleting that partition, but to no avail. Got the EFI in the checklist there. So, I checked into my BIOS and found out that apparently the motherboard supports both the Legacy and UEFI BIOS. I’ve tried setting most of the relevant options there to support only Legacy BIOS, but that didn’t make a difference.
    Will continue the probing. It’s taking some time since I’m not familiar with a lot of those options.

    P.S: Sorry for the delay, I only get to do this when I’m off work.
    P.P.S: Any ideas to resolve this are utmost welcome :blush:

  • @Sylar said:

    …So, I checked into my BIOS and found out that apparently the motherboard supports both the Legacy and UEFI BIOS…

    So the previous answer - “It’s Legacy BIOS” - was not correct. It’s UEFI one.

    A true Legacy BIOS doesn’t even mention UEFI. Legacy BIOS knows nothing about UEFI. It may not be “converted” into UEFI, in no way.

    Only UEFI bios may work in both [UEFI] and [Legacy] boot modes. The boot mode is set by entering in bios setup utility during boot. The bios setup utility is usually entered by pressing F2 if you boot in [Legacy] mode, or by using OS- and computer’s make- and model-specific software tools if you boot in [UEFI] mode.

    …I tried installing again after deleting that partition, but to no avail. Got the EFI in the checklist there…

    I made a second installation to test your case. This time on a computer with UEFI. As UEFI is needed only by Win8+ crap, which is not used here, UEFI bios on this computer is set to boot in [Legacy] mode.

    The rest remains the same as during the first installation (on true Legacy BIOS computer). The stable antergos-2015.07.01-x86_64.iso release is used. The disk has no /boot/efi partition.

    Cnchi 0.8.151 has no EFI checkbox even on UEFI computer:

    antergos-no-efi-2.png

    I’m out of ideas, at this point.

  • …No, not yet. There’s another one :smile: .

    'Cause I have no wish to study Cnchi’s source, let’s simply make two temporarily assumptions about the installer:

    • it is not smart enough to distinguish between win7 and win8+
    • if it sees any windows installed, it checks for /boot/efi presence on the disk

    Remember, win7 (and below) doesn’t require /boo/efi. Win8 (and above) does require it.

    You have win7, but Cnchi sees simply a generic “windows”. So it wants to find /boot/efi on the disk, with the correct filesystem. If no /boot/efi is present, or with a wrong filesystem, than the EFI check can not be passed.

    The difference between your and mine computers is that none of mine have a windows on them. So Cnchi doesn’t do EFI check. Probably bios type (Legacy BIOS or UEFI) has no importance for Cnchi.

    In such a case the solution could be

    1. Create a (small) /boot/efi partition. 100 M for it should be enough.

    2. Format it with fat32.

    3. Retry the installation.

    4. Allow Cnchi to use /boot/efi how it wants. Follow its (eventual) suggestions.

    Just remember that I have neither windows nor grub 2 on my computers, so can’t test this suggestion. The risk is yours.

    Good luck.

  • @just Thanks for that suggestion, it’s the only thing that I can do right now (other than trashing windows).
    I tried installing by setting the BIOS boot option as Legacy only for all settings but then it wouldn’t detect the bootable USB and would proceed straight to Windows. The only way I could get into the Live Antergos was by setting the boot mode to UEFI and Legacy
    I’ll definitely try this one and get back to you.

  • you could go into the bios and check the boot list.

    if your mobo is bios AND uefi compatible it should show your usb twice, one with a uefi tag and one without.

    if not that means the usb is configured to be uefi only if thats the case reply i have something you could try

  • With my BIOS, when it shows the devices list to boot, it distiguish both modes UEFI and Legacy.
    In my menu, it would look like this:

    -UEFI SanDisk CruzerBlade (8Gb)
    -SanDisk CruzerBlade (8Gb)

    You shouldn’t start the UEFI session of Antergos, because it will default to install that way. I suggest you change your settings in BIOS to boot from both UEFI and Legacy, hoping that it will provide both methods.
    One more thing. Don’t do separate partitions unless you are pretty sure of what kind of software you’ll use. It is better to just use a big one for the root (I’d say 100Gb is enough), and 4Gb for swap. Whatever media you download, you can move it to a Windows partition later (if you change Linux distros frecuently), or better yet, directly store everything in the Windoze partition so you can access it from both OS’s at any time.
    Cheers.

dual boot21 partitioning8 bootefi6 windows72 Posts 24Views 5942
Log in to reply