• [SOLVED]Destroyed Grub


    I need help. I have been attempting to repair windows for weeks now. I won’t get into that except to say that Windows is the bane of my existence. Thankfully, I have Antergos, which I love. Here’s the problem. I screws up the MBR (Master Boot Record) and that, in turn, destroyed my grub. Thankfully, I had a linux boot disc but I don’t believe there’s an option to repair my grub. I may recheck the disc again. Anyway, I can’t boot into Antergos except via the disc because my original file has been overwritten. Is there a way to repair it? Is there a repair tool on the Antergos Live DVD? Or is there another easy peasy way of fixing this issue so I can see my windows 8 and my antergos distros at boot time?

  • Actually, yes. From the command line, you can call grub configuration. I don’t know the reach of it, so I won’t speak about it either.
    From the live CD, you can download a repair tool like Super GRUB Disk2 utility (http://www.supergrubdisk.org/). In that page there’s also Rescatux, but the file is huge and not necessary. Supergrubdisk, is really small (just a couple of Mb), and has plenty of options. It searches OS’s in your disks, and let you boot any of them. Also, it can build the grub again with all those OS’s it finds ( I believe this is what you need). Just head over the page, look for it and instructions to make a bootable USB, and come back if you have any doubts. Also, there’s plenty of videos about a previous version of grubdisk on YouTube.
    Best luck. Cheers. :)

  • Rolando, thanks. I actually found it before your post. It was so darn easy I was jumping up and down. Everyone should have a copy on a flash drive or a cd disc.

    http://www.supergrubdisk.org/rescatux/

  • You’re welcome.
    And yes, is a super handy tool, but you don’t notice untill the time you need a rescue.
    i’m glad you solved your problem.
    Regards. :)

grub224 grub72 boot loader8 Posts 4Views 1413
Log in to reply