• Smb/cifs mount shows twice


    I created a line in FSTAB (with the help of los.0.logs) to mount a smb share on startup. It works great but it did not show up as a link in pcmanfm. Hmmm I thought, what happens when I connect a USB device, it shows up as a folder in /run/media/<username>. What if I told the mount command to mount it overthere. Bingo! it worked. I didn’t even have to create the folder upfront. However, it is now showing twice as a link in pcmanfm. One as a device, two as a folder (both with the eject button).
    If I execute mount without parameters I see two mounts with diferent ID’s. Maybe this is normal behaviour and should I consider an other option but which?

    Anyone thoughts on this?

    Cheers,

    BootZ

    Antergos: funny name, serious distro

  • I created a line in FSTAB (with the help of los.0.logs) to mount a smb share on startup. It works great but it did not show up as a link in pcmanfm. Hmmm I thought, what happens when I connect a USB device, it shows up as a folder in /run/media/<username>. What if I told the mount command to mount it overthere. Bingo! it worked. I didn’t even have to create the folder upfront. However, it is now showing twice as a link in pcmanfm. One as a device, two as a folder (both with the eject button).
    If I execute mount without parameters I see two mounts with diferent ID’s. Maybe this is normal behaviour and should I consider an other option but which?

    Anyone thoughts on this?

    Cheers,

    BootZ

    Antergos: funny name, serious distro

  • If you use pcmanfm to navigate into the folder that is set as the mount point in fstab, does it show it under devices afterwards? I am thinking the reason it doesn’t show at first is because there hasn’t been an attempt to use it. Systemd is set to auto mount on “first use”. I am not too familiar, does pcmanfm allow you to place bookmarks in the sidebar? A solution may be to add a bookmark, which would make sure it touches that folder every boot.

    Regards,

  • @“lots.0.logs”:30ajbzih said:

    If you use pcmanfm to navigate into the folder that is set as the mount point in fstab, does it show it under devices afterwards? [/quote:30ajbzih]

    Not observed. I creted a folder in my home and changed the fstab line into:

    //192.168.178.27/share /home/bootz/Popcorn cifs x-systemd.automount,username=xxxx,password=xxxx,sec=ntlm  
    > 
    

    So I removed the first auto in front of x-systemd.automount. It shows as a “device” in pcmanfm but still twice. I think it is something in systemd.

    Antergos: funny name, serious distro

  • It seems now that you bypassed pcmanfm to get the drive mounted it has decided it wants to mount it properly now LOL. Two options:

    1. Tell pcmanfm not to auto mount removable drives (Edit>Preferences)
    2. remove systemd from the fstab entry.

    If it were me, I’d set pcmanfm to not worry about mounting drives and handle them via fstab and mount myself.

    I almost forgot, there is a 3rd option. The package “gnome-disk-utility” is actually quite useful in cases like this. It will create fstab entries automatically and allows you to revise the settings. If you want to use it, best start fresh by removing current fstab entry.

    Cheers!

Posts 5Views 1345
Log in to reply