• Keboard/Mouse USB / P/S 2 Not working on boot.


    Hello there!.
    I have asked help in the Arch forum and they got rid of me really soon…XD
    So, here is the issue I am facing:

    I have a terrible problem here. As suggested in other thread, I changed XHCI to enabled, since I wasn’t able to shutdown/suspend/reboot without falling into an irrecoverable freeze, and all cheatcodes and workarounds out there didn’t solve my problem either. But now I can’t use any peripherals after boot. I edited my BIOS about 12 times after that and tried pretty much everything.

    Everything works fine untill LightDM starts and nothing responds, so I can’t login.
    I’m using Antergos, and tried two keyboards (USB and P/S2) and USB mouse, but nothing. Have anyone here experienced something similar?

    By the way, I have an ASUS motherboard and the BIOS utility I would say it seems that it was made for UEFI Windows only (I really hate Microsoft for that).

    One more question. The only distro that gets to shutdown properly is Fedora 21. I know it uses Linux 3.19 kernel. I tried downgrading my kernel and headers to that and even lower versions but no luck. Do you guys know what other modules and/or packages I should roll back?

    Thanks in advance. big_smile

  • Hi,

    Just so I understand, you activated XHCI, usb stopped working, and when you set XHCI to disable USB still does not work?

    By the way, I don’t see how this can affect your PS/2 Keyboard… ¿?

  • Yes, that’s exactly what happened.

    I tried to revert it, but as soon as LightDM shows up, keyboard and mouse stop responding. I tried everything, EHCI, smart auto, auto, disabled. I enabled full USB initialization on boot, everything. And no luck.

    I have Win7 on a separate disk, and it works just like usual. Antergos live CD works fine too (except for the shutdown issue).

  • I’m really out of ideas here. Let’s hope somebody else can help.

    Cheers!

  • Gracias igual.

    Un saludo. :D

usb55 mouse41 ps21 keyboard34 boot150 Posts 5Views 1264
Log in to reply