• HP Deskjet 1510 - scanning issue


    Hey everyone, great to be here, have a bit of an issue with my scanner.
    After going to a similar ordeal like here: http://forum.antergos.com/topic/2090/trying-to-add-hp-printer-after-fresh-installation/5 I managed to get my printer to print, but now it doesn’t get recognized by the system as a scanner. After I open XSane or SimpleScan, they don’t even recognize the scanner is there and go automatically to my Lenovo webcam.
    I didn’t have this problem on the previous distros (most recently I was on Manjaro and went back to Ubuntu for a while before coming to Antergos. The printer is recognized as a device in the settings, I’ve tried rebooting… I’m just stuck.

  • @judd Cheers Judd, didn’t realize I linked to a wrong forum post, I was talking about that topic you linked to and fixed my link.
    Also, my printer isn’t a wireless one, I’m connecting through a USB cable.

  • Hi,

    1. What does the command sane-find-scanner return?
    2. Are you in the scanner group? (this might not be necessary anymore, but it doesn’t hurt).
    3. Check that when running lsusb with your user (not root), you see the scanner
    4. Have you added hpaio to your dll.conf? echo "hpaio" >> /etc/sane.d/dll.conf

    Check the Arch wiki: https://wiki.archlinux.org/index.php/SANE

    Cheers!

  • @karasu

    1. Here’s the printscreen of the command result:
      answer-1.png
      You can see I tried what the first result suggested and that it only found my web camera.
    2. Here on the forum? No, I’m still getting to know my way around.
    3. Here’s the readout:
      answer-3.png
      It’s recognizing the hardware, doesn’t seem to recognize the scanner part. Just tried with xsane, still doesn’t recognize it.
    4. I did that right now, here goes nothing… AND IT WORKS! Finally it recognizes the scanner part, both in xsane and simplescan! Thanks a lot man, decided to keep the long answer since I already typed so that people who have a similar issue can learn smth as well. :+1:
      Like I said before, best forum ever!
  • @pasanov said:

    @judd Cheers Judd, didn’t realize I linked to a wrong forum post, I was talking about that topic you linked to and fixed my link.
    Also, my printer isn’t a wireless one, I’m connecting through a USB cable.

    Sorry:relaxed:

scanning2 hpdeskjet1 printer34 Posts 6Views 1644
Log in to reply