• Poor video performance on Sony Vaio P with Antergos (Intel 500 GMA)


    I tried to revive my old Sony Vaio P VPCP110KL with antergos, all is working well, but the video performance is very poor, even on Youtube 360p videos :(

    I know the GMA500 is a very poor performance card, but there is no chance to tweak something? or install propietary drivers?

    Insert Code Here[[email protected] ~]$ lsmod | grep gma
    gma500_gfx            163840  2
    drm_kms_helper         90112  1 gma500_gfx
    drm                   233472  4 drm_kms_helper,gma500_gfx
    i2c_algo_bit           16384  1 gma500_gfx
    i2c_core               45056  7 drm,i2c_isch,drm_kms_helper,i2c_algo_bit,gma500_gfx,v4l2_common,videodev
    video                  20480  1 gma500_gfx
    
    

    Antergos Gnome - Lenovo G4070
    Antergos XFCE (Ex-Mate) - Dell D630
    Antergos Cinnamon - Asus E-11
    Puppy Linux Precise 5.7.1 - Asus 701 EEEpc
    Puppy Linux Lxpuptahr USB live - All machines

  • Hi,

    You can try to use modesetting…

    Create a new file: /etc/X11/xorg.conf.d/20-gpudriver.conf

    And add this:

     Section "Device"
        Identifier "gma500_gfx"
        Driver     "modesetting"
        Option     "SWCursor"       "ON" 
     EndSection
    

    There’s also a troubleshooting section in Arch’s Wiki, check this out:
    https://wiki.archlinux.org/index.php/Poulsbo

    Cheers!

  • Thank you Karasu! i know this card is a pain in the… on Linux, because the chipset is not from Intel.

    Antergos Gnome - Lenovo G4070
    Antergos XFCE (Ex-Mate) - Dell D630
    Antergos Cinnamon - Asus E-11
    Puppy Linux Precise 5.7.1 - Asus 701 EEEpc
    Puppy Linux Lxpuptahr USB live - All machines

  • @karasu , veo que eres de Barcelona y hablas español; la verdad es que esta tarjeta es maldita en el mundo GNU/Linux, el chipset fue creado por una empresa que tiene el driver de codigo cerrado, no se si mantener este equipo con una distro, o volverme a Windows en el, que me recomiendas tu? Saludos desde Chile :) (Me encanta Antergos!)

    Antergos Gnome - Lenovo G4070
    Antergos XFCE (Ex-Mate) - Dell D630
    Antergos Cinnamon - Asus E-11
    Puppy Linux Precise 5.7.1 - Asus 701 EEEpc
    Puppy Linux Lxpuptahr USB live - All machines

  • Hola,

    Sí, de Barcelona xD

    Bueno, pues tu única opción es usar el driver gma500 que estás utilizando, con el modesetting en Xorg como te puse antes. Lo has probado? No mejora?

    Puedes poner el log de Xorg? (debería estar en /var/log/Xorg.0.log

    Por cierto, ya avisan que en pantalla completa es un total desastre.

    Saludos!

  • Hice lo que me dijiste, pero la verdad no mejora casi nada :( , creo que volvere a Windows 7 en ese netbook, no hay caso.

    No soy el unico que se queja en todo caso:

    https://communities.intel.com/message/62562

    Antergos Gnome - Lenovo G4070
    Antergos XFCE (Ex-Mate) - Dell D630
    Antergos Cinnamon - Asus E-11
    Puppy Linux Precise 5.7.1 - Asus 701 EEEpc
    Puppy Linux Lxpuptahr USB live - All machines

500gma1 vaiop1 Posts 6Views 1517
Log in to reply