• White Lock Screen


    I installed Antergos last week, picking gnome as my DE. After installing, I installed the nvidia drivers and ran updates. I think the lock screen worked initially on install, but after the updates my lock screen is white and I can’t log back in.

    I am running LightDM, the default that comes with the installer.

    Any Ideas?

    A few possible relevant details: The white screen was super low res. After adjusting the default Grub resolution, the lock screen followed that updated resolution.

  • Hi,

    just a thought : have you set the lock screen parameters with the Light Lock Setting application and deactivated any standard Gnome features like black screen in Privacy and Power modules of Gnome settings ?

  • @squid-f said:

    just a thought : have you set the lock screen parameters with the Light Lock Setting application and

    No I have not. Is that the default lock screen in antergos? Does it not play nice with some gnome features?

    deactivated any standard Gnome features like black screen in Privacy and Power modules of Gnome settings ?

    Come to think of it, I might have switched on the Screen lock in the gnome settings while trouble shooting/screwing around.

    Comparing the settings in gnome settings and light locker settings, they look fairly redundant. Could I have possibly turned on a second locking mechanism? If so, any idea where I can look to reconcile this?

  • I found this in the logs:

    ** (light-locker:2236): WARNING **: Couldn't register with accessibility bus: Did not receive a reply. Possible causes include: the remote application did not send a reply, the message bus security policy blocked the reply, the reply timeout expired, or the network connection was broken.
    
    ** (light-locker:2236): WARNING **: screensaver already running in this session
    

    Any ideas?

  • @bcomnes Hi,

    By experience, if you use Light DM, it is better not to use the Gnome features.
    Not sure it will solve your issue but it is worth trying to set the parameters you want with Light Lock Setting (default lock screen with Light DM as far as I know) and to remove any Gnome lock screen features in Privacy and Power modules.

  • I have turned off all (known) gnome settings, and disabled and re-enabled light-locker in the light locker settings pannel:

    Screenshot from 2015-08-05 14-28-41.png

    Screenshot from 2015-08-05 14-28-24.png

    Screenshot from 2015-08-05 14-28-17.png

    Screenshot from 2015-08-05 14-28-02.png

  • Hi,
    okay, it is exactly what I meant. So, what is the result now ? Does it work ?

    If not,then, it might be connected to your driver update. In that case, the only advice I can give you is to provide us with your hardware specifications and to search the Arch wiki and forum as well, focusing on your video card.

  • Sorry, wasn’t clear. Yeah even after setting these things back, it still just goes white when I lock the screen.

    Is it a matter of uninstalling the nvidia drivers to roll back? Or do I also need to re-install some older driver?

  • @bcomnes Hi

    I am not in the video card thing but if you think it was working before, it is worth reverting the process by uninstalling the suspected driver. If it works again, we will know where to look at !

    What you could do is to run and report the output of the command lspci -k | grep -A 4 -E "(VGA|3D)" before uninstalling and after. It will give us information on your video card setup.
    Then, there is also a this interesting link you might want to look at : https://wiki.archlinux.org/index.php/NVIDIA

  • I switched to GDM following the instructions found in http://forum.antergos.com/topic/1944/bug-unable-to-lock-autolock-antergos-gnome-on-alienware-m11x-r2/2

    And that seems to be working fine for now. It would be rad to get Light-DM working later though.

    @lots.0.logs said:

    Full and complete screen locking is currently not possible without switching to GDM. We’re working on a permanent solution. In the meantime if having your screen locked is important (and simply displaying the greeter won’t be enough to deter threats) then we recommend that you install GDM:

    sudo pacman -Rcc lightdm
    sudo pacman -S gdm
    sudo systemctl -f enable gdm
    
  • Current video driver:

    bcomnes ~ $ lspci -k | grep -A 4 -E "(VGA|3D)"
    02:00.0 VGA compatible controller: NVIDIA Corporation GK104GL [Quadro K5000] (rev a1)
    	Subsystem: NVIDIA Corporation Device 0965
    	Kernel driver in use: nvidia
    	Kernel modules: nouveau, nvidia
    02:00.1 Audio device: NVIDIA Corporation GK104 HDMI Audio Controller (rev a1)
    
  • @bcomnes Good to remember indeed that switching to GDM is the fix currently.
    Myself, I am now on KDE and I use light DM without any issue with the lock screen. I remember though that I switched to GDM when I was on Gnome.
    Let us hope a solution will be found as @lots-0-logs said.

  • Greetings,

    I can confirm I was having the same issue with Gnome 3.16 using an nvidia video card and proprietary nvidia drivers. I moved to gdm and it addressed my issue as well.

    Video card:

    $ lspci -k | grep -A 4 -E "(VGA|3D)"
    05:00.0 VGA compatible controller: NVIDIA Corporation GM107 [GeForce GTX 750] (rev a2)
    	Subsystem: Gigabyte Technology Co., Ltd Device 3642
    	Kernel driver in use: nvidia
    	Kernel modules: nouveau, nvidia
    05:00.1 Audio device: NVIDIA Corporation Device 0fbc (rev a1)
    

    Video drivers:

    $ pacman -Q nvidia
    nvidia 352.41-1
    

    Solution:

    $ sudo pacman -Rcc lightdm
    $ sudo pacman -S gdm
    $ sudo systemctl -f enable gdm
    

    @bcomnes and @lots.0.logs, thank you for the help!

Posts 13Views 2930
Log in to reply