• Stalonetray is blank


    Hey Antergos users,

    I’m on arch setting up a custom desktop and stuck at the system tray.
    The plan is to use stalonetray and cairo-dock on desktop.

    Stalonetray is giving me problems, it just shows up a blank line and no icons, also, no errors in terminal.

    I have systray applications running, they do show up when I use xfce4-panel or gome-panel or tint2 but not in stalonetray, same is the case with cairo-dock’s notification area applet, its blank.
    Although, cairo-dock’s systray is really bad so I dont really care about it.

    Here’s what shows up when I run stalonetray.
    stalonetray.png

    Here’s my .stalonetrayrc

    background "#777777"
    decorations none
    dockapp_mode simple
    fuzzy_edges 0
    geometry 3x1+30+30
    grow_gravity NE
    icon_gravity NW
    icon_size 20
    kludges force_icons_size
    log_level err
    max_geometry 0x0
    no_shrink false
    parent_bg false
    scrollbars none
    skip_taskbar true
    sticky true
    tint_color white
    tint_level 0
    transparent false
    vertical false
    window_layer normal
    window_strut auto
    window_type dock
    xsync false
    

    I could even use tint2 instead of stalonetray if its possible to only display systray on it.

    Archlinux x64

    AMD A4-3305M Processor
    6GB RAM
    1GB+512MB Hybrid AMD GPU

  • Perhaps you could just make the panel smaller as small as just the system tray. Then you can put the panel at the bottom, right, left or top.

  • @Yash Hi,
    you force icon size smaller than default (24) , acccording to the man page of stalonetray.
    I don’t know whether it is the issue but it might be a starting point…

    Other link that you might know already https://wiki.archlinux.org/index.php/Stalonetray

    Good luck

  • Thanks @herbie and @squid-f

    But Stalonetray didn’t work with forced smaller icon size, still the same.

    I found out cairo-dock’s systray applet after detached from dock works just what I wanted it to work like. also, after detached, systray icons show up (idk how) xD But the problem is solved!

    Cheers! 😄

    Archlinux x64

    AMD A4-3305M Processor
    6GB RAM
    1GB+512MB Hybrid AMD GPU

Posts 4Views 1550
Log in to reply
Bloom Email Optin Plugin

Looks like your connection to Antergos Community Forum was lost, please wait while we try to reconnect.