• Package Dependancy Question.

    For the past few day or so, I’ve been getting the message below about a dependency:

    :: Starting full system upgrade...
    resolving dependencies...
    looking for conflicting packages...
    error: failed to prepare transaction (could not satisfy dependencies)
    :: lib32-libgphoto2: requires libgphoto2=2.5.7

    When I view the version I have installed, it looks like it matches:

    $ sudo pacman -Q libgphoto2
    libgphoto2 2.5.7-1
    $ sudo pacman -Q lib32-libgphoto2
    lib32-libgphoto2 2.5.7-1

    Looks like version is correct to me… I even looked on the Arch Rollback Machine and there is no “2.5.7” its just “2.5.7-1” that I have.

    What am I missing?

  • Join the club. I’m having a similar problem but mine is for lib32-libdn. It’s 1.32-1. When I click on apply in the update manager I get the following error message.

    cannot resolve “libidn>=1.32”, a dependency of “lib32-libidn”

  • cannot resolve “libidn>=1.32”, a dependency of “lib32-libidn”
    The same problem here. Any suggestions what to do?

  • @Anastasiya-Miloslavskaya I think we need to create a separate thread since there are two of us with the same error.

  • @reefland The system upgrade is trying update libgphoto2 to 2.5.8-1 but this breaks the lib32 dependency which requires 2.5.7 exactly. lib32-libgphoto2 has not been updated in AUR and appears to be orphaned, it has been flagged out of date.

    @linux_mark libidn-1.32-1 is in the testing repository, it appears you have the multilib-testing repo enabled, maybe worth checking you have the testing repo enabled too.

  • @ial - thanks - I tacked on an ignore such as

    sudo pacman -Syu --ignore libgphoto2

    And that got me processing updates again.

Posts 6Views 1502
Log in to reply
Bloom Email Optin Plugin

Looks like your connection to Antergos Community Forum was lost, please wait while we try to reconnect.