• How to restore grub after upgrade to win 10?


    Hello
    I upgraded my 7 to 10 yesterday and grub is missing now.
    How can I restore it?

  • I had the same problem with windows 8 months ago and I solved with boot-repair-disk.

  • boot-repair-disk did not work.

  • I have this problem too and boot-repair-disk dint work D: … I upgraded from Win8.1 Pro to Win10 Pro… Any ideas?.

  • Hi all

    Does it mean you boot now automatically on Windows but Antergos is still installed on another partition ?

    At first, have you then checked your BIOS setup to be sure than the boot is not done on the Windows Boot Manager but on Antergos_grub ?
    I don’t know whether all BIOS work like that but on mine I have this choice on the boot option priorities.

  • in my case grub was deleted from mbr.
    I need restore it.

  • @Strangiato Ok. If you boot on a flash drive with Antergos on it for instance, do you see the partitions where Antergos is installed on your PC ? Are you able then to locate the files /etc/default/grub and /boot/grub/grub.cfg ?

    EDIT: to locate those files on your disk, one way is to open gnome file manager after booting on your flash drive and then to click on the volume where your Antergos root folder is on your hard drive ; it will be mounted. Then, open a terminal window and type the command

    cd /run/media/antergos
    ls
    

    The output of the ls command should be a long string of numbers and letters (like f22e1cb5-5ff2-…). It is the name of the folder where Antergos is installed.
    If you enter in this folder you will find the tree your are familiar with (etc, boot, home…).

  • In addition, here are interesting links :
    http://www.dedoimedo.com/computers/grub-2.html
    https://wiki.archlinux.org/index.php/GRUB
    http://news.softpedia.com/news/Windows-8-Update-Might-Delete-GRUB2-and-Set-UEFI-to-Secure-Boot-434009.shtml

    The last article explains that Windows 8 (and newer ?) might erase Grub AND change BIOS setup ! Freaky !

  • Yes, my antergos partition is still here and I can find /etc/default/grub and /boot/grub/grub.cfg files. How restore grub now?
    sudo-grub install /dev/sda did not work. I got grub-rescue after restart.

  • @Strangiato
    Following the link to the Arch wiki in my previous post, there is a method provided to install GRUB to an USB stick. My idea is to use it but pointing to the partition of your hard drive where Antergos is installed. I have never done this, so, it is safer you back-up your data if not done yet in case you will have to re-install your PC. I would be very sorry if it is the case but it is a risk.

    So, here we go.
    1/Boot on your Antergos flash drive
    2/Assuming Antergos is installed on your hard disk on the partition /dev/sdy1 or your /boot is on /dev/sdy1, run the following replacing sdy1 and sdy by your locations (the command fdisk -l should help you) :

    sudo mkdir -p /mnt/usb 
    sudo mount /dev/sdy1 /mnt/usb
    sudo grub-install --target=i386-pc --recheck --debug --boot-directory=/mnt/usb/boot /dev/sdy
    sudo grub-mkconfig -o /mnt/usb/boot/grub/grub.cfg
    

    3/Restart your laptop and boot on your hard disk . You mght have only Antergos as options and you might have both an entry for your flash drive and your hard disk. If it is the case, after logging in on Antergos on your hard disk, run :

    sudo grub-mkconfig -o /boot/grub/grub.cfg
    

    Really hoping it will solve your issue !

  • I hope this can help. It is something I found on how to restore our own bootloader via the Windows installation. It refers to the case that the grub is normally installed in the efi partition, but simply not used and certainly not in the case of absence of installation or improper installation of grub.
    The first movement we do is to check from the bios if secure boot is still disabled (it should be) and from the Windows Settings Fast Boot is disabled (it should also be), like this:
    widows settings.png
    If not, we disable them and try rebooting again, as it is quite possible that the problem was solved and the grub has reappeared.
    If the problem persists, then, we load the Windows and open an administraror command prompt, according to the figure below (to open the context menu take the mouse to the bottom left of the screen and click the right mouse button):
    windows2.png
    Type the commandl
    bcdedit /set {bootmgr} path \EFI\ubuntu\grubx64.efi
    and press enter.
    If all goes well, we will get a message that our command was executed successfully and on reboot we will have our grub restored.

    ATTENTION: The command applies to restoring the Ubuntu grub. Change it accordingly.

    ****I don`t use Windows, so I cannot guaranty if this solution works or not!:innocent:

    1.Antergos Linux KDE plasma / Gnome 2.Ubuntu 17.10 64bit Unity
    Intel Core2 Duo CPU P8400 2.26GHz‖ RAM 3908 MiB ‖ Dell Inc. 0F328M - Dell Inc. Latitude E6500
    Intel Mobile 4 Series Chipset Integrated Graphics [8086:2a42] {i915

  • my motherboard has no uefi feature.

  • Thanks for the replies, i have Antergos root, /home and /boot separately and intact, but Windows 10 just do the mbr thing screwing up the grub init, so i will try the sugestions tomorrow (heavy work day today) and feedback the results… Thanks! :D

  • I have also found this “How to Restore Arch Linux Boot After Installing Windows” thing posted in the Google+ Arch Linux community…

    https://www.jeremymorgan.com/tutorials/linux/how-to-restore-arch-linux-after-installing-windows/?utm_content=buffer75fad&utm_medium=social&utm_source=twitter.com&utm_campaign=buffer

    1.Antergos Linux KDE plasma / Gnome 2.Ubuntu 17.10 64bit Unity
    Intel Core2 Duo CPU P8400 2.26GHz‖ RAM 3908 MiB ‖ Dell Inc. 0F328M - Dell Inc. Latitude E6500
    Intel Mobile 4 Series Chipset Integrated Graphics [8086:2a42] {i915

  • @anarch This tip solved my problem! :smile:

    Thank you very for all replies.

Posts 15Views 8617
Log in to reply