Hi all,

I was looking about a solution for this, because it was happening with the last version included in the ISO (01.07.2015).

When I’ve tried to install in a Z3736 I have this problem, and nobody said nothing, but when cnchi is checking in the install process, when the download of all packages has finished, always is returning an error (cnchi could not continue). If you take a look into logs always is the same thing, sha256 check is failing with 33 code error.

I have tried changing repository manually on pacman.conf, redownloading it again, but always there are more packages with the same error. No mather if the installation is launched in the 01/07 or today, all days are returning the same error.

It’s weird because this error is critical, you MUST be connected to internet because there is no alternative to install antergos offline and now there is no choice to use other tool different of cnchi.

I like antergos, it’s very useful, but this tool… always have bugs like this and in the next revision is solved. I was waiting for a fix, but nobody is telling nothing related to this error (one person said the same thing in the forum some days before, but this user said that it was fixed for him, but I can say that NO for me).

This trace is part of this error, but you can redownload this package and get the same error with others, so the problem is the download process.

[2015-07-30 14:26:40] [pac] DEBUG: checking sha256sum for /install/var/cache/pacman/pkg/pulseaudio-alsa-2-3-any.pkg.tar.xz
[2015-07-30 14:26:40] [pac] ERROR: returning error 33 from check_validity : paquete no válido o dañado
[2015-07-30 14:26:40] [pac] ERROR: No se puede finalizar transacción alpm: transaction failed, pm_errno 33 (paquete no válido o dañado), []
[2015-07-30 14:26:40] [pac] DEBUG: Lanzando transacción alpm...
[2015-07-30 14:26:40] [pac] DEBUG: Transacción alpm completa.
[2015-07-30 14:26:40] [process] ERROR: 'No se pueden instalar los paquetes necesarios. Cnchi no puede continuar.'
[2015-07-30 14:26:40] [process] ERROR: Traceback (most recent call last):

[2015-07-30 14:26:40] [process] ERROR:   File "/usr/share/cnchi/cnchi/installation/process.py", line 166, in run
    self.run_installation()

[2015-07-30 14:26:40] [process] ERROR:   File "/usr/share/cnchi/cnchi/misc/misc.py", line 175, in helper
    return func(*args, **kwargs)

[2015-07-30 14:26:40] [process] ERROR:   File "/usr/share/cnchi/cnchi/installation/process.py", line 362, in run_installation
    self.install_packages()

[2015-07-30 14:26:40] [process] ERROR:   File "/usr/share/cnchi/cnchi/installation/process.py", line 724, in install_packages
    raise InstallError(txt)

[2015-07-30 14:26:40] [process] ERROR: misc.misc.InstallError: 'No se pueden instalar los paquetes necesarios. Cnchi no puede continuar.'

[2015-07-30 14:26:40] [show_message] ERROR: 'No se pueden instalar los paquetes necesarios. Cnchi no puede continuar.'

cnchi_log.zip

Thanks for all work, Antergos Team rocks and I have to say that it’s the unique distro that I have test in a tablet and it’s working the touch panel in live version and working fine, but really I’m thinking it’s incredible that nobody say nothing about this huge bug and Antergos distro cames with a no easy way to install offline (no without assistant, I want to say offline with the packages included in the iso, a base system) or a console assistant like previews versions, where are they?