• Nvidia Optimus issue


    Hi all,

    First of all, thank you for this great distribution and community, both are amazing. Now the reason I am asking for your help is because I can’t get work my nvidia card. A few months ago it used to work fine (with bumblebee), but recently stopped working.

    I have a lenovo y410p with an intel graphics card as well as a nvidia (GeForce GT 750M). I installed the packages nvidia, nvidia-utils, bumblebee, bbswitch following the instructions from the archlinux wiki.

    The error that prompts is the following:
    [ERROR]Cannot access secondary GPU - error: [XORG] (EE) systemd-logind: failed to get session: PID 994 does not belong to any known session
    [ERROR]Aborting because fallback start is disabled.

    I have followed the troubleshooting section of the wiki and few other posts with no success. I would really appreciate some help to solve this issue.

    Thank you!

  • Hey! thanks for your fast response! the sad thing is that I already tried that with no luck :(

  • Do you boot with rcutree.rcu_idle_gp_delay=1 parameter?

  • Yep, the line looks like this:

    GRUB_CMDLINE_LINUX_DEFAULT="resume=UUID=f6daa909-105c-4e10-9437-803ef166c3a0 quiet rcutree.rcu_idle_gp_delay=1"
    
  • No other ideas here then. I use the same card as yours (though not on Lenovo), and it’s smooth as silk with Bumblebee here

    $ optirun inxi -Gxx
    Graphics:  Card-1: Intel Haswell-ULT Integrated Graphics Controller bus-ID: 00:02.0 chip-ID: 8086:0a16
           Card-2: NVIDIA GK107M [GeForce GT 750M] bus-ID: 01:00.0 chip-ID: 10de:0fe4
           Display Server: X.Org 1.17.1 drivers: intel (unloaded: fbdev,vesa) Resolution: [email protected]
           GLX Renderer: GeForce GT 750M/PCIe/SSE2 GLX Version: 4.5.0 NVIDIA 346.59 Direct Rendering: Yes
    $
  • Oh, I see, yeah mine used to work flawlessly :( what nvidia driver are you using? do you update your nvidia package? I ask that because I think I was using the nvidia-352.

  • @ben Sorry for a late reply. For some days I’ll be in another location, with bad and irregular connection.

    Yes, there are nvidia 352.21-1 installed here right now. But! I’ve never bothered about a specific driver’s version installed. There are three Optimus cards here (GeForce GT 555M, 650M, 750M). The key to not have any trouble with them in four years is to elaborate well and follow… the spirit of ArchWiki’s Bumblebee article.

    I’ve tried to summarize all I know about Bumblebee here. Actually, every time I need to (re)install Bumblebee on Arch I blindly follow that step-by-step guide. It never failed for me.

  • Thanks @just no problem, I really appreciate your help.
    I did a fresh install of the package following your guide, but still same problem. Do you have any other idea?

  • @ben said:

    …I did a fresh install of the package following your guide, but still same problem. Do you have any other idea?

    It’s a pity. No, unfortunately not, there’s no other idea. At least, right now, on the fly.

    Maybe you could look at the problem from a slightly different point of view? Why the card worked flawlessly in the past but not now? There should a reason for it. Miracles in computerscience are possible, but they happen very seldom.

    What could be changed in computer’s config? Some BIOS setting? Changed hard disks? Use of some other boot loader, with other parameters? It could anything, even the most improbable change…

  • Ummm I think problems started a few updates ago, but I wasn’t able to attend the issue. I will track what I did in the past and try to find a solution.
    Thank you!

nvidia100 bumblebee30 optimus24 Posts 11Views 2492
Log in to reply