• Problem with live CD and boot after the install


    I am trying to install Arch from latest Antergo iso. I have used Antergos for two other installments about a half year ago and didn’t have any problems.

    Today I have face several issues:

    1. There is some error message displayed before logon screen even started.
    2. Logon displays clock and there really is no way to see how to log into live CD. I accidentally clicked on the clock, and than a button with option “login” appeared. Why live cd does not login automatically is beyond my understanding. As a user what else what I like to do if I started a live session but to “log in” or start inistallation.
    3. After successfull installation to a USB stick, the newly installed system wan’t start up. I have installed on an ASUS g75VW laptop, and properly configured boot option, as well as installed GRUB according to offered options during installation with cinchi, but system does not seem to recognize uefi boot installed from cinchi (it is installed at all). As said, I had no problems with installation of Antergos on same usb stick and same computer about few months back.
  • Hi.
    Regarding your issue with your system not recognizing your uefi installation…
    a. Did you create a separate FAT32 partition to be used as /boot/efi, or you installed your efi file in the same partion from which
    b. I recently installed Antergos in a UEFI enabled hardware (Acer Aspire E11) and, although I followed the instructions to install (for Manjaro), Antergos didn’t boot at all. In general terms, I:
    b.1 Disabled secure-boot, but kept UEFI enabled.
    b.2 Created a separate FAT32 partition and set it mount point to /boot/efi
    b. 3 Installed Antergos (alongside Windows 8.1)
    b.4 Rebooted the system.
    b.5 Found Antergos didn’t boot.

    After days of researching in the web (it was a nightmare), I…
    b.6 Re-enabled secure boot to enable an option in the ‘BIOS’ setup from which I could choose to ‘trust a new efi file’’. This led me to a kind of rudimentary ‘file browser’ from which I could find a location called Grub.efi, Grub Boot, Antergos Boot, or somethig like that (I don’t remember the exact name right now). I eventually found a kind of file with .efi extension, selected it, labelled it as ‘ANTERGOS’, and then saved the changes.
    b.7 Finally, I enabled an option called ‘Boot Select’ (which allows me to select boot options at startup by pressing key F12 (remember that I installed Antergos alongside Windows 8.1).
    b.8. Rebooted, pressed F12 and then selected ‘ANTERGOS’ from the boot options.

    After a few times of booting into Antergos by pressing F12 at startup, I finally changed boot options in the ‘BIOS’ setup and selected Antergos as the first option.

    Maybe there is some equivalent procedure to enable a GNU/Linux installation to boot with an Asus machine.

  • EDIT:

    In point a, I should have written: ‘Did you create a separate FAT32 partition to be used as /boot/efi?’. Please, ignore all the rest at point a.

Posts 3Views 1028
Log in to reply