• Noisy/low volume microphone with pulseaudio in Skype


    Hi, I recently had to replace my laptop, and I am experiencing issues with my internal microphone.
    I thought it was only in Skype, but also in Audacity and Gnome Sound Recorder I am getting a constant distorded noise, and I think my voice but in a really really low volume. It’s practically noise. I tried some tweaking from the arch wiki, with no results, adding tshed=0 to the line that loads the udev module. Any help will be appreciated :smiley: Here is the output to pactl list sources…

    	State: SUSPENDED
    	Name: alsa_output.pci-0000_00_03.0.hdmi-stereo.monitor
    	Description: Monitor of Audio Interno Digital Stereo (HDMI)
    	Driver: module-alsa-card.c
    	Sample Specification: s16le 2ch 44100Hz
    	Channel Map: front-left,front-right
    	Owner Module: 6
    	Mute: no
    	Volume: front-left: 65536 / 100% / 0,00 dB,   front-right: 65536 / 100% / 0,00 dB
    	        balance 0,00
    	Base Volume: 65536 / 100% / 0,00 dB
    	Monitor of Sink: alsa_output.pci-0000_00_03.0.hdmi-stereo
    	Latency: 0 usec, configured 0 usec
    	Flags: DECIBEL_VOLUME LATENCY 
    	Properties:
    		device.description = "Monitor of Audio Interno Digital Stereo (HDMI)"
    		device.class = "monitor"
    		alsa.card = "0"
    		alsa.card_name = "HDA Intel HDMI"
    		alsa.long_card_name = "HDA Intel HDMI at 0xb2610000 irq 51"
    		alsa.driver_name = "snd_hda_intel"
    		device.bus_path = "pci-0000:00:03.0"
    		sysfs.path = "/devices/pci0000:00/0000:00:03.0/sound/card0"
    		device.bus = "pci"
    		device.vendor.id = "8086"
    		device.vendor.name = "Intel Corporation"
    		device.product.id = "0a0c"
    		device.product.name = "Haswell-ULT HD Audio Controller"
    		device.form_factor = "internal"
    		device.string = "0"
    		module-udev-detect.discovered = "1"
    		device.icon_name = "audio-card-pci"
    	Formats:
    		pcm
    
    Source #1
    	State: SUSPENDED
    	Name: alsa_output.pci-0000_00_1b.0.analog-stereo.monitor
    	Description: Monitor of Audio Interno Estéreo Analógico
    	Driver: module-alsa-card.c
    	Sample Specification: s16le 2ch 44100Hz
    	Channel Map: front-left,front-right
    	Owner Module: 7
    	Mute: no
    	Volume: front-left: 56973 /  87% / -3,65 dB,   front-right: 56973 /  87% / -3,65 dB
    	        balance 0,00
    	Base Volume: 65536 / 100% / 0,00 dB
    	Monitor of Sink: alsa_output.pci-0000_00_1b.0.analog-stereo
    	Latency: 0 usec, configured 0 usec
    	Flags: DECIBEL_VOLUME LATENCY 
    	Properties:
    		device.description = "Monitor of Audio Interno Estéreo Analógico"
    		device.class = "monitor"
    		alsa.card = "1"
    		alsa.card_name = "HDA Intel PCH"
    		alsa.long_card_name = "HDA Intel PCH at 0xb2614000 irq 48"
    		alsa.driver_name = "snd_hda_intel"
    		device.bus_path = "pci-0000:00:1b.0"
    		sysfs.path = "/devices/pci0000:00/0000:00:1b.0/sound/card1"
    		device.bus = "pci"
    		device.vendor.id = "8086"
    		device.vendor.name = "Intel Corporation"
    		device.product.id = "9c20"
    		device.product.name = "8 Series HD Audio Controller"
    		device.form_factor = "internal"
    		device.string = "1"
    		module-udev-detect.discovered = "1"
    		device.icon_name = "audio-card-pci"
    	Formats:
    		pcm
    
    Source #2
    	State: SUSPENDED
    	Name: alsa_input.pci-0000_00_1b.0.analog-stereo
    	Description: Audio Interno Estéreo Analógico
    	Driver: module-alsa-card.c
    	Sample Specification: s16le 2ch 44100Hz
    	Channel Map: front-left,front-right
    	Owner Module: 7
    	Mute: no
    	Volume: front-left: 65536 / 100% / 0,00 dB,   front-right: 65536 / 100% / 0,00 dB
    	        balance 0,00
    	Base Volume: 6554 /  10% / -60,00 dB
    	Monitor of Sink: n/a
    	Latency: 0 usec, configured 0 usec
    	Flags: HARDWARE HW_MUTE_CTRL HW_VOLUME_CTRL DECIBEL_VOLUME LATENCY 
    	Properties:
    		alsa.resolution_bits = "16"
    		device.api = "alsa"
    		device.class = "sound"
    		alsa.class = "generic"
    		alsa.subclass = "generic-mix"
    		alsa.name = "ALC233 Analog"
    		alsa.id = "ALC233 Analog"
    		alsa.subdevice = "0"
    		alsa.subdevice_name = "subdevice #0"
    		alsa.device = "0"
    		alsa.card = "1"
    		alsa.card_name = "HDA Intel PCH"
    		alsa.long_card_name = "HDA Intel PCH at 0xb2614000 irq 48"
    		alsa.driver_name = "snd_hda_intel"
    		device.bus_path = "pci-0000:00:1b.0"
    		sysfs.path = "/devices/pci0000:00/0000:00:1b.0/sound/card1"
    		device.bus = "pci"
    		device.vendor.id = "8086"
    		device.vendor.name = "Intel Corporation"
    		device.product.id = "9c20"
    		device.product.name = "8 Series HD Audio Controller"
    		device.form_factor = "internal"
    		device.string = "front:1"
    		device.buffering.buffer_size = "17632"
    		device.buffering.fragment_size = "4408"
    		device.access_mode = "mmap"
    		device.profile.name = "analog-stereo"
    		device.profile.description = "Estéreo Analógico"
    		device.description = "Audio Interno Estéreo Analógico"
    		alsa.mixer_name = "Realtek ALC233"
    		alsa.components = "HDA:10ec0235,17aa3805,00100002"
    		module-udev-detect.discovered = "1"
    		device.icon_name = "audio-card-pci"
    	Puertos:
    		analog-input-internal-mic: Micrófono interno (priority: 8900)
    		analog-input-mic: Micrófono (priority: 8700, not available)
    	Puerto Activo: analog-input-internal-mic
    	Formats:
    		pcm```
  • Just an update, after configuring input on Audacity, I was able to record just fine. The problem remains in Skype and it is related to the ALSA support being dropped in version 4.3. Version 4.2 won’t let you login. I tried using apulse32 (resulting in no sound), I installed all the necessary libraries and some other tricks I found in forums but no success… anybody using Skype 4.3 in Antergos with no problem? I can hear just fine, the problem remains with the microphone. I tried all entries in pavucontrol…

  • I have the same problem, and not only with Antergos, also with Puppy Linux; the same noisy low volume. When im using Whatsapp web, i cannot record a note voice because of that… I do some tweaking like you, but finally i gave it up.

    I think it’s a pulseaudio bug :( , let’s hope for a solution here.

    Antergos Gnome - Lenovo G4070
    Antergos XFCE (Ex-Mate) - Dell D630
    Antergos Cinnamon - Asus E-11
    Puppy Linux Precise 5.7.1 - Asus 701 EEEpc
    Puppy Linux Lxpuptahr USB live - All machines

  • Hi
    I use Skype sometimes to time and I had to tweak the configuration to get my mic working…
    I use skype 4.3 from the Multilib repo.

    In the Skype Options menu, I went in Sound / Voice menu (not sure about the name used in the English version) and I did 2 things :

    1. Untick the option to allow Skype to automatically adjust levels
    2. On the same place, there is a button to open Pulseaudio control menu. I adjusted the mic entry level to about 80% and the Latency offset to 30ms

    Hope it will help.

  • @squid-f tried it, didn’t work. Also, in the record tab, the control only appears while skype is working with the mic, otherwise it’s blank. The Input devices tab doesn’t help me either. I’m stuck with Skype in a Win7 virtual machine (sound is also crappy there, but well…) I’ll keep looking for a workaround. Cheers!

  • @guillermohs9 Hi,
    Did you try the pulse audio options through the Skype option windows ? See below (sorry the interface is in french) :
    skype 1.jpeg
    skype 2.jpeg

  • @squid-f Yes, I tried that and through the GNOME menu, I think that button open pavucontrol…

  • @guillermohs9 Too bad it didn’t work.
    Good luck !

  • UPDATE: Determined to find a way, I found a 2010 post in an Ubuntu forum with a weird yet simple solution. Apparently, the internal mic of my lenovo laptop is mono, so in pavucontrol you have to unlock the channel volumes, and then set the right channel to 0%, leaving the left channel as the only one with volume (aroud 50% does it in my case). Using this setting, I was able to use the mic successfully in various recording applications…
    HOWEVER… Skype still fails to capture my voice, even when the same settings work with every other program… So, the search continues…

  • @guillermohs9 said:

    UPDATE: Determined to find a way, I found a 2010 post in an Ubuntu forum with a weird yet simple solution. Apparently, the internal mic of my lenovo laptop is mono, so in pavucontrol you have to unlock the channel volumes, and then set the right channel to 0%, leaving the left channel as the only one with volume (aroud 50% does it in my case). Using this setting, I was able to use the mic successfully in various recording applications…
    HOWEVER… Skype still fails to capture my voice, even when the same settings work with every other program… So, the search continues…

    That worked for me too, but with the same problems :( have you found something more?

    https://bugs.launchpad.net/ubuntu/+source/alsa-driver/+bug/1002978 This is the bug i think, there is a DEB package to solve our “Inverted internal microphone”

    Antergos Gnome - Lenovo G4070
    Antergos XFCE (Ex-Mate) - Dell D630
    Antergos Cinnamon - Asus E-11
    Puppy Linux Precise 5.7.1 - Asus 701 EEEpc
    Puppy Linux Lxpuptahr USB live - All machines

  • This post is deleted!
  • I just tried again after a reinstall of Antergos that I had to do a couple of weeks ago, reinstalled Skype and it seems that I achieved something… I went into settings, uncheck the “let Skype…” option and the Apply. Went to pavucontrol, set the volumes as needed and, so far Skype hasn’t messed with them… I’m crossing fingers

  • Awesome !

  • I know its a very old thread, but i just HAVE to write this:

    FINALLY my inverted microphone works flawless! :D

    Antergos Gnome - Lenovo G4070
    Antergos XFCE (Ex-Mate) - Dell D630
    Antergos Cinnamon - Asus E-11
    Puppy Linux Precise 5.7.1 - Asus 701 EEEpc
    Puppy Linux Lxpuptahr USB live - All machines

pulseaudio14 microphone11 Posts 14Views 4608
Log in to reply