• Can not unlock from suspend


    Yesterday I installed Antergos and it has been working great, except for one thing: I can’t unlock it from suspend without a reboot. Whenever I close the lid, reopen it and enter my password the screen goes black but the power light says it is on. I even have this problem when I lock the screen and try to unlock it. I am using the latest GNOME edition on an Acer C720 Chromebook with 2gb of ram How can I fix this?

  • Hey Connor W.
    I don’t know what your problem is but I think people on this forum will maybe need a bit more info to answer your question.
    Like what Desktop Environment are you using for example KDE or XFCE

  • Hi

    apparently Connor uses Gnome, if I well understood.

    Remembering some similar issues I had and by reading across this forum, it seems a conflicting behavior may happen between LightDM and Gnome modules (Confidentiality and Energy management modules).
    One way to solve that is to chose one or the other.

    Either you want lightDM and, in that case, you should not use any Gnome modules in the settings menu to manage your lock screen or for energy saving purpose (black screen and so on). Instead, you should have a LightDM application in your installed software list to handle all of this.
    Or you want to use Gnome features and, in that case, it safer to install GDM and to remove lightDM ; you will find how to do that somewhere in the Antergos Wiki.

    If I misunderstood your issue or if a developer has a better idea, feel free to correct me.

    Good luck!

  • I got it to work! Just launched Light Locker Settings and configured it from there! Thank you!

  • @Connor-W. Hi,

    To my knowledge, they are 2 modules in the Gnome “All Settings menu” you need to look at : Privacy and Power.

    To enter the All Settings menu, make a left click on the right corner of the tool bar (sorry if it is obvious for you). Then, you get a window with a bunch of icons spread among 3 categories (Personal, Hardware, System).

    In the Personal section, click on Privacy. Check Automatic Screen Lock and Lock screen after blank are turned off.
    In the Hardware section, click on Power. Check Blank screen is never activated.

    Hoping it will solve your issue!

  • @Connor-W. Hi again.

    You have been faster than my answer. :smiley:

    Congratulations ! :sunglasses:

lock23 suspend33 Posts 6Views 1827
Log in to reply