• Sound at startup on Antergos Gnome?


    Hi Anterguys

    A kind of a newbie question, how can i put a sound at startup on Antergos Gnome?

    Thanks :)

    Antergos Gnome - Lenovo G4070
    Antergos XFCE (Ex-Mate) - Dell D630
    Antergos Cinnamon - Asus E-11
    Puppy Linux Precise 5.7.1 - Asus 701 EEEpc
    Puppy Linux Lxpuptahr USB live - All machines

  • @Caiosama205 First, find a sound theme with sound events of your liking. Example: UltimateEdition sound theme (can’t upload it right here, it’s 10+ M, twice more than max allowed 5M upload size). Besides a good startup sound, it has a lot of nice sounds for many button-clicking events.

    Add it to Gnome.

    Second, with dconf-editor enable gnome-desktop sound events for a standard user, by navigating to:

    org → gnome → desktop → sound

    • org.gnome.desktop.sound.event-sounds ENABLE (set checkmark)
    • org.gnome.desktop.sound.input-feedback-sounds ENABLE (set checkmark)
    • org.gnome.desktop.sound.theme-name UltimateEdition (or another one of your choice)

    Third, do the same for root user, if you want to have the same sounds while using root account. Repeat the above steps by starting dconf-editor as root: gksu dconf-editor .

    Fourth and last, reboot. A simple logout-login is not enough to get the new sound theme to work.

  • Thank you just, but i have a question…

    @just said:

    Add it to Gnome.

    Im very newbie on the Gnome desktop, how i add a sound to Gnome?

    Antergos Gnome - Lenovo G4070
    Antergos XFCE (Ex-Mate) - Dell D630
    Antergos Cinnamon - Asus E-11
    Puppy Linux Precise 5.7.1 - Asus 701 EEEpc
    Puppy Linux Lxpuptahr USB live - All machines

  • @Caiosama205 said:

    …how i add a sound to Gnome?

    It’s pretty simple.

    System-wide (available to all users) sound themes are kept in the /usr/share/sounds directory. To each theme corresponds a subdirectory with theme’s name. It may be a real directory or a link to a directory with sound theme, found elsewhere.

    For example, if there is a sound theme named MySounds in the system, then most probably it is kept in the /usr/share/sounds/MySounds directory. As a real directory or as a link that points to MySounds folder somewhere.

    To add a new sound theme to Gnome (Mate, Cinnamon, Kde, Plasma) simply copy (or link) the folder with the theme to /usr/share/sounds .

    Check / set the permissions for theme’s folder and all files it contains. Allow at least Read access for all users that might use the theme.

    You may find some sound themes here. Or simply copy/link the theme you like from another distro.

  • Edit:

    More correctly, if the folder with sound theme has the index.theme file, then theme’s name is given by the Name= parameter in the [Sound Theme] section.

    Like in this example

    [Sound Theme]
    Name=UltimateEdition
    Directories=stereo
    
    [stereo]
    OutputProfile=stereo
  • Thank you Just :)

    But i have a problem

    I made a folder with “Gentle_Sounds”, with a couple of sounds inside, placed at usr/share/sounds, downloaded at Gnome-look. Later with the dconf, change org.gnome.desktop.sound.theme-name freedesktop, to org.gnome.desktop.sound.theme-name Gentle_Sounds (exactly the name of the folder), done also with root. Later reboot and nothing happens :(

    Antergos Gnome - Lenovo G4070
    Antergos XFCE (Ex-Mate) - Dell D630
    Antergos Cinnamon - Asus E-11
    Puppy Linux Precise 5.7.1 - Asus 701 EEEpc
    Puppy Linux Lxpuptahr USB live - All machines

  • The Gentle_Sounds doesnt have an index file :(

    Antergos Gnome - Lenovo G4070
    Antergos XFCE (Ex-Mate) - Dell D630
    Antergos Cinnamon - Asus E-11
    Puppy Linux Precise 5.7.1 - Asus 701 EEEpc
    Puppy Linux Lxpuptahr USB live - All machines

  • @Caiosama205 said:

    The Gentle_Sounds doesnt have an index file :(

    That means nothing and is normal. The presence of index.theme is optional. It is used only in some “high-end” sound themes, like UltimateEdition. Simple sound themes don’t require and work without it. Don’t worry about the absence of index.theme .

    Another thing. Only few sound themes include the Gnome startup sound. A sound theme is not a rigid construction, that always covers all possible Gnome sound events. Most sound themes are very simple, and cover only very basic sound events.

    I don’t know Gentle Sounds theme. Probably it simply doesn’t have the startup sound. Like the majority of themes.

    To discover if the currently applied sound theme has the startup sound, run the command in Gnome

    /usr/bin/canberra-gtk-play -V -20.0 --id="desktop-login" --description="GNOME Login"
    

    If some sound is being played, then the theme has the startup sound - those reproduced by the command. Otherwise (no sound is played and the command returns the error) the currently applied sound theme has no startup sound.

  • Thank you so much @just , i just downloaded another theme, and finally works!

    Antergos Gnome - Lenovo G4070
    Antergos XFCE (Ex-Mate) - Dell D630
    Antergos Cinnamon - Asus E-11
    Puppy Linux Precise 5.7.1 - Asus 701 EEEpc
    Puppy Linux Lxpuptahr USB live - All machines

  • @Caiosama205 You’re welcome. Glad to know you have the problem solved. Completely agree with you - a sounding Gnome is much nicer than a mute one.

  • That´s very true :)

    Antergos Gnome - Lenovo G4070
    Antergos XFCE (Ex-Mate) - Dell D630
    Antergos Cinnamon - Asus E-11
    Puppy Linux Precise 5.7.1 - Asus 701 EEEpc
    Puppy Linux Lxpuptahr USB live - All machines

startup14 sound42 start-up4 Posts 11Views 2939
Log in to reply