• Time/date formats


    Hello. I have a problem with date/time formats discrepancy. My system language is set to English and formats are set to Ukrainian. At GNOME top panel time is shown in 24 hour mode as it should but at welcome screen it’s in 12 hour mode and the same goes for Chromium and Firefox. How to change it to 24 hour mode? Screenshot from 2015-07-27 13-41-07.png

  • @Anastasiya-Miloslavskaya Sorry for a stupid suggestion. Format changes (to Украина) are applied after logout-login. Did you do it?

  • @just I hadn’t changed it right before posting. Formats were set to ukraine during installation (3 days ago) so I think the option should be in effect but time were always displayed in 12 hour mode

  • @Anastasiya-Miloslavskaya Could you be so kind to share the full output of the following three commands:

    1. cat /etc/locale.conf
    2. cat /etc/environment
    3. locale

    It looks like:

    1. $ cat /etc/locale.conf
      LANG=en_IE.UTF-8
      LC_COLLATE=en_IE.UTF-8
      $ 
      
    2. $ cat /etc/environment
      LANG=en_IE.UTF-8
      BROWSER=/usr/bin/chromium
      $ 
      
    3. $ locale
      LANG=en_IE.UTF-8
      LC_CTYPE="en_IE.UTF-8"
      LC_NUMERIC="en_IE.UTF-8"
      LC_TIME="en_IE.UTF-8"
      LC_COLLATE=en_IE.UTF-8
      LC_MONETARY="en_IE.UTF-8"
      LC_MESSAGES="en_IE.UTF-8"
      LC_PAPER="en_IE.UTF-8"
      LC_NAME="en_IE.UTF-8"
      LC_ADDRESS="en_IE.UTF-8"
      LC_TELEPHONE="en_IE.UTF-8"
      LC_MEASUREMENT="en_IE.UTF-8"
      LC_IDENTIFICATION="en_IE.UTF-8"
      LC_ALL=
      $ 
      

    It might help to make the situation with your locale and regional settings a bit clearer.

  • $ cat /etc/locale.conf
    LANG=en_US.UTF-8
    LC_NUMERIC=ru_UA.UTF-8
    LC_TIME=ru_UA.UTF-8
    LC_MONETARY=ru_UA.UTF-8
    LC_PAPER=ru_UA.UTF-8
    LC_MEASUREMENT=ru_UA.UTF-8
    
    $ cat /etc/environment
    BROWSER=/usr/bin/chromium
    
    $ locale
    LANG=en_US.UTF-8
    LC_CTYPE="en_US.UTF-8"
    LC_NUMERIC=ru_UA.UTF-8
    LC_TIME=ru_UA.UTF-8
    LC_COLLATE="en_US.UTF-8"
    LC_MONETARY=ru_UA.UTF-8
    LC_MESSAGES="en_US.UTF-8"
    LC_PAPER=ru_UA.UTF-8
    LC_NAME="en_US.UTF-8"
    LC_ADDRESS="en_US.UTF-8"
    LC_TELEPHONE="en_US.UTF-8"
    LC_MEASUREMENT=ru_UA.UTF-8
    LC_IDENTIFICATION="en_US.UTF-8"
    LC_ALL=
    
  • @Anastasiya-Miloslavskaya What a confusing locales configuration. Never seen anything like that before in Antergos.

    It’s still possible to try to recover from it. Let’s start with very simple, easy undo-able steps.

    1. Edit /etc/locale.conf

    2. Add to it a new line

      LC_COLLATE=ru_UA.UTF-8
      
    3. Leave other lines unchanged

    4. Logout, login. Or reboot.

    It may or may not work. If the things are getting worse, simply remove that line and reboot again.

  • @just nothing has changed

  • @Anastasiya-Miloslavskaya said:

    At GNOME top panel time is shown in 24 hour mode as it should but at welcome screen it’s in 12 hour mode and the same goes for Chromium and Firefox.

    Hi,
    what do you mean by the same goes for Chromium and Firefox ? Would you have an example of the behavior you want to change with them ? Have you looked at the preferred language in Firefox preferences ?

    What do you call the welcome screen ? Is it the screen you get just after the boot screen in order to sign in ? Do you use lightDM or GDM then ? What about the format of the time when the screen is locked ?

    I am trying to understand the issue more in details to try to help.

  • Very good questions. The answers may really help to clear the situation.

  • @squid-f said:

    Hi,
    what do you mean by the same goes for Chromium and Firefox ? Would you have an example of the behavior you want to change with them ? Have you looked at the preferred language in Firefox preferences ?

    If I need to choose date and time in some formes they are shown like that
    screenshot-smotrisport.tv 2015-07-28 10-01-46.png
    And I need them like that (screen from from ubuntu where langage set to russian and formats to ukraine)
    screenshot-smotrisport.tv 2015-07-28 10-20-25.png
    In firefox preferred languages are English [en] and English/US [en-us]
    Maybe I should just set system language not to US English but to some other country’s where metric system is used? Which one should I choose?

    What do you call the welcome screen ? Is it the screen you get just after the boot screen in order to sign in ? Do you use lightDM or GDM then ? What about the format of the time when the screen is locked ?

    IMG_20150728_102247311.jpg

  • Hi

    @Anastasiya-Miloslavskaya said:

    And I need them like that (screen from from ubuntu where langage set to russian and formats to ukraine)
    screenshot-smotrisport.tv 2015-07-28 10-20-25.png
    In firefox preferred languages are English [en] and English/US [en-us]
    Maybe I should just set system language not to US English but to some other country’s where metric system is used? Which one should I choose?

    I don’t understand how it is connected to Firefox but never mind. Indeed, changing the language to something else than US might help but I am not sure.
    I am just curious : why don’t you set it to your native language ? It will not prevent having the page displayed in English but the rest should be more suitable ? Otherwise, maybe setting it to English-United Kingdom will help.

    @Anastasiya-Miloslavskaya said:

    What do you call the welcome screen ? Is it the screen you get just after the boot screen in order to sign in ? Do you use lightDM or GDM then ? What about the format of the time when the screen is locked ?

    IMG_20150728_102247311.jpg

    Ok, you use lightDM display manager apparently. There is a nice Wiki on Arch website : link to Arch Wiki
    You may want to have a look at it.
    Before changing anything, I would like to know what is your keyboard layout ? QWERTY, AZERTY, something else ? And does it work properly when you enter your password when you log in ?

    “Talk” to you soon !:smirk:

  • Seems like changing formats doesn’t change the way date and time displayed in browsers but changing system language to en-UK worked, now time is in 24 hour mode

    @squid-f said:

    I am just curious : why don’t you set it to your native language ? It will not prevent having the page displayed in English but the rest should be more suitable ?

    I just want it in English

    Ok, you use lightDM display manager apparently. There is a nice Wiki on Arch website : link to Arch Wiki
    You may want to have a look at it.
    Before changing anything, I would like to know what is your keyboard layout ? QWERTY, AZERTY, something else ? And does it work properly when you enter your password when you log in ?

    I’m not really concerned about login screen as long as it works. I see it only once or twice a day so I can just ignore strange time.
    My layout is QWERTY and since my password doesn’t contains letters I don’t have any problems logging in

  • Hi

    @Anastasiya-Miloslavskaya said:

    Seems like changing formats doesn’t change the way date and time displayed in browsers but changing system language to en-UK worked, now time is in 24 hour mode

    So, does that mean your issue is solved ?

    I’m not really concerned about login screen as long as it works. I see it only once or twice a day so I can just ignore strange time.
    My layout is QWERTY and since my password doesn’t contains letters I don’t have any problems logging in

    The layout can impact numbers as well, but it is another story. :smirk:

  • @squid-f said:

    So, does that mean your issue is solved ?

    Yeah, kind of

time2 Posts 14Views 2929
Log in to reply