• kdm login theme problem


    hi all :)

    I want to chance the login KDM theme.
    I downloaded “caledonia” theme by malcer, then I installed it and selected it with KDM manager but the default antergos theme doesn’t change! :(

    This is my kdmrc… any solution?

    [General]
    ConfigVersion=2.4
    ConsoleTTYs=tty1,tty2,tty3,tty4,tty5,tty6
    GreeterUID=kdm
    PidFile=/var/run/kdm.pid
    ReserveServers=:1,:2,:3
    ServerVTs=-7
    StaticServers=:0
    
    [Shutdown]
    BootManager=None
    HaltCmd=/sbin/shutdown -h -P now
    RebootCmd=/sbin/shutdown -r now
    
    [X-*-Core]
    AllowNullPasswd=false
    AllowRootLogin=false
    AllowShutdown=Root
    AutoReLogin=false
    ClientLogFile=.xsession-errors-%d
    Reset=/usr/share/config/kdm/Xreset
    Session=/usr/share/config/kdm/Xsession
    SessionsDirs=/usr/share/config/kdm/sessions,/usr/share/apps/kdm/sessions
    Setup=/usr/share/config/kdm/Xsetup
    Startup=/usr/share/config/kdm/Xstartup
    
    [X-*-Greeter]
    AntiAliasing=false
    BackgroundCfg=/usr/share/config/kdm/backgroundrc
    ColorScheme=
    FaceSource=AdminOnly
    FailFont=Sans Serif,10,-1,5,75,0,0,0,0,0
    ForgingSeed=1428751938
    GUIStyle=
    GreetFont=Serif,20,-1,5,50,0,0,0,0,0
    GreetString=Welcome to %s at %n
    GreeterPos=50,50
    HiddenUsers=
    Language=en_US
    LogoArea=Logo
    LogoPixmap=
    MaxShowUID=65000
    MinShowUID=500
    Preloader=/usr/bin/preloadkde
    SelectedUsers=
    ShowUsers=NotHidden
    SortUsers=true
    StdFont=Sans Serif,10,-1,5,50,0,0,0,0,0
    Theme=/usr/share/apps/kdm/themes/Caledonia-KDM
    UseBackground=true
    UseTheme=true
    UserCompletion=false
    UserList=true
    
    [X-:*-Core]
    AllowNullPasswd=true
    AllowShutdown=All
    NoPassEnable=false
    NoPassUsers=
    ServerArgsLocal=-nolisten tcp
    ServerCmd=/usr/bin/X -br -novtswitch -quiet
    
    [X-:*-Greeter]
    AllowClose=false
    DefaultUser=git
    FocusPasswd=false
    LoginMode=DefaultLocal
    PreselectUser=None
    
    [X-:0-Core]
    AutoLoginEnable=false
    AutoLoginLocked=false
    AutoLoginUser=
    ClientLogFile=.xsession-errors
    
    [Xdmcp]
    Enable=false
    Willing=/usr/share/config/kdm/Xwilling
    Xaccess=/usr/share/config/kdm/Xaccess
    
  • @stefat77 said:

    …I want to chance the login KDM theme.
    I downloaded “caledonia” theme by malcer, then I installed it and selected it with KDM manager but the default antergos theme doesn’t change! :(

    Antergos uses by default LightDM display manager, along with lightdm-webkit2-greeter for theming

    Unless the default display manager was substituted with KDM display manager, it’s hard to expect that LightDM will ever display KDM’s themes.

    Did you change LightDM with KDM?

  • @just thanks for the answer! I’m stupid, I hadn’t thought about that… :)
    How can I disable ldm and enable kdm?

  • @stefat77 said:

    …How can I disable ldm and enable kdm?

    Unless you’re very experienced with display managers, I would advice to not doing that. Because:

    • Among many distros, Antergos has the best LightDM integration not only with Kde, but also with its other DEs. Until you stay with LightDM in Antergos, you’ll never have a problem to instantly switch from one DE to another.

    • KDM is dying. It’s about to be abandoned. It’s not developed anymore for months. It is already substituted by SDDM in many Kde distros.

    • Kde’s EOL is scheduled for this august. It will be substituted by Plasma. SDDM is the default display manager in Plasma.

    • Changing display manager is not an easy task. It requires a certain experience. The user should be ready to face many troubles while doing it. To get an idea about what could be expected, you might take a look at ArchWiki here.

    Finally, it’s enough to enable autologin, thus avoiding to deal with any display manager on startup at all. This is the choice in my case.

  • Kdm is being replaced by sddm. Use sddm instead.

    I7 [email protected]/32GB Ram/3440 x 1440 + 1440p/EVGA 1080 FTW/512GB SSD/2TB HD/Antergos Base w/ Plasma

Posts 5Views 1072
Log in to reply