• [SOLVED]WiFi disconnection


    I use Antergos for a while but I’m actually a newbie user :P . Recently I’ve bought a new laptop but I’m having a problem with my WiFi connection. After connected (some ramdom period of time) the indicator continues to show “connected” but the connection is actually lost. I always need to disconnect and connect again. This happens everywhere, college, home… and it was not happening when I used windows in this laptop.
    Help me, please! :)

  • Hi,

    I am not sure I know the answer but to try to help could you tell us what is your desktop environment and how do you initiate the connection ?

    Good luck

  • I’m using xfce and I just click on the plugin icon for internet connection and connect on WiFi. I was using gnome a week ago and the problem was the same. It’s happening since the installation

  • That’s weird. If the connection is lost, it is usually because the signal became too weak (by moving around, you can still have a signal but too weak to get access to internet) or because the lease expired from the router.

    Could you open a terminal window and post the result of the command ifconfig ? Running it when the connection is up and when the connection is getting down (of course for the same wifi network).

    Also, what is the brand and the model of your laptop ?

  • After some reserch I finally find out that the problem is with the driver of my wireless card

    Network controller: Realtek Semiconductor Co., Ltd. RTL8723BE PCIe Wireless Network Adapter

    Some folks on internet solved the problem but teir solutions is not working for me


  • @PluckSeabra
    your search helps progressing for sure 😎
    Going through your links, it seems there is a bug report opened : link to the report
    At the end of this report, there is a fix proposed. Have you tried it ?

  • I’m unable to build. This happens when I type make :

    [[email protected] wififix]$ make
    make -C /lib/modules/4.1.2-2-ARCH/build M=/home/juan/wififix modules
    make[1]: Entering directory '/usr/lib/modules/4.1.2-2-ARCH/build'
    make[1]: *** No rule to make target 'modules'.  Pare.
    make[1]: Leaving directory '/usr/lib/modules/4.1.2-2-ARCH/build'
    Makefile:53: recipe for target 'all' failed
    make: *** [all] Error 2

    I tried to do what they say here but I’m getting the same build error.

    After a kernel update I as able to compile and it’s everything working until now. Thanks a lot for the help! :)

  • @PluckSeabra said:

    After a kernel update I as able to compile and it’s everything working until now. Thanks a lot for the help! :)

    Awesome !

wi-fi16 Posts 8Views 2560
Log in to reply
Bloom Email Optin Plugin

Looks like your connection to Antergos Community Forum was lost, please wait while we try to reconnect.