• Why does settings show my graphics as Gallium 0.4 on llvmpipe (LLVM 3.6, 256 bits)


    I actually have:
    $ lspci -v -s lspci | awk '/VGA/{print $1}'
    01:00.0 VGA compatible controller: NVIDIA Corporation GF108 [GeForce GT 730] (rev a1) (prog-if 00 [VGA controller])
    Subsystem: Micro-Star International Co., Ltd. [MSI] Device 8a9f
    Flags: bus master, fast devsel, latency 0, IRQ 30
    Memory at f6000000 (32-bit, non-prefetchable) [size=16M]
    Memory at e8000000 (64-bit, prefetchable) [size=128M]
    Memory at f0000000 (64-bit, prefetchable) [size=32M]
    I/O ports at e000 [size=128]
    [virtual] Expansion ROM at f7000000 [disabled] [size=512K]
    Capabilities: <access denied>
    Kernel driver in use: nvidia
    Kernel modules: nouveau, nvidia
    Googling shows lots of others having this issue but the only solution I saw (which I dont understand) was -
    “i resolved this by adding my user to the video group and restarting x it was just a permission problem
    eg
    usermod -a -G video sillyme” bbs.archlinux.org
    Ideas anyone?

  • Googling as much as i can to get to the bottom of this but going down the rabbit hole now & getting lost. Seems to be related to DRI2 and using KVM (I am not running in VM) which on boot mine says is disabled by bios.

    Anyone understand this stuff?

  • OK - solved this. Here for anyone else having this issue is what I did.

    Seems the problem was the new Nvidia 352.21 driver. I switched from Nouveau to it & had problems with my game playing VERY slow & laggy. I have just followed ArchWiki instructions:
    Order of install/deinstall for changing drivers
    Where the old driver is nvidiaO and the new driver is nvidiaN.

    remove nvidiaO
    install nvidia-libglN
    install nvidiaN
    install lib32-nvidia-libgl-N (if required)
    

    To change to the older Nvidia 340xx and now my game plays as it should AND setting show Graphics as - GeForce GT 730/PCIe/SSE2

nvidia138 arch38 graphics card7 gallium 0.4 on1 Posts 3Views 8848
Log in to reply
Bloom Email Optin Plugin

Looks like your connection to Antergos Community Forum was lost, please wait while we try to reconnect.