• Connection issues with Intel 7260 wireless card


    My WIFI associates and connects, but even when I try to update my pacman DB’s it will start at ~180kbps and then slow down and finally time out due to getting less than 1kbps for 10 seconds. I have tried turning off power management with iwconfig and even removing some of the newer ucodes in /lib/firmware (down to version 9). It worked in previous versions of the live environment but it does this in the newest. It is not in a location I can run a ethernet to it.

    Thanks in advance

  • Does it happen during the updates with pacman only? Can you still use a browser and navigate normally, without connection slowdowns? If both answers are “yes”, then a problem could be caused by slow mirrors pacman tries to access.

    To get the list of fastest mirrors and allow pacman to use it:

    sudo pacman -S reflector
    sudo reflector --age 8 --fastest 128 --latest 64 --number 32 --sort rate --save /etc/pacman.d/mirrorlist
    

    This will find 128 fastest mirrors in last 8 hours, select 64 most recently synchronized from them, limit the list to first 32, sort them by access rate (speed), store the result in the file used by pacman when it accesses the repos.

    Then simply retry to do what you was doing with pacman.

  • Thanks for the reply but web browsing also is slow or i get server has reset due to time out.

  • I have no Intel 7260 network controller, and know nothing about it. But a quick DDG-oing returned this thread on Intel forums, which speaks about very slow conncetions with 7260; look at the post #19 by Barto, Jun 5, 2014 1:02 PM:

    https://communities.intel.com/message/237854#237854

    The guy says: “…Edit: I turned off u-apsd. Now conection speed is the same, as on old drivers.”

    Have no idea what u-apsd is and how to turn it off, but apparently doing so has solved the problem.

  • So after some fiddling around I disabled the NetworkManager service, removed the iwlwifi module and readded it with 11n_disable=0 and It worked, kinda. I got decent (enough) throughput of about 2mbps consistently it seemed. I went through with the install and it said it couldn’t verify the integrity of the packages.

    Rebooted, did the module thing and updated the keychains before installing. Got to the end of the install and it gives me a generic can’t install the packages error, different than before. Checked the /tmp/cnchi.log and it looks like none of the sha1sums are matching what I downloaded, so maybe there is still some corruption going on in the connection.

iwlwifi2 intel26 72602 Posts 5Views 1215
Log in to reply