• Installing Antergos and it stalls downloading packages

    Hello, I’m trying to install Antergos for what seems to be the 10th time and it always stalls on downloading some package for 15+ minutes or more. It once finished downloading everything but failed to install the OS. I understand this is a common problem but I am wondering if there is a way to see in the terminal the download speeds of the packages and the place where it is being downloaded from. I am curious if the servers are slow or not.

  • i too am getting this experience every attempt. and this post is just the most recent of countless others before it. Can we please look into this? definitely willing to test to help debug… but there isn’t even test builds…

    …c’mon guys. this actually seems like a great project, or could be anyway :/

  • Yep, I was about 61% done with downloading packages and it gave me the “peer reset connection” error and kicked me out. I would like to add to this question and ask if there is any way to pick up where you left off when installing Antergos. That is, not having to re-download every single package again in hopes that it doesn’t stall/reset connection some arbitrary percent of the way done. cnchi prompts me to reformat the partitions to begin downloading packages. It’s very frustrating.

  • Hi,

    Sorry for the trouble you experienced. If you could, please provide the installer log after it fails. You can find the log in the /tmp directory. Thanks.

  • Here are my logs.Logs.tar

  • @lots.0.logs Here is another failed attempt:


  • @lots.0.logs And yet another failed attempt, this one stopped at around 81%. I hope these logs are of use. I think I am not alone in this wave of reset connections.

  • I am having similar issues. Installation stalls at random percentage, and i got a couple of errors: once a 104 (something about connection refused or dropped) and an error about downloading packages after the download reached 100%. I attach the cnchi.log.tar log from cnchi. This one stalled at 19% download…

  • Hi,

    Just with a quick look I see some mirror problems in your log:

    WARNING: Can't open http://archlinux.surlyjake.com/archlinux/extra/os/x86_64/foomatic-db-engine-3:20150620-1-any.pkg.tar.xz - Reason: [Errno 111] Connection refused
    WARNING: Can't open http://mirrors.manchester.m247.com/arch-linux/core/os/x86_64/nano-2.4.2-1-x86_64.pkg.tar.xz - Reason: Not Found
    WARNING: Can't open http://arch.static.lu/extra/os/x86_64/glew-1.12.0-1-x86_64.pkg.tar.xz - Reason: Forbidden
    WARNING: Can't open http://mirrors.hustunique.com/archlinux/extra/os/x86_64/boost-libs-1.58.0-2-x86_64.pkg.tar.xz - Reason: Forbidden
    WARNING: Can't open http://arch.static.lu/multilib/os/x86_64/lib32-keyutils-1.5.9-1-x86_64.pkg.tar.xz - Reason: Forbidden
    WARNING: Can't open http://mirrors.hustunique.com/archlinux/extra/os/x86_64/librevenge-0.0.2-1-x86_64.pkg.tar.xz - Reason: Forbidden
  • I might be asking a dumb question… But is there a way to manually pass a specific mirror as an option? Im from Argentina, i usually use mirrors from Brazil…

  • Try this:

    1. Run the livecd
    2. Update the mirrorlists:
      sudo pacman -S pacman-mirrorlist antergos-mirrorlist
    3. As you already had a mirrorlist, you must copy the new ones to the old ones:
    sudo mv /etc/pacman.d/mirrorlist.pacnew /etc/pacman.d/mirrorlist
    sudo mv /etc/pacman.d/antergos-mirrorlist.pacnew /etc/pacman.d/antergos-mirrorlist
    1. Edit those two files, and leave just the mirrors you want to use (put a starting # in those that you don’t)
    2. Run sudo pacman -Syy to check that the mirrors are working (NB: Do not do this in an installed system, in an installed system always run sudo pacman -Syu).
    3. Run Cnchi again and do the installation as always:
      sudo -E cnchi -dv

    Tell us how it goes.

  • I’m trying it right now… the Antergos mirrorlist’s servers ran a bit slower than the rest when I ran pacman -Syy. I’ll post a log if anything goes wrong! It’s looking good so far. Thanks karasu!

  • Well after doing as instructed, installation went just fine. I am about to reboot. Mirror configuration did the trick in my case. Thanks a lot! It’s things like these that make me love linux, you have to get your hands dirty some times, but you end up knowing something more and with a system working better than before.

  • Cnchi 0.10 will do this itself, I hope this way users will have to face less mirror problems (fingers crossed).

  • @karasu I did this and the installation worked fine! I now have a dual-booting Antergos/Windows 7 computer. For anyone that might be interested I did run into some kinks following the steps that @karasu gave. Here is a list of them and what I did:

    • After step 2, if you look in the etc/pacman.d directory on a Live USB, you will notice that there is only one file created by the command. This file is mirrorlist.pacnew. I’m guessing that when you update the mirrorlist it can write to the antergos-mirrorlist but not the pacman-mirrorlist.

    • When carrying out step 3, you will get a warning in the terminal stating that it can’t find mirrorlist.pacnew, This is because it never seemed to have been made when you ran the command from step 2.

    • In step 4, it tells you to edit the files to your liking. I was not able to do this since when I clicked on the files, it can only be opened up as “read-only”. What I did is copy the files onto the /home directory and change them to my liking there and carried out the command from step 3 slightly modified to move the files from the home directory to the /etc/pacman.d directory. It went something like this:
      sudo mv /home/mirrorlist /etc/pacman.d/mirrorlist
      sudo mv /home/antergos-mirrorlist /etc/pacman.d/antergos-mirrorlist

    Then all I did was do step 5 and 6 and I had a successful installation. One thing I’d like to say is the reason I went through the trouble of doing the steps I mentioned is that if I performed the steps verbatim and did NOT modify the mirrorlist file by uncommenting some servers is that when I finished setting up cnchi to install the OS it would hang in the installation screen and say something along the lines of “installing using `advanced` mode” and never actually load the changes to mirrors as well as start the downloading process.

    I hope this helps some of you who are having trouble installing Antergos, for me it took about 2 days because the connection kept resetting. Hopefully you all get this fixed soon.

  • I’m having this same problem. I tried the solution above and even used mirrorrank and reflector to rank the mirrors. It still got stuck downloading some random package (I waited about half an hour). Have been trying to install for 2 days now, to no avail :S Any ideas? I’m really really tired of the other distro I’m using and Vainilla Arch is too much of a pain to install.

    EDIT: I’m gonna try again and see if there’s anything on the log (i’ll post it), but last time I checked it had nothing on errors (last line said something about downloading XYZ package. Which seemed to be taking forever without any progress so I desisted)

  • @PunkCapitalist That sound so familiar to me. It took me 2 days to install Antergos as well. I would suggest you stick with @karasu 's instructions. I am not sure if you followed @karasu 's instructions purely or tried what worked for me. If you haven’t already tried doing what I did perhaps give it a shot. I have found a simpler way of performing step 4 in my post. All you have to do is go to the folder where the mirrolists are at and right click on a white space in the explorer and open up a terminal. You can command the terminal to open up gedit WITH root priviledges with:
    sudo gedit mirrorlist to edit the mirrorlist file and then sudo gedit antergos-mirrorlist to edit the antergos-mirrorlist file. This saves you the trouble of having to move the edited file back to where cnchi will read it. Hopefully you get this installed, I know it can be frustrating!

  • @karasu Has anyone figured out why Cnchi is so buggy? This distro is perfect but getting it installed is painful. I currently run Openbox, Gnome, and Cinnamon. They are all awesome but the installs were not smooth. Can’t wait for you guys to figure out the issue cause then you’ll have perfection!

  • I had the exact same issue. I tried the steps suggested by @karasu however the installer still seem to stall while pulling certain packages. I finally managed to install Antergos without selecting the Libreoffice & Truetype fonts packages.

  • Would just like to say that even today this installer seems to be not so good. This is my 15th attempt now after trying almost everything in the book. Most issues seem to be related to package sources timing out, at which point the installer thinks its a good idea to FAIL everything and terminate. This means a reboot is needed as it doesn’t reset the hdd correctly so the system can detect it again, the installer REALLY needs redundancies and options to RETRY / TRY different repo etc instead of falling over like it does.

download31 live usb11 stalling3 cnchi 0.8.212 Posts 26Views 15809
Log in to reply
Bloom Email Optin Plugin

Looks like your connection to Antergos Community Forum was lost, please wait while we try to reconnect.