• Black screen, static cursor instead of login screen after update to linux 4.1.2-2


    Just a note in case this may affect others… After updating to kernel linux 4.1.2-2 (among other packages) today and rebooting, I was greeted by a grim screen of black with just a static cursor in the top left instead of a login screen.

    I eventually resolved the issue by logging in via SSH and rolling back the kernel to linux 4.0.7-2, after chrooting in from a live USB to enable SSH! I re-installed Antergos on a new drive a couple of days ago, and hadn’t thought to enable SSH yet!

    My machine is a MacBook-Pro 6,2 (mid 2010), GNOME desktop environment.

    Cheers, Steve.

  • Your thread piqued my curiosity. I don’t have a blank screen by my desktop has been acting a bit wonky for the past few days after the update. I initially thought the problem was my video driver update but I’m wondering if it maybe the linux update?

  • I have the exact same problem, also on MacBookPro6,2 it started since the 4.1 kernel. Have you found a solution other than going back to the old kernel?

    Cheers, Huub

  • hmm… perhaps this is the problem i’m having with my MBP 8,2. Thank you for sharing your experience Steve.
    So if downgrading to the 4.0(?) kernel solved the issue… is there a good way for me to do a fresh antergos install with using the old kernel instead of the 4.1 which is automatically installed?

  • Huub, I haven’t found another solution (I haven’t been looking, I’m now using the linux-lts kernel).

    QuantumQweef, I’m sorry, I don’t know how to install with the older kernel, but perhaps after installation, you could boot again from the install media then chroot into your new installation to enable SSH, then reboot from the new installation, log in via SSH and use pacman to install the linux-lts package. That should get you up and running. There might possibly be a more elegant way to go about this, but I couldn’t say. It worked for me!

    Steve.

  • @steven5632 yes I’ve tried this…but didn’t quite solve the problem completely. So maybe there’s a driver I’m missing as well

  • I noticed linux has been updated to 4.1.3-1. When I have time, I’ll update again and see what happens.

  • I updated my MacBook Pro 6,2 to linux 4.1.4-1 today, to see if anything had changed. However, I got the same result as the original post (static cursor on black screen, no access to virtual terminals). It seems that at the moment, linux 4.0.7-2 is the most recent kernel that can be used with this machine.

    Steve.

  • @QuantumQweef Installing linux-lts isn’t enough. You’ll need to downgrade to the previous kernel version 4.0.7-2. I tried installing linux-lts first before I downgraded the kernel with no success.

    Steve.

  • @steven5632 yea I didn’t get success with the lts kernel either. but in my case at least I don’t think the kernel may be the root of the problem. At least for my MBP 8,2, the display problem was probably to do with driver support. I ended up resorting back to manually installing arch myself (from the archlinux iso) and configured the nouveau driver instead of any nvidia ones and Xorg seems to cooperate better now

  • @QuantumQweef I haven’t been able to get the proprietary Nvidia to work at all. I’m using nouveau also…

  • I just had a little time on my hands so I decided to try to upgrade to linux 4.2.1-1 in the hope that my previous issue has been fixed in subsequent updates. Sure enough, the upgrade went without a hitch! I’m running an up-to-date kernel again. Happy now. It had been bugging me for a while!

  • Nice, anyone having video issues can boot up without vesa by putting this in the kernel line before bootup.

    video=vesa:off vga=normal

    That helped me out a bit, normally not needed, but sometimes with certain displays, issues occur. Now if only AMD had some functional Kernel 4.2 drivers, I’m not really keen on getting latest llvm going to take advantage of the latest Open Source drivers…

display32 kernel79 macbook19 update46 Posts 13Views 4327
Log in to reply