• lightdm lock screen switches off display


    I am having problems using the lightdm screen locker as of late.

    Whenever I lock the screen with the “dm-tool lock” command, after logging back in the display is turned off (not in a minimal brightness way, but being switched off).

    I disabled Gnome’s screen lock (in the Preferences>Privacy menu), after which the lightdm lock worked normally once, but after that occasion the problem appeared again.

  • i was trying to post the journal log, but neither uploading a file nor posting it in a code block worked.

  • Check that you have xscreensaver installed. Also check the settings in the light locker settings application. Finally, check /etc/lightdm/Xsession to verify that it includes this at the end:

     /usr/bin/light-locker &
    sleep 3; echo "X session wrapper complete, running session [email protected]"
    

    Let me know if it helps. Cheers!

  • thanks for the reply but, no, that doesn’t help.

lockscreen11 gnome229 lightdm96 Posts 4Views 1576
Log in to reply