• Fish shell as default


    I’m trying to set my default shell to Fish. But it seems, that it does not work.:

    [[email protected] ~]$ chsh -s /usr/bin/fish
    Shell für buzz-dee ändern.
    Passwort: 
    chsh: Shell nicht geändert.
    

    What could be the problem?

  • @k357k9 said:

    Does this help? http://fishshell.com/docs/current/faq.html#faq-default

    No. I have installed the Fish shell via Pacman.

    On another computer, it seems that I can change the default shell, but it also does not work.:

    [[email protected] ~]$ chsh
    Shell für buzz-dee ändern.
    Passwort: 
    Neue Shell [/bin/bash]: 
    [[email protected] ~]$ echo $SHELL
    /bin/bash
    [[email protected] ~]$ chsh -s /usr/bin/fish 
    Shell für buzz-dee ändern.
    Passwort: 
    Shell geändert.
    [[email protected] ~]$ chsh
    Shell für buzz-dee ändern.
    Passwort: 
    Neue Shell [/usr/bin/fish]:             
    [[email protected] ~]$ echo $SHELL
    /bin/bash
    [[email protected] ~]$
  • from the Arch Wiki:

    In Arch, there are a lot of shell scripts written for Bash, and these have not been translated to fish. It is advisable not to set fish as your default shell because of this. The best option is to open your terminal emulator with a command line option that executes fish. For most terminals this is the -e switch, so for example, to open gnome-terminal using fish, change your shortcut to use: gnome-terminal -e fish

    Personal: http://michaeltunnell.com
    Business: http://visuex.com

  • @MichaelTunnell said:

    from the Arch Wiki:

    In Arch, there are a lot of shell scripts written for Bash, and these have not been translated to fish. It is advisable not to set fish as your default shell because of this. The best option is to open your terminal emulator with a command line option that executes fish. For most terminals this is the -e switch, so for example, to open gnome-terminal using fish, change your shortcut to use: gnome-terminal -e fish

    from the Arch Wiki:

    The factual accuracy of this article or section is disputed.

    Reason: Changing the default shell should not interfere with the execution of shell scripts, so long as they begin with a proper shebang line. (Discuss in Talk:Fish#)

    Also, that is not really an answer to my question.

  • @BuZZ-dEE
    Works for me

    [[email protected] ~]$ chsh -s /usr/bin/fish 
    Changing shell for balki.
    Password: 
    Shell changed.
  • @balkierode said:

    @BuZZ-dEE
    Works for me

    [[email protected] ~]$ chsh -s /usr/bin/fish 
    Changing shell for balki.
    Password: 
    Shell changed.
    

    Great, but also a useless information for me.

  • @BuZZ-dEE said:

    On another computer, it seems that I can change the default shell, but it also does not work.:

    [[email protected] ~]$ chsh
    Shell für buzz-dee ändern.
    Passwort: 
    Neue Shell [/bin/bash]: 
    [[email protected] ~]$ echo $SHELL
    /bin/bash
    [[email protected] ~]$ chsh -s /usr/bin/fish 
    Shell für buzz-dee ändern.
    Passwort: 
    Shell geändert.
    [[email protected] ~]$ chsh
    Shell für buzz-dee ändern.
    Passwort: 
    Neue Shell [/usr/bin/fish]:             
    [[email protected] ~]$ echo $SHELL
    /bin/bash
    [[email protected] ~]$
    

    Seems to be solved after restart. Before I only closed all terminals and started a terminal to test it. That seems to be not enough.

fish1 default4 shell13 Posts 8Views 2712
Log in to reply