• How to mount .iso file in Antergos linux


    I am trying hard to find the solution and already did some homework but still I am not able to mount the ISO image. Used fuseiso, file-roller but nothing is working. Please help!

  • Please any one can solve this?

  • You do not have to use file-roller, that is to decompress files you have to do is download the image and burn it to a CD or DVD or flash drive. Record antergos image directly.-

  • I don’t know if I get your question. If you want to mount an iso file you can use the loop option:

    sudo mount -o loop disk1.iso /mnt

    Cheers!

  • @karasu Still I can’t do that…After your suggestion…I run the command and get the following result.

    [[email protected] PluralSight PHP_ Get Started]$ sudo mount -o loop PluralSight PHP_ Get Started.iso /mnt
    [sudo] password for p4rv33n:

    Usage:
    mount [-lhV]
    mount -a [options]
    mount [options] [–source] <source> | [–target] <directory>
    mount [options] <source> <directory>
    mount <operation> <mountpoint> [<target>]

    Mount a filesystem.

    Options:
    -a, --all mount all filesystems mentioned in fstab
    -c, --no-canonicalize don’t canonicalize paths
    -f, --fake dry run; skip the mount(2) syscall
    -F, --fork fork off for each device (use with -a)
    -T, --fstab <path> alternative file to /etc/fstab
    -h, --help display this help text and exit
    -i, --internal-only don’t call the mount.<type> helpers
    -l, --show-labels lists all mounts with LABELs
    -n, --no-mtab don’t write to /etc/mtab
    -o, --options <list> comma-separated list of mount options
    -O, --test-opts <list> limit the set of filesystems (use with -a)
    -r, --read-only mount the filesystem read-only (same as -o ro)
    -t, --types <list> limit the set of filesystem types
    –source <src> explicitly specifies source (path, label, uuid)
    –target <target> explicitly specifies mountpoint
    -v, --verbose say what is being done
    -V, --version display version information and exit
    -w, --rw, --read-write mount the filesystem read-write (default)

    -h, --help display this help and exit
    -V, --version output version information and exit

    Source:
    -L, --label <label> synonym for LABEL=<label>
    -U, --uuid <uuid> synonym for UUID=<uuid>
    LABEL=<label> specifies device by filesystem label
    UUID=<uuid> specifies device by filesystem UUID
    PARTLABEL=<label> specifies device by partition label
    PARTUUID=<uuid> specifies device by partition UUID
    <device> specifies device by path
    <directory> mountpoint for bind mounts (see --bind/rbind)
    <file> regular file for loopdev setup

    Operations:
    -B, --bind mount a subtree somewhere else (same as -o bind)
    -M, --move move a subtree to some other place
    -R, --rbind mount a subtree and all submounts somewhere else
    –make-shared mark a subtree as shared
    –make-slave mark a subtree as slave
    –make-private mark a subtree as private
    –make-unbindable mark a subtree as unbindable
    –make-rshared recursively mark a whole subtree as shared
    –make-rslave recursively mark a whole subtree as slave
    –make-rprivate recursively mark a whole subtree as private
    –make-runbindable recursively mark a whole subtree as unbindable

    For more details see mount(8).

    Again please help!

  • There should be a program called furius iso that may help you, install that and give it a try.

  • I tried and install Furius iso mount but after mounting my .iso file it shows a blank folder with no any containt. I think it is still not working…

  • When there are spaces in a filename you must surround it by quotes on the command line like this:

    sudo mount -o loop "PluralSight PHP_ Get Started.iso" /mnt
    
  • I use mounty from AUR “yaourt -S mounty” if you can’t mount with mounty and the other programs redownload the iso image, maybe its corrupted.

  • hii @parveen-kumar

    is this solved??

  • For GUI mounter its fuseisomount from AUR

  • It’s Not solved yet! Getting following error…

    [[email protected] PluralSight PHP_ Get Started]$ sudo mount -o loop “PluralSight PHP_ Get Started.iso” /mnt
    [sudo] password for p4rv33n:
    mount: wrong fs type, bad option, bad superblock on /dev/loop0,
    missing codepage or helper program, or other error

       In some cases useful info is found in syslog - try
       dmesg | tail or so.
  • Ok, do this.
    If you haven’t yet, create a mount directory. — “sudo mkdir /mnt/iso” (name it whatever you want)
    Then, open a command line where the .iso file is (with Pcmanfm, press F4), then do— “sudo mount -t iso9660 -o loop PluralSight PHP_ Get Started.iso /mnt/iso”.
    Now, in order to get the .iso file name right, is better if you let the command line interface to autocomplete it, write “Plural” and press Tab, it should complete the name automatically.
    As far as this thread goes, I didn’t see you made a mount point. A mount point has to be done, that’s what the “mkdir” command is for.
    Follow this instructions and let me know how it goes.
    Good luck. :)

  • @Rolando-E-Rolon : You can mount in /mnt, that’s not the problem.

    @parveen-kumar : Just after trying to mount it, run (as suggested) dmesg | tail and post it here.

    Cheers!

  • @karasu I know it should work, but I found, more than once, that it doesn’t. I always ha to make my mount point a couple of times in the past or I would get errors. Since then, I only do it that way, cause I know is a sure method.

mount iso1 Posts 15Views 4468
Log in to reply