• UEFI+GPT+minimal-2015-06-03-x86_64 Won't boot


    Sorry, I couldn’t find the forum rules.

    I guess I’ll start from the beginning.

    I used Rufus on Windows 7 to write the ISO to a USB (I didn’t know there were recommended programs I was suppose to use) which ask to update a few files. I don’t remember which but the ISO booted fine. it was in text mode I guess(where you have to type start instead of a GRUB menu), but it started just fine in Openbox, I ran:

    sudo pacman -Syy
    then:
    sudo pacman -Sy cnchi
    To donwload version 0.8.15X I believe, if my memory is right.(I think the original was 0.8.137) I did this because yesterday I tried to install it and I got the famous cnchi can’t continue error. I checked the log and it had a corrupt package right before it gave the error(side note, can’t you just have it redownload the corrupt packages). I chose the Advanced Install option, I click new partition table and selected GPT here’s my table:

    Device      Type    Mount point   Format  Size
    /dev/sda1  bios-gpt-boot                    2M
    /dev/sda2  swap         swap      Yes       8G
    /dev/sda3  ext4         /         Yes     100G
    /dev/sda4  ext4         /home     Yes    2742G
    free space none                           150G
    

    I also chose Cinnamon (seems a lot of people have problems with it). The installation was successful (I was so happy and relieved) so I hit the restart now button or whatever it said. it restarted into a blank screen with the text cursor blink on the screen in a few weird place then went to the UEFI BIOS settings. So I guess it failed to boot and went to the default thing to do aka the UEFI BIOS settings.
    I checked the ISO’s md5sum and its correct. I really REALLY don’t want to install again Id rather fix it because my internet is really slow the average speed is 120Kbps and sometimes more like 88Kb, but thank you, thank you, thank you for reading and any help would be much appreciated.

    PS. How do you get code tags to work? Sorry for the bad grammar. I’ve been using linux for 5 years. Im no guru, but Im definitely not a complete idiot. I’ve used multiple OS’s:

    • Zorin OS

    • Multiple Ubuntus

    • Arch Linux(My Preferred)

    • Bridge Linux

    • Manjaro

    • Linux Mint

    • Windows 7(against my will)

    • Windows 10(Got Curious)
      and more on multiple computers. This is my first time dealing with UEFI, GPT, and Antergos. My hardware, just in case:

    • Asus Z87-A

    • i5 4670k NO OC

    • GTX 750 Ti EVGA NO OC

    • 3TB SATA 3

  • @saitomaligo
    You can try to restore your bootloader (did you use grub or gummiboot?)

    I do not use UEFI myself, so I can’t test this commands. Tell me if you managed to solve this.

    If you used GRUB:

    1. Boot from the ISO
    2. Mount your root partition
      mount /dev/sda3 /mnt
    3. Chroot to your root partition
    mount -t proc proc /mnt/proc
    mount -t sysfs sys /mnt/sys
    mount -o bind /dev /mnt/dev
    mount -t devpts pts /mnt/dev/pts/
    chroot /mnt
    
    1. Install mtools and os-prober (just in case)
      pacman -S mtools os-prober

    2. Mount your efi partition:

    sudo mkdir /boot/efi 
    sudo mount /dev/sda1 /boot/efi
    
    1. Reinstall Grub:
      sudo grub-install --target=x86_64-efi --efi-directory=/boot/efi --recheck

    Cheers!

  • I feel for you mate, I was in the same boat as you. Took me 2 days to get an install. I gave up on trying to have a separate home partition, encryption, lvm or btfs as my file system and it would only install on ext4 . Also I’m a big fan of Cinnamon on Mint, but forget it on any other distro, stuff breaks, applets can’t be downloaded and extensions don’t work. I went with Gnome in the end, everything works including bluetooth. Yes, it’s down to personal preference, but I need shit to work at least!
    Good luck…

  • @karasu Thanks for your help.

    I chrooted in tried to use pacman. Apparently its not installed! lol.
    so I skipped that step went straight to mounting the bios-gpt-boot to /boot/efi but it said it was write protected and something about bad sector or code block.

    So in light of pacman not even being installed. I’ve decided to install again this time using one of the recommended usbwriters and not updating cnchi. Thanks again for all the help.

  • Update, it doesn’t seem to work on “Erase the disk” setting. My guess is it automatically tries MBR which doesn’t work because this is a 3tb drive.

    also in “Choose where Antergos is installed” after creating a new GPT it gives a message:

     GRUB requires a BIOS Partition in BIOS systems to embed its
     core.img file due to lack of post-MBR embed gap in GPT disks.
    
    Cnichi will create this BIOS Boot Partition for you.
    

    I don’t know if this helps because you don’t have uefi and probably a 3tb HDD(I don’t see where you choose GRUB or Gummiboot. I’ll do more research)

  • @saitomaligo
    You only can choose between gummiboot/grub in advanced not in “erase disk”

    If UEFI is detected, “erase disk” uses GPT not MBR.

  • @karasu
    I figured out the problem, it wasn’t detecting UEFI(My bad). I changed a few settings in the BIOS and reinstalled in UEFI mode. everything is all good. Thanks for the help and sorry to be a bother.

    P.S. how do you mark as solved.
    I really like your OS it has every thing I needed and more.

    Wiki for installation is Empty [http://antergos.com/wiki/install/installing-antergos/](link url)

    Things I changed in BIOS

    • You can’t disable secure boot unless you enable Windows Mode then delete the keys.(I chose Other in the beginning and hoped it would work (which it did NOT))
    • Changed Boot to use UEFI first.(I could of swore I had done that in the beginning!)
uefi35 cinnamon72 gpt6 boot163 Posts 7Views 2247
Log in to reply