• Cnchi can't continue


    Having a problem installing Antergos, have tried with different ISOs, checked integrity both times, same issue. Changing the DE does not change anything.

    Log file:
    https://pastebin.mozilla.org/8838681

    If anyone could help me understand what is going wrong it would be much appreciated!

  • @AlanJohnson said:

    The sha256sum check is failing, so pacman gives an error and Cnchi stops. I’ve never got this kind of error so it’s very difficult to debug it from here.

    Please, before running Cnchi, update pacman database (this should not be done in an installed system). From a terminal, run:

    sudo pacman -Syy

    and then try again. I don’t really know if this will help or not, so if it doesn’t don’t get mad at me.

    Cheers!

  • Ah, I’m afraid that didn’t make any difference.

    I still don’t really understand why this is happening, it’s not specific to my ISO, why is the sha256sum check failing?

  • @AlanJohnson

    why is the sha256sum check failing?

    Good question, I don’t get it either, and as I’m unable to reproduce it here it’s nearly impossible to fix.

    Which Antergos ISO are you using?

  • antergos-2015.06.03-x86_64.iso from the downloads page

  • Which language are you choosing in the first screen?

  • English (UK)

  • Hi ppl!

    Please dont take my comments as rude ones, since the effort to make an easy archlinux install is really hard. I`ve installed Arch Linux a dozen times, and got back to Ubuntu due to the excessive time you spend calibrating the system.

    Definitely this is not a friendly installer yet, there are so many rough edges.

    I`ve tried in 3 completely different computers a dual(triple) boot solution and 2 different USB disks (Kingston and Sandisk), created with DD from 06.03 iso:

    AMD A6 with Radeon, multiple HDs with Windows 8 / ElementaryOS
    Intel Core i7 1st gen with Nvidia 9500GT, with Linux Mint 17.2
    Lenovo Ultrabook with 4th gen Core i5, Intel Graphics with Windows 10.

    First of all is that before login error, you can ignore, so, ok, little scary.

    Then cnichi doens`t find the last version from .137, you need to manually run pacman -Syy, and then pacman -S cnchi to get manually .151-2.

    If you dont do that, you got packages errors, or you cant format the partitions correctly (even deleting them from gparted).

    If you get some error, cnchi doesnt relase the mounted /install, so even with umount -f you get ‘/install: target is busy’ errors, and you cant restart cleanly the cnchi, you need to restart the entire computer to be safe.

    Even after updating the cnchi, you get errors [1] on creating package list (dnsutils package broken), so you need to delete /var/cache/pacman/pkg, and another pacman -Syu, then you need again to force umount with fuser -km /dev/sdaX, umount /install.

    [1] from /tmp/cnchi.log:
    [2015-07-09 15:24:34] [metalink] ERROR: Can’t find these packages: dnsutils
    [2015-07-09 15:24:34] [download] ERROR: Error creating metalink for package dnsutils. Installation will stop

    I really think you need to respin the iso again to avoid these issues. I’m yet trying, but i’m feeling very scared, even with 15 years of linux experience!

    I will get back after -Syu finishes with results, but I’ve already spent like 5 hours trying on these different computers vs usb disks, reading tons of posts here and such.

    But again, I know it’s hard to get all these stuff correctly, I hope you can find ways to get the installation smoothier.
    Cheers!

  • @rodrigodk I’ve had the exact same experience trying to install antergos. Unfortunately pacman -Syu crashed my system and I didn’t catch what the error was. Strangely, the installation works if I do it with virtualbox. I really like antergos but I’m quite upset I can’t properly install it on my system.

  • @meras I’ve narrowed down a bit the error with these steps:

    You can’t pacman -Syu, since you’ll run out of temporary space.

    1. Clean Boot!
    2. Wait Cnchi try to update (it fails silently saying you have the latest version)
    3. Run in terminal:
      pacman -Syy
      pacman -S cnchi dnsutils

    It will say that dnsutils is replaced by bind-tools.

    Run cnchi again, you now have the 0.8.151 version.

    Now I get consistently this error:

    [2015-07-09 16:20:24] [metalink] ERROR: Can’t find these packages: dnsutils
    [2015-07-09 16:20:24] [download] ERROR: Error creating metalink for package dnsutils. Installation will stop
    [2015-07-09 16:20:24] [process] ERROR: “Can’t create download package list. Check log output for details”

    Packages selected by cnchi (from same log)
    [2015-07-09 16:20:24] [process] DEBUG: [‘alsa-utils’, ‘antergos-keyring’, ‘antergos-mirrorlist’, ‘b43-fwcutter’, ‘base’, ‘base-devel’, ‘bash-completion’, ‘crda’,** ‘dnsutils’**, ‘dosfstools’, ‘haveged’, ‘gzip’, ‘ipw2100-fw’, ‘ipw2200-fw’, ‘modemmanager’, ‘net-tools’, ‘ntfs-3g’, ‘openssh’, ‘pkgfile’, ‘sudo’, ‘tar’, ‘transmission-cli’, ‘unzip’, ‘unrar’, ‘usb_modeswitch’, ‘wget’, ‘whois’, ‘wireless_tools’, ‘wpa_actiond’, ‘zd1211-firmware’, ‘accountsservice’, ‘antergos-wallpapers’, ‘chromium’, ‘chromium-pepper-flash’, ‘gst-libav’, ‘gst-plugins-bad’, ‘gst-plugins-base’, ‘gst-plugins-good’, ‘gst-plugins-ugly’, ‘gstreamer-vaapi’, ‘gstreamer0.10-plugins’, ‘libdvdcss’, ‘libreoffice-installer’, ‘lightdm’, ‘lightdm-webkit-theme-antergos’, ‘mesa’, ‘mesa-vdpau’, ‘numix-frost-themes’, ‘numix-icon-theme’, ‘numix-icon-theme-square’, ‘pamac’, ‘pavucontrol’, ‘pulseaudio-alsa’, ‘ttf-bitstream-vera’, ‘ttf-dejavu’, ‘ttf-liberation’, ‘upower’, ‘xf86-input-synaptics’, ‘xf86-video-fbdev’, ‘xf86-video-vesa’, ‘xorg-apps’, ‘xorg-fonts’, ‘xorg-server’, ‘xorg-server-utils’, ‘xorg-xinit’, ‘xorg-xkill’, ‘antergos-gnome-defaults-list’, ‘baobab’, ‘bijiben’, ‘brasero’, ‘cdrkit’, ‘cinnamon’, ‘cinnamon-control-center’, ‘cinnamon-desktop’, ‘cinnamon-menus’, ‘cinnamon-session’, ‘cinnamon-settings-daemon’, ‘cinnamon-screensaver’, ‘cinnamon-theme-nadia’, ‘cjs’, ‘eog’, ‘evince’, ‘file-roller’, ‘gedit’, ‘gnome-calculator’, ‘gnome-common’, ‘gnome-disk-utility’, ‘gnome-keyring’, ‘gnome-music’, ‘gnome-photos’, ‘gnome-screenshot’, ‘gnome-system-monitor’, ‘gnome-terminal’, ‘gnome-themes-standard’, ‘gvfs-mtp’, ‘hicolor-icon-theme’, ‘libgnomeui’, ‘muffin’, ‘nemo’, ‘nemo-fileroller’, ‘nemo-preview’, ‘nemo-share’, ‘network-manager-applet’, ‘networkmanager-openvpn’, ‘networkmanager-pptp’, ‘pidgin’, ‘totem’, ‘transmission-gtk’, ‘xdg-user-dirs-gtk’, ‘zukitwo-themes’, ‘ntp’, ‘lib32-mesa-libgl’, ‘lib32-mesa’, ‘xf86-video-nouveau’, ‘gufw’, ‘ufw’, ‘grub’, ‘os-prober’]

    It’s obvious that dnsutils doesn’t exist anymore, but how I can tell cnchi 0.8.151 to use bind-tools instead dnsutils?

  • @rodrigodk That’s where I arrived as well and I don’t know how to switch dnsutils to bind-tools. Perhaps trying out the test build is worth a shot.

  • @meras said:

    @rodrigodk That’s where I arrived as well and I don’t know how to switch dnsutils to bind-tools. Perhaps trying out the test build is worth a shot.

    Hmm didn’t know about test builds, downloading 07.01 right now.

    But with so many bugs on 06.03, why offer that as oficial release?

    It’s not better to offer test builds directly with a bold advice for average users?

  • Hi all,

    Thanks for your feedback.

    It seems that the package list is not updated in our server. As a workaround, you can pass cnchi your own list.
    Here you have an updated version: https://raw.githubusercontent.com/Antergos/Cnchi/master/data/packages.xml
    Just run cnchi with the -p option, giving the new packages.xml file, this way:
    sudo -E cnchi -dv -p packages.xml
    Thanks again!

    @lots-0-logs : Can you check packages.xml from the server? It seems it still has dnsutils in it.

  • @karasu I have another error. When cnchi fails, it wont release/umount ‘/install’, so if you start cnchi again, the partition step will throw a “cant format” error. (But continues to install on mounted /install, I can override with fuser -km /dev/sdaX, umount /install)

    Now with this xml + 07.01 it seems fine about dnsutils, It is downloading/installing packages right now.

    Will return after install finishes to give feedback.

    Edit: I will give feedback tomorrow, since I’m hurry for another task. SystemD download stalled 5 minutes ago (don’t know if its really downloading, since I have no feedback from installer about download speed).

  • @karasu Thank you! that fixed the issue. I was able to install antergos using thenewest cnchi and the xml file you provided.

  • (don’t know if its really downloading, since I have no feedback from installer about download speed).

    Next Cnchi version will show it (it’s already coded).

    @meras : Glad it worked!

  • @karasu one final and kind of off topic question. I’ve a broadcom wireless board which needs drivers. Is it possible to install the drivers from the live usb environment in to the already existing system?

  • Is it possible to install the drivers from the live usb environment in to the already existing system?

    Short answer is no. Cnchi should have done this for you, but the hardware module had some flaws (in the newest Cnchi version, still unreleased, this should be fixed, hopefully).

    Depending on your broadcom device you have to install one package or another. In the Arch wiki you’ll find all info:
    https://wiki.archlinux.org/index.php/Broadcom_wireless

    Cheers!

    EDIT: The easiest way to know which driver where you using is to boot again using the iso and in a terminal, type lsmod. It will show all loaded modules. Search for broadcom-wl or b43 or bcm, …

  • @karasu said:

    Short answer is no. Cnchi should have done this for you, but the hardware module had some flaws (in the newest Cnchi version, still unreleased, this should be fixed, hopefully).

    Turns out it was possible and and much more simple than anything the wiki suggests. I simply mounted my local install and chrooted into it using the live usb. Since the live environment had working wifi I was able to use pacman and get the packages I needed. Looks like I’ll be able to get back to work tomorrow after all! Apologies for derailing the thread.

  • Feedback about my installation:

    Dowloaded the 07.01 iso today, installed fine.

    Thanks guys!

Posts 20Views 5386
Log in to reply