• TESTERS NEEDED - A New Set Of ISO Images Are Available On The Build Server


    There are new ISO Images available on the build server. They worked fine in our testing but we would like to get a few more real-world tests to confirm that the images are good. If all goes well, these images will replace the images currently available on the main download page. If you have the time, please test them and let us know how it goes. Thanks!

    http://build.antergos.com/browse/testing

  • Any particular testing scenarios that you are interested in having done? If not, I’ll just play with various combinations.

    Personal: http://michaeltunnell.com
    Business: http://visuex.com

  • A long and tedious post. Excuse: no answer expected. Can be safely ignored.

    Testing ISO: antergos-2015.06.28-x86_64.iso

    Downloaded from: http://build.antergos.com/browse/testing

    Computer the ISO is tested on:

    BIOS: UEFI, but disabled
    Secure Boot: present, but disabled
    De facto boots in legacy BIOS mode.

    RAM: 16G

    HDD: MBR-partitioned. 14 available partitions. Some partitions are formatted during install, but never deleted or created. Installer’s partition manager, if any, is never used.

    DEs installed:

    • Mate
    • Cinnamon
    • Gnome
    • Kde4

    Addons installed:

    • AUR yes
    • BT yes, where applicable (= all but Mate)
    • TTF no
    • FF yes
    • LO yes
    • Printing yes
    • SMB no

    Bootloader is never installed.

    Autologin is enabled in all 4 DEs.

    Cnchi on ISO: 0.8.151
    Cnchi in repo: 0.8.151. Verified by hand with Chromium.

    1. Installer

      Starting with Mate. Cnchci, started on boot, is never closed or restarted. Boot, wifi to Internet, check for newer cnchi version, corresponds to those in repo (verified in Chromium), go with installation.

      No problems at all up to the end of the installation. Nice surprise! Very good.

      Selecting and indicating the swap partition as such doesn’t make anymore bad jokes as in the past. Good.

      Memory usage during “Donwloading packages” stages remains below 780 MiB. Good.

      During “Installing packages” stage memory usage increases up to 1,3 GiB, and never exceeds it. Good.

      Installer never uses swap space. Good.

      The same applies to three other DEs - Cinnamon, Gnome, Kde4. This time the installer works really well.

      Score: 5/5

    1. First run: Mate

      Differently from the past, the user gets effectively logged in automatically into DE on the very first boot. Good.

      Network connection, used during install, is remembered and automatically reconnected on login. No manual intervention required. Nice.

      As expected, mate-mint-menu package still doesn’t like the recent python2-2.7.10 (note for myself: downgrade and pin python2 to 2.7.9). It means that mintmenu applet is not added to the panel. On first boot the user remains without any menu in the panel. Bad.

      The rest of DE works as expected. Good.

      Score: 4/5

    1. First run: Cinnamon

      As forMate, effectively logs in automatically on first boot, remembers and reconnects to wifi Internet connection, used during install. Good.

      By Antergos habit, panel’s applets don’t follow the default Cinnamon configuration. Every time I must reset them to default config, before being able to use them normally. Unrelated to first boot evaluation.

      Everything else works nicely in Cinnamon on first boot. Good.

      Once panel applets are reset to default config, Cinnamon becomes simply perfect. Good.

      Score: 5/5

    1. First run: Gnome

      Boots, logs in, connects to Internet automatically. No manual intervention required. Everything works. Too good. Quite boring.

      Score: 5/5

    1. First run: Kde4

      Finally! Something that’s not working right OOTB.

      Kde4 boots, automatically starts to login into DE. But fails doing so. KSplash stucks forever on the first icon.

      It’s not Antergos fault. It’s a common trouble for many Arch installers nowdays.

      It’s the result of mixing together old-style well-working Kde4 and newer full-of-bugs bad-working Plasma5 by Kde project.

      Kde4 still can be fixed and used in Antergos. Though it requires some experience from the user. Bad.

      Otherwise, it simply doesn’t start. Very bad.

      Score: 0/5

    1. Subsequent runs

      Mate, Cinnamon, Gnome work perfectly. Without a hitch. Excellent.

      All three by default use LibreOffice Writer for editiong plain ASCII files. Probably by design. The default text editor for plain text files can be easily changed. Never mind.

      Subscore for Mate, Cinnamon, Gnome: 5/5

      Kde4 doesn’t start. Stop.

      Subscore for Kde4: 0/5

    1. Final score

      Overall for Mate, Cinnamon, Gnome, Kde4: 4/5

  • i really like to participate but as my Internet connection is very low i must say im really am sorry

  • I have problems with the test iso.

    I downloaded the 64 bit version.
    I want to install it with uefi and secure boot enabled.

    My rig
    lenovo flex 2 15D

    My steps:
    gnome desktop
    manual partitioning
    /boot (ext4)
    /boot/efi (fat32)
    swap (swap)
    / (f2fs)
    grub bootloader

    It installs fine but I can not boot it.
    Tried to chroot and repair the bootloader but still no luck.
    Googled and found this (https://bugs.archlinux.org/task/45472)
    please downgrade efibootmgr.
    I already downgraded it on my machine but still no luck.

    I know, I know just disable secure boot…
    I do not want to. I have a tablet with secure boot only and I did like to install the 32 bit version of antergos on it.

    Anyone had luck with secure boot?

  • found a bug

    (i have 8 gb ram
    amd apu with shared gpu memory about 1.2 gb
    6.5 gb left for antergos)

    use the gnome live desktop and download something around 700mb.
    Now try to open terminal (or something else)
    error
    failed to execute child process input/output error

    I do not know why its happening. Maybe because I am downloading an iso to ram, maybe not. I can not open anything after this point. (logs included)

  • @curiouseag said:

    I know, I know just disable secure boot…
    I do not want to. I have a tablet with secure boot only and I did like to install the 32 bit version of antergos on it.

    Anyone had luck with secure boot?

    Antergos does not support Secure Boot as Arch doesn’t support it. It is technically possible but it would require you to compile your own kernel each time a kernel update is released. It’s simply not practical. AFAIK, the only distros that support Secure Boot are Ubuntu, Fedora, & openSUSE.

    @curiouseag said:

    I do not know why its happening. Maybe because I am downloading an iso to ram, maybe not. I can not open anything after this point. (logs included)

    That’s not a bug. The live environment is not intended to be used for downloading large files. If you need to download a large file you should save it onto an external drive.

    Cheers!

  • @lots.0.logs

    thx for your response

    understood but I still think its an bug because I have enough free ram. Going to use real storage next time.
    Other distribution support downloading of large files in live mode.

    Can you explain me what exactly is missing in the stock kernel configuration?
    I can compile a kernel since i used to stay with the current mainline build instead of arch stable.

  • Here is an explanation of booting a cutom kernel with secure boot enabled.
    https://en.opensuse.org/openSUSE:UEFI#Booting_a_custom_kernel

    I understand know why arch does not support it.

  • Kde 4 is up and running. A miracle.

    Without changing or touching anything, at a 1-day distance from initial antergos-2015.06.28-x86_64.iso install, Kde4 has decided to turn back to life. On its own. Without any intervention from the user side.

    1. First run: Kde4

    Computer boots. Kernel , display manager, Kde start without a problem. KSplash doesn’t hang anymore on first icon. Good.

    Autologin works. Good.

    Wifi Network connection, used during install, is reconnected automatically. Good.

    Score: 5/5

    1. Subsequent runs

    It’s really good old rock solid well working Kde 4. Not a Kde 5 (Plasma 5) nonsense. Very good!

    This time Antergos team has decided to use Lancelot menu launcher. May be changed to anything else with extreme ease. Never mind.

    Max respect to Antergos devs.

    Score: 5/5

  • Testing ISO: antergos-2015.06.28-x86_64.iso

    1. Daily use: Mate, Cinnamon, Gnome

    In three days no problems encountered. Everything works as usual.

    Score: 5/5

    1. Daily use: Kde4

    As more Kde5 packages are mixed up with Kde4, they break more and more Kde4 functionalities. Two most noticeable annoyances are:

    • Konsole panel disappeared in Dolphin. It’s the panel that opens at the bottom of Dolphin’s window when F4 is pressed. The bottom panel is still opens, but it’s empty - there’s no Konsole in it.

    • GTK configuration module disappeared from System Settings. It is usually found in System Settings → Application Appearance → GTK icon in the left pane. There’e no graphical tool to configure GTK apps anymore.

    Two solutions for Kde4 are:

    • Dolphin without Konsole: install konsolepart4 package:

      sudo pacman -S konsolepart4
      

      Logout - login. Done. Konsole is back.

    • System Settings without GTK: install kde-gtk-config-kde4 package (from AUR):

      sudo pacman -S kde-gtk-config-kde4
      

      The package conflicts with installed by default kde-gtk-config one. The latter is for Kde5 now. It doesn’t work in Kde4 anymore. Simply allow kde-gtk-config to be uninstalled automatically during kde-gtk-config-gtk installation.

      Logout - login. Done. GTK is back.

    Score: 4/5

  • Started with 2015,06,28-x86-64 for a mate installation
    TWO screens and iso is on usb
    get my OH NO screen
    then I press enter to execute the button log out
    i become the greeter
    and click on antergos !!
    I relogin!
    cnchi v 0,8,151 is the latest version
    all screens work fine - choose automatic partitioning and choose MATE installation
    choose all options
    downloads work great - no packages that go on “forever”.
    Everything installed fine.

    But on reboot

    Mintmenu crash when restarting

    Message = Mintmenu has quit unexpectedly - if you reload a panel object it will be automatically be added back to the panel"
    don’t reload or reload

    Pressing Reload does not help the issue as there is an error in syntax.

    Restarting does not help
    ctrl alt backspace does not help
    mintmenu is not available no applications can be selected
    no crtl+alt+ T to get to the terminal
    starting mintmenu in the terminal reports
    line 7 error in /usr/bin/mintmenu
    print "mintMenu - the advanced Mate menu…
    Syntax error : missing parentheses in call to print

    Mintmenu can not be added to panel BUT
    Main Menu and Menu Bar can be addedIMG_0917.JPG

  • @erikdubois said:


    Mintmenu crash when restarting

    downgrade python2 package from 2.7.10 to 2.7.9.

    pin it in /etc/pacman.conf: uncomment the line IgnorePkg = and make it read IgnorePkg = python2 to avoid re-upgrading back to 2.7.10.

    mintmenu will turn back :smiley: .

cnchi109 testing6 installation205 iso47 Posts 14Views 3891
Log in to reply