• Share folder in nautilus


    Hi Everyone
    the sharing tab in nautilus is missing
    i installed samba and smbclient but nothing changed
    so how can i share a folder also i cannot access to the shared file on other computer from "Browse network"
    my gnome version:3.10
    tnx

  • Hi Everyone
    the sharing tab in nautilus is missing
    i installed samba and smbclient but nothing changed
    so how can i share a folder also i cannot access to the shared file on other computer from "Browse network"
    my gnome version:3.10
    tnx

  • Was it working before now or is this the first you noticed it? Some things to check:

    1. Ensure your system is updated (sudo pacman -Syu)
    2. Ensure you have “gnome-user-share” package installed
    3. Check in gnome control center under “Sharing” and ensure its enabled
    4. Restarting both PCs involved, one at a time, is a good idea.

    Hopefully it was one of those easy fixes

    Regards,

  • first tnx for your reply
    i do what u said but it didn’t work
    becuase the samba wont start and in systemctl show failed next to the samba.service
    after that i found a package in aur : [aur.archlinux.org/packages/nautilus-share/][0]
    and i got this error when try to share a folder

    Samba's testparm returned error 1: Load smb config files from /etc/samba/smb.conf  
    rlimit\_max: increasing rlimit\_max (1024) to minimum Windows limit (16384)  
    Processing section "[homes]"  
    Processing section "[printers]"  
    Loaded services file OK.  
    WARNING: 'workgroup' and 'netbios name' must differ.
    

    : http://aur.archlinux.org/packages/nautilus-share/

  • It should work without the extra package you installed. Try removing and then reinstalling samba to ensure you are using the default settings. Use this command:

     sudo pacman -Rddn samba && sudo pacman -S samba --force
    

    As long as your windows computers have the default workgroup setting you should see them once all systems have been restarted. Please let me know the result

    Regards,

  • Im confused…

    I’m pretty sure I have nautilus. I went into the terminal and ran:

    sudo pacman -S gnome-user-share
    

    but I still do not have the ‘Sharing’ tab when going into the ‘Properties’

    I noticed in the ‘Sharing’ section within the system settings that I now have Personal File Sharing and Bluetooth Sharing. I have enabled Personal File Sharing - still can’t share a folder.

    Also when I select ‘Browse Network’ I do not see my Windows shares. How do I know i’m on the same workgroup?
    I also tried to ‘Connect to Server’ by typing in my Windows share (ie. //10.0.0.10/share/ and cifs://10.0.0.10/share and smb://10.0.0.10/share) but it would only accept dav:// connections (Connect button becomes enabled when I type dav:// only)

    So as of now, in summary, I have no idea how to:
    1. Connect to a Windows share using 'Connect to Server’
    2. Share a folder in Antergos
    3. And how to browse network shares on my workgroup by using ‘Browse Network’.

    Thanks for your help.

    Never was anything great achieved without danger. - Niccolo Machiavelli

  • @“juice”:235cprhy said:

    Im confused…

    I’m pretty sure I have nautilus. I went into the terminal and ran:

    sudo pacman -S gnome-user-share
    

    but I still do not have the ‘Sharing’ tab when going into the ‘Properties’

    I noticed in the ‘Sharing’ section within the system settings that I now have Personal File Sharing and Bluetooth Sharing. I have enabled Personal File Sharing - still can’t share a folder.

    Also when I select ‘Browse Network’ I do not see my Windows shares. How do I know i’m on the same workgroup?
    I also tried to ‘Connect to Server’ by typing in my Windows share (ie. //10.0.0.10/share/ and cifs://10.0.0.10/share and smb://10.0.0.10/share) but it would only accept dav:// connections (Connect button becomes enabled when I type dav:// only)

    So as of now, in summary, I have no idea how to:
    1. Connect to a Windows share using 'Connect to Server’
    2. Share a folder in Antergos
    3. And how to browse network shares on my workgroup by using ‘Browse Network’.

    Thanks for your help.[/quote:235cprhy]

    When it comes to networking, there really isn’t one definitive answer. I’m sure we can get you up and running though! Are any of the other systems running Windows 7 or 8? If so, you need to make sure to disable Homegroups as samba does not support it.

    Check here for details:
    [http://www.pcadvisor.co.uk/how-to/windows/3434911/how-share-folders-without-homegroups-in-windows-7/][2]">[http://www.pcadvisor.co.uk/how-to/windo][3] … windows-7/

    Now once you have done that go ahead and restart the windows machines while you make sure Antergos is ready to share. You will need to have these packages installed: samba, libwbclient, gvfs-smb, gnome-user-share, & cifs-utils. Now tell systemd to start samba at boot: “sudo systemctl enable samba” Restart your system. You should now be in business! One thing I forgot to mention is that these instructions assume all machines are using default settings for dhcp, workgroups, ips, etc. Please let me know if its working for you!

    Regards,

    [2]: <a href=
    [3]: http://www.pcadvisor.co.uk/how-to/windo

  • Thanks for your reply lots.0.logs

    I already had those packages installed. Only difference I did was as you said, start the samba service, restart, and BAM I see all my windows network shares by going to ‘Browse Network’

    So, to update:
    As of now, in summary, I CAN:
    1. Connect to a Windows share using 'Connect to Server’
    3. Browse Windows shares on my workgroup by using ‘Browse Network’.

    I still cannot:
    3. Share a folder in Antergos (anything BUT the public folder)

    Any ideas?

    Never was anything great achieved without danger. - Niccolo Machiavelli

  • Yep! You just need “yaourt nautilus-share” then restart nautilus, right click, Share!

    Cheers!

  • WOOHOOO!!! I now see ‘Sharing Options’

    Yet another issue (WTF)…

    When I installed nautilus-share it then said:

    Please add the line 'include = /etc/samba/usershare.conf’
    in the [global] section of /etc/samba/smb.conf and restart samba.
    All users that want to use nautilus-share MUST be in the ‘users’ group.

    After browsing through to /etc/samba/ i noticed there was a smb.conf.default file (not smb.conf) so I did

    sudo cp smb.conf.default smb.conf
    

    Then added include = /etc/samba/usershare.conf to the global section of smb.conf

    Then I restarted samba by doing

    sudo systemctl restart samba
    

    And now I am getting this when trying to make ‘Downloads’ folder a share:
    ‘net usershare’ returned error 255: net usershare add: cannot convert name “Everyone” to a SID. The connection was refused. Maybe smbd is not running.

    I then added include = /etc/samba/usershare.conf to smb.conf.default - same thing ^^

    Anymore ideas?

    Never was anything great achieved without danger. - Niccolo Machiavelli

  • Try changing [global] “security = share” to “security = user” and instead just pre-define allowed users with “valid users = yourusername”

    Regards,

  • from the arch wiki
    Nautilus and Nemo
    In order to access samba shares through Nautilus or Nemo, install the gvfs-smb package, available in the official repositories.
    Press Ctrl+l and enter smb://servername/share in the location bar to access your share.
    The mounted share is likely to be present at /run/user/your_UID/gvfs in the filesystem.
    Thunar and PCManFM
    For access using Thunar or PCManFM, install gvfs-smb, available in the official repositories.
    Go to smb://servername/share, to access your share.

    when I installed gvfs-smb everything worked!

    [img:1pt1tebw]http://i59.tinypic.com/33e3r08.png[/img:1pt1tebw]
    [b:1pt1tebw]Don't forget to mark your thread as [SOLVED] [/b:1pt1tebw]

Posts 12Views 6841
Log in to reply