• Changing Button Orientation in Gnome-Centric Apps?


    How do I rearrange the window decoration button order in Gnome-ish apps? I have arranged Cinnamon to have the close, maximize, and minimize buttons on the left side, because I got used to it from using Unity for so long. The Gnome-centric apps don’t obey this setting, so I need some help finding where to configure this.

    I found some stuffs online and made some edits using gconf-editor (i think) but it didn’t seem to work, so I’m guessing I targeted the wrong thing. Before I end up breaking something, I’d like some info from experienced folk ;)

  • Try using dconf-editor instead of gconf-editor. In dconf-editor go to:

    org/gnome/desktop/wm/preferences button-layout

    Instructions are contained in ‘description’ at the bottom of the screen.

    Alternatively, open a terminal and:

    gsettings set org.gnome.desktop.wm.preferences button-layout ‘close,minimize,maximize:’

    This seems to work for most applications but not for Chromium.

  • Hi

    Correction to the above post, please remove quotation marks from terminal command, it should read:

    gsettings set org.gnome.desktop.wm.preferences button-layout close,minimize,maximize:

  • This doesn’t seem to work. The setting is there, but the Gnome apps still don’t follow the rule. Could it be because I am running Cinnamon, and some package is missing that would make these Gnome apps follow directions? I recall this working when I used Gnome, but for some reason, it doesn’t in Cinnamon.

    A few apps in particular, Gedit and Totem.

  • @Myk-Robinson
    In terminal, dconf write /org/gnome/shell/overrides/button-layout "'close,minimize,maximize:'"
    Then restart the shell if needed: press Alt+F2, type r and press Enter.

  • @Yash did that and opened dconf-editor to confirm that key was added. It shows up in the editor, but totem and gedit still do not obey… Unruly punks…

    Any other ideas?
    thanks

  • This post is deleted!
Posts 7Views 1467
Log in to reply