• Intel HDA ALC269VC Audio Codec Combo Jack - Microphone Issues


    Hello there,

    I have recently installed Antergos (with Arch as a user background) on my Asus R704VC / Asus R75VC laptop and tried to get Teamspeak3 running when I noticed something:

    The only microphone it picks up is the internal (utterly crappy) one. I am blessed/cursed with a unified headphone/microphone jack, so I thought hulking through alsa settings would be a good shot. After quite a while of googling and reading, it appears that alsa itself is not very comfortable with that stupid HD Audio standard.

    So far my Codec has been identified as an ALC269VC Realtek codec, and after some further research I found two “fixes”.

    The first being to actually modprobe for the right HDA Model, appending model=headphone-mic post options snd-hda-intel to my audio.conf.

    No success.

    Another apparent fix was said be using hdajackretask and map the “Microphone” input to an unused pin, which for me would have been 0x18.

    No success, either.

    And after a whole nother 4 hours of searching, I ended up here asking if there are any more ideas floating around.

    If there are any logs that would help you, I’d be happy to comply - though I have no idea which ones would be the most useful, thus no logs are appended on this OP.

  • I had issue with sound only was able to work in one software at the time and with crap quality. Solved the issue by installing PulseAudio.

  • @Dominik-Köllges said:

    Asus R75VC

    Hi,

    Try creating this file: /etc/modprobe.d/modprobe.conf with the following contents:

    option snd-hda-intel model=headphone-mic
    

    Let me know if it helps. Cheers!

  • Sorry for the late reply, University suddenly got extremely timeconsuming (through which I actually forgot about the thread…)

    The modprobe options have been thoroughly tested with various model-entries, none of them working.

    Currently, I am back on Arch Linux but the same issue resides there. I have had it working on other distributions for sure, though.

    Seems to be an issue with arch-flavoured Distros in general, in my oppinion.

alc269vc1 audio30 realtek2 microphone11 combo jack1 Posts 4Views 1604
Log in to reply