• Systemd error message at boot: Failed to start Setup Virtual Console


    I woke up this morning to the following error message at boot:

    Jun 25 10:21:35 user systemd[1]: systemd-vconsole-setup.service: Main process exited, code=exited, status=1/FAILURE
    Jun 25 10:21:35 user systemd[1]: Failed to start Setup Virtual Console.
    Jun 25 10:21:35 user systemd[1]: systemd-vconsole-setup.service: Unit entered failed state.
    Jun 25 10:21:35 user systemd[1]: systemd-vconsole-setup.service: Failed with result 'exit-code'.
    

    Anyone else? Any idea what’s going on?

  • I have the same message after fresh installation.

  • Please, post here your boot journal:

    journalctl -xb

  • This post is deleted!
  • Hmmmm… despite following the instructions in the how to post a log thread, it still won’t upload. It makes it to 100 percent, but then says “413 request entity too large”. The file itself is just over 2.1 MB. Any suggestions?

  • @melchizedek

    Paste it here: http://pastebin.com/

    I7 [email protected]/32GB Ram/3440 x 1440 + 1440p/EVGA 1080 FTW/512GB SSD/2TB HD/Antergos Base w/ Plasma

  • @Wyn Pastebin has an even smaller limit of 512 KB per paste.

  • @karasu

    Let’s see if this works…

    link deleted

  • @melchizedek
    You have to share it (allow access to everybody).

  • Jul 14 02:56:22 melchizedek systemd-vconsole-setup[169]: /usr/bin/loadkeys failed with error code 1.
    Jul 14 02:56:22 melchizedek systemd-vconsole-setup[169]: cannot open file gb
    

    And also:

    Jul 14 02:56:26 melchizedek systemd-vconsole-setup[314]: /usr/bin/loadkeys failed with error code 1.
    Jul 14 02:56:26 melchizedek systemd-vconsole-setup[313]: /usr/bin/loadkeys failed with error code 1.
    Jul 14 02:56:26 melchizedek systemd-udevd[236]: Process '/usr/bin/set-wireless-regdom' failed with exit code 1.
    Jul 14 02:56:26 melchizedek systemd-udevd[228]: Process '/usr/lib/systemd/systemd-vconsole-setup' failed with exit code 1.
    Jul 14 02:56:26 melchizedek systemd-udevd[233]: Process '/usr/lib/systemd/systemd-vconsole-setup' failed with exit code 1.
    

    I do not know which keymap are you trying to load (but gb does not exist).

    EDIT: Start checking your /etc/vconsole.conf file

    Cheers!

  • @karasu Thanks, Karasu – that solved it. I simply changed the keymap from ‘gb’ to ‘uk’ in vconsole.conf.

  • @karasu

    Sorry for the small bump. But I just had this issue with the latest github cnchi (As of 20 mins ago)

    /etc/vconsole.conf was set to ca. Changing it to us fixed it.

    I7 [email protected]/32GB Ram/3440 x 1440 + 1440p/EVGA 1080 FTW/512GB SSD/2TB HD/Antergos Base w/ Plasma

  • I had the same issue but i’m from Mexico, the solution was change “latam” for “la-latin1” in the same /etc/vconsole.conf file.

    Tenía el mismo problema pero como soy de México, la solución fué cambiar “latam” por “la-latin1” en el mismo archivo /etc/vconsole.conf .

    Thanks for your help.

  • This is very annoying. I’m sorry guys. The naming conventions of console keymaps are somewhat arbitrary.

    Maybe in the end instead of trying to guess it I’ll do like the Debian guys do, ask the user…

    We’ll see. Anyway, thanks for your patience.

  • same here. I’m getting this error for ages, but since it seem not be a system crippling problem, only now i started to investigate.
    I think this only occurs with non english setup and starts with the system installation.
    The default /etc/vconsole.conf only has one configuration line, in my case Portuguese: KEYMAP=pt . I have to change it to KEYMAP=pt-latin1 , so i don’t get the error.
    If you run the localectl list-keymaps command you will se no pt keymap, but only pt-latin1, pt-latin9
    pt-olpc. For European Spanish, for instance, there is no problem since there’s a es, es-cp850 and a es-olpc keymap.
    This small annoyance causes the virtual consoles (TTYs) to be in the default english keymap, and why in every new installation i have to reconfigure the keyboard (in gnome settings) to Portuguese.
    As Karasu said, the name conventions are somewhat messy…

  • @Carpintero tengo el mismo problema e hice lo que dices y me quede sin tarjeta de red inalambrica te pego mi dmesg a ver si me puedes apoyar XD, saludos.

    [   63.957077] ieee80211 phy0: rt2800_wait_wpdma_ready: Error - WPDMA TX/RX busy [0x00000068]
    [   65.289652] ieee80211 phy0: rt2800_wait_wpdma_ready: Error - WPDMA TX/RX busy [0x00000068]
    [   65.289661] ieee80211 phy0: rt2800pci_set_device_state: Error - Device failed to enter state 4 (-5)
    [   66.638911] ieee80211 phy0: rt2800_wait_wpdma_ready: Error - WPDMA TX/RX busy [0x00000068]
    [   67.971469] ieee80211 phy0: rt2800_wait_wpdma_ready: Error - WPDMA TX/RX busy [0x00000068]
    [   67.971476] ieee80211 phy0: rt2800pci_set_device_state: Error - Device failed to enter state 4 (-5)
    [   80.231330] ieee80211 phy0: rt2800_wait_wpdma_ready: Error - WPDMA TX/RX busy [0x00000068]
    [   81.563862] ieee80211 phy0: rt2800_wait_wpdma_ready: Error - WPDMA TX/RX busy [0x00000068]
    [   81.563868] ieee80211 phy0: rt2800pci_set_device_state: Error - Device failed to enter state 4 (-5)
    [   82.909835] ieee80211 phy0: rt2800_wait_wpdma_ready: Error - WPDMA TX/RX busy [0x00000068]
    [   84.242424] ieee80211 phy0: rt2800_wait_wpdma_ready: Error - WPDMA TX/RX busy [0x00000068]
    [   84.242431] ieee80211 phy0: rt2800pci_set_device_state: Error - Device failed to enter state 4 (-5)
    
  • This post is deleted!
systemd25 Posts 18Views 8426
Log in to reply