• \[SOLVED\] swap partition


    I made a swap partition and marked it as so in the partitioneditor. After the installation is finished the swap partition is not used. I need to enter “swapon /dev/sda1” (my swap partition) in the terminal to activate swap. Is this normal behaviour?

    Antergos: funny name, serious distro

  • I made a swap partition and marked it as so in the partitioneditor. After the installation is finished the swap partition is not used. I need to enter “swapon /dev/sda1” (my swap partition) in the terminal to activate swap. Is this normal behaviour?

    Antergos: funny name, serious distro

  • I don’t know how the installer works, but if you create a swap partition and you want to use it (without running swapon /dev/sdXY). you should add it to [i:2r56vta9]/etc/fstab[/i:2r56vta9] file.

    Have a look here: [https://wiki.archlinux.org/index.php/Fstab][0]">[https://wiki.archlinux.org/index.php/Fstab][1]

    [0]: <a href=
    [1]: https://wiki.archlinux.org/index.php/Fstab

  • @“carlo”:pzfsuz6e said:

    I don’t know how the installer works, but if you create a swap partition and you want to use it (without running swapon /dev/sdXY). you should add it to [i:pzfsuz6e]/etc/fstab[/i:pzfsuz6e] file.

    Have a look here: [https://wiki.archlinux.org/index.php/Fstab][0]">[https://wiki.archlinux.org/index.php/Fstab][1][/quote:pzfsuz6e]

    Trust me, it’s there…
    UUID=9fcf8a71-f8b4-4402-b825-7ad73f16f5ba swap defaults 0 0

    [0]: <a href=
    [1]: https://wiki.archlinux.org/index.php/Fstab

    Antergos: funny name, serious distro

  • Could you open a bug in our bugtracker about this please?

    [http://bugs.antergos.com][0]">[http://bugs.antergos.com][1]

    I will check it as soon as I can

    [0]: <a href=
    [1]: http://bugs.antergos.com

  • @“faidoc”:um8qlbe7 said:

    Could you open a bug in our bugtracker about this please?

    [http://bugs.antergos.com][0]">[http://bugs.antergos.com][1]

    I will check it as soon as I can[/quote:um8qlbe7]

    Yes sure. I did some investigation and found the installer marked the partition as swap but with ID 83. In my opinion that should be 82. So I installed gparted, erased it with linux-swap and rebooted. That changed the ID to 82 just fine but no luck.
    Then I used mkswap which changed the UUID, altered that in /etc/fstap but no luck.
    Swapon /dev/sda1 or swapon UUID=564208904 etc. works but only in this session

    [0]: <a href=
    [1]: http://bugs.antergos.com

    Antergos: funny name, serious distro

  • mmmm I couldn’t test if this is it, but change

    UUID=9fcf8a71-f8b4-4402-b825-7ad73f16f5ba swap defaults 0 0

    to

    UUID=9fcf8a71-f8b4-4402-b825-7ad73f16f5ba swap swap defaults 0 0

    I think it could be this, cnchi is not setting the mount point, just the origin, fs and options

  • Faidoc is correct. At install time, user must select ‘use as’ swap AND mount point enter ‘swap’ else it mounts it nowhere. This was pretty counterintuitive so my apologies. I’ve changed it to automatically set ‘swap’ as mountpoint if user selects ‘swap’ as the filesystem. This should show up in next release.

  • @“faidoc”:1g5qlf13 said:

    mmmm I couldn’t test if this is it, but change

    UUID=9fcf8a71-f8b4-4402-b825-7ad73f16f5ba swap defaults 0 0

    to

    UUID=9fcf8a71-f8b4-4402-b825-7ad73f16f5ba swap swap defaults 0 0

    I think it could be this, cnchi is not setting the mount point, just the origin, fs and options[/quote:1g5qlf13]

    Yes! Tnx faidoc that works (at least with swpaon -a to process the fstab entrys). Thanks again!

    Antergos: funny name, serious distro

  • @“skinner”:12zwnnw8 said:

    Faidoc is correct. At install time, user must select ‘use as’ swap AND mount point enter ‘swap’ else it mounts it nowhere. This was pretty counterintuitive so my apologies. I’ve changed it to automatically set ‘swap’ as mountpoint if user selects ‘swap’ as the filesystem. This should show up in next release.[/quote:12zwnnw8]

    Brilliant. I noticed no swap mountpoint in the list in the installer and on internet I found some articles explaining that swap didn’t need a mountpoint set. I’m a Linux noob so I thought that it would be allright to leave it blank.

    Antergos: funny name, serious distro

  • From what I can remember of my install, it didn’t give me an option to set a swap mount point. It was shaded out. I didn’t think anything of it because I have seen the same behavior in other distros and swap was always working. I’ll double check tonight while I am gathering some screenshots for the installation guide

Posts 11Views 3835
Log in to reply