Still cannot boot standard Antergos ISO on my laptop, minimal works well though by I need to setup L2TP internet connection befora installation so I need to use a standard image. Everything happens just like I described it in my last post but here are some logs.
logs.tar
Upd. Some strange lines:

Jun 18 14:30:22 Antergos-ISO org.a11y.atspi.Registry[1000]: XIO:  fatal IO error 11 (Resource temporarily unavailable) on X server ":0"
Jun 18 14:30:22 Antergos-ISO org.a11y.atspi.Registry[1000]: after 21 requests (21 known processed) with 0 events remaining.
Jun 18 14:30:22 Antergos-ISO org.gtk.vfs.Daemon[837]: A connection to the bus can't be made
Jun 18 14:30:22 Antergos-ISO org.gtk.vfs.Daemon[837]: g_dbus_connection_real_closed: Remote peer vanished with error: Underlying GIOStream returned 0 bytes on an async read (g-io-error-quark, 0). Exiting.
Jun 18 14:30:22 Antergos-ISO ca.desrt.dconf[837]: g_dbus_connection_real_closed: Remote peer vanished with error: Underlying GIOStream returned 0 bytes on an async read (g-io-error-quark, 0). Exiting.
Jun 18 14:30:22 Antergos-ISO org.a11y.Bus[837]: g_dbus_connection_real_closed: Remote peer vanished with error: Underlying GIOStream returned 0 bytes on an async read (g-io-error-quark, 0). Exiting.
Jun 18 14:30:26 Antergos-ISO gnome-session[831]: gnome-session[831]: WARNING: Could not make bus activated clients aware of GNOME_DESKTOP_SESSION_ID=this-is-deprecated environment variable: Could not connect: Connection refused
Jun 18 14:30:26 Antergos-ISO gnome-session[831]: WARNING: Could not make bus activated clients aware of GNOME_DESKTOP_SESSION_ID=this-is-deprecated environment variable: Could not connect: Connection refused
Jun 18 14:30:26 Antergos-ISO gnome-session[831]: WARNING: Could not make bus activated clients aware of XDG_MENU_PREFIX=gnome- environment variable: Could not connect: Connection refused
Jun 18 14:30:26 Antergos-ISO gnome-session[831]: gnome-session[831]: WARNING: Could not make bus activated clients aware of XDG_MENU_PREFIX=gnome- environment variable: Could not connect: Connection refused
Jun 18 14:30:26 Antergos-ISO gnome-session[831]: WARNING: Lost name on bus: org.gnome.SessionManager
Jun 18 14:30:26 Antergos-ISO gnome-session[831]: gnome-session[831]: WARNING: Lost name on bus: org.gnome.SessionManager
Jun 18 14:30:34 Antergos-ISO lightdm[820]: pam_unix(lightdm-autologin:session): session closed for user antergos
Jun 18 14:30:34 Antergos-ISO systemd-logind[666]: Removed session c1.
Jun 18 14:30:34 Antergos-ISO lightdm[797]: ** (lightdm:797): CRITICAL **: session_get_login1_session_id: assertion 'session != NULL' failed
Jun 18 14:30:34 Antergos-ISO systemd[1]: Stopping User Manager for UID 1000...

PS. Does anyone have previous antergos iso?