• Default File Manager - Round II


    I installed EasyTag today for tagging MP3s. it works great. One problem… Somehow, EasyTag seems to be my default file manager now when I press the key command to open the home directory. Also, if I insert a flash drive, EasyTag automatically opens.

    If I look through Preferred Applciations, EasyTag does not show for any entry whatsoever…

    In Cinnamon, how do I definitively set my default file manager to Nemo?

  • I’ve always had this problem with EasyTag and with Audacious. I’ve never really find out where the problem is.

    Maybe somebody can enlighten us.

  • @karasu Weirdness… I used to use EasyTag in Ubuntu and Mint without issue.

    Really wish there was some way that was obvious to set the default file manager, though, as Cinnamon still seems schizophrenic and randomly puts some things in Nemo and others in Nautilus…

  • @herbie said:

    You could try this

    https://wiki.archlinux.org/index.php/Xdg-open#Set_the_default_file-browser

    Good call. Looking at that link, i learned where the file is that controls the default file manager (why is this not a simple setting in the control panel equivalent?). Pretty easy to edit that file with nano. Looks like Nautilus is the default out of the box, which seems counter-intuitive because isn’t Nemo the default file manager of Cinnamon?

  • UPDATE: even after manually setting the default through that file listed in the link above, EasyTag still hijacks things. Removing EasyTag…

  • UPDATE AGAIN:

    I found a fix!

    Install EasyTag, then edit the file /usr/share/applications/mimeinfo.cache using the command

    sudo gedit /usr/share/applications/mimeinfo.cache

    Edit the file to remove all traces of EasyTag (use the find function, I found 11 places), being sure to pay attention to syntax. This should resolve it.

    Apparently, this bug goes WAY back…

  • Nice work Myk… Glad you found it.

  • Well, it’s a new day and the problem comes back after a reboot… Nevermind… Not Solved.

Posts 9Views 1946
Log in to reply