• WHY Gnome ignores the nvidia-settings-load-config ...?


    ftp://download.nvidia.com/XFree86/Linux-x86_64/352.09/README/commonproblems.html#settingsoverridden
    "If you believe that your desktop environment is overriding settings that you configured in nvidia-settings, some possible solutions are:

    1. Use the display configuration tools provided as part of the desktop environment (e.g. gnome-control-center display, gnome-display-properties, kcmshell4 display, unity-control-center display, xfce4-display-settings) to configure your displays, instead of the nvidia-settings control panel or the xrandr command line tool. Setting your desired configuration using the desktop environment’s tools should cause that configuration to be the one which is restored when the desktop environment overrides the existing configuration from nvidia-settings. If you are not sure which tools your desktop environment uses for display configuration, you may be able to discover them by navigating any available system menus for “Display” or “Monitor” control panels.
    2. For settings loaded from ~/.nvidia-settings-rc which have been overridden, run nvidia-settings --load-config-only as needed to reload the settings from ~/.nvidia-settings-rc.
    3. Disable any features your desktop environment may have for managing displays. (Note: this may disable other features, such as display configuration tools that are integrated into the desktop.)
    4. Use a different desktop environment which does not actively manage display configuration, or do not use any desktop environment at all…" :laughing:

    It’s very frustrating for me. The driver is good and efficient, but you can not permanently set of personal values of brightness, contrast and gamma. :rage: :rage: :rage:
    It is there a chance to Gnome offered brightness and contrast controls integrated with gnome-tweak-tool or with any other tool?

  • Hmm…No, I don’t think there is such a tool for GNOME. I find it strange that the brightness and gamma settings would be altered by GNOME. Are you certain its GNOME doing it? After configuring it the way that you want using nvidia-settings, did you export the config to this file: /etc/X11/xorg.conf.d/20-nvidia.conf?

  • No, only what i have in: /etc/X11/xorg.conf.d is /00-keybord.conf
    and in /etc/X11/xorg.conf create nvidia-xconfig

  • Ok, that’s the problem I think. You should not save the nvidia one as xorg.conf. You should save it as 20-nvidia.conf.

  • Ok, i try it. Cant do this as normal user, should open nvidia-settins as root? (sudo nvidia-settings)
    Ok, its my 20-nvidia.conf
    http://pastebin.com/AEjZ3kUr
    and ~/.nvidia-settings-rc
    http://pastebin.com/Psh8GjkE

    after this in terminal: nvidia-settings --load-config-only
    and settings after rebooot not loading.

    Xorg.0.log:
    http://pastebin.com/uUMyHg7X

    Yes, Gnome will ignore everything !!! Whatever it will be… xorg.conf, or 20-nvidia.conf, or /.xinitrc, or ~ / .xprofile, or ~ / .config / autostart / nvidia.desktop
    There is no chance to: nvidia-settings --load-config-only add to the startup and execute it.

    But still Gnome is best choice in actually linux desktop.

  • @gaim said:

    nvidia-settings --load-config-only

    Hmm…You can run that command automatically on startup by editing /etc/lightdm/lightdm.conf and change this line:

    #session-setup-script=
    

    to the following:

    session-setup-script=nvidia-settings --load-config-only
    
  • I’m Arch user Gnome, and gdm is my default to login. In /etc/gdm/ dont have gdm.conf.
    But I have: /etc/gdm/Xsession:
    http://pastebin.com/Ze9BkV8p

  • Hi,

    You can try creating a new file at: ~/.config/autostart/my-nvidia-settings.desktop and add the following to it:

    [Desktop Entry]
    Name=My Nvidia Settings
    Exec=nvidia-settings --load-config-only
    Terminal=false
    Type=Application
    X-GNOME-Autostart-enabled=true
    
  • @lots.0.logs said:

    Hi,

    You can try creating a new file at: ~/.config/autostart/my-nvidia-settings.desktop and add the following to it:

    [Desktop Entry]
    Name=My Nvidia Settings
    Exec=nvidia-settings --load-config-only
    Terminal=false
    Type=Application
    X-GNOME-Autostart-enabled=true
    

    It does not work.

  • Hmm…Well, I don’t use GNOME as my daily desktop and in Antergos we don’t use GDM so I’m afraid I 'm out of ideas :frowning: Sorry!

nvidia-settings11 Posts 10Views 3205
Log in to reply