• Error: Can't install necessary packages. Cnchi can't continue.


    Hi,
    when I try to install antergos-2015.06.03-x86_64.iso on a DN2820FYKH NUC I get this error: https://imgur.com/a/rSnGL

    edit
    Updated title from “Installer: “Error creating a new partition table on device /dev/sda”” to “Error: Can’t install necessary packages. Cnchi can’t continue.”

  • Hi,

    If you could, please post the installer log after the error occurs. You can find it in the /tmp directory. Thanks.

  • The error message doesn’t say where the log file is located. This should be improved.

    So, I tried it in the next day (had to reinstall the iso because I got a kernel panic error message while booting from USB stick) and this time I get a different error: "ERROR: ‘Error informing the kernel of the partition change.’"
    http://pastebin.com/dA6P1RT6

    edit
    After let it run for a few hours, the OS hanged itself and I had to reboot but after trying to boot from the USB stick again, it said: “couldn’t find usb_device” (I guess this is similar to the kernel panic error, but this time something different got corrupted).

  • @Sunsearcher :

    You had already your sda partitions mounted:

    [2015-06-15 09:09:31] [auto_partition] WARNING: Unmounting /dev/sda3
    [2015-06-15 09:09:31] [auto_partition] WARNING: Unmounting /dev/sda2
    [2015-06-15 09:09:31] [auto_partition] WARNING: Unmounting /dev/sda1
    

    this makes for Cnchi impossible to wipe out your sda to create the new partitions.

    Please, do not mount those partitions. If you didn’t do it, then it was that you tried to reinstall after a failed installation, didn’t you? Please, always reboot to retry after a failed install.

    Cheers!

  • I simply put the USB stick, booted from it and tried to install using the Cnchi installer. Didn’t to extra things like mounting some broken partitions manually or so. Yes, the installation failed and I tried to install it again, but even after several reboots I still get the same error (otherwise I wouldn’t start a topic here). I tried it like 5 times but get these errors. Weird, never got them earlier when installing any other Linux distribution. So maybe I should try to boot but this time unmount the partitions manually (again, never had to do things like this in the past). Wonder, maybe this behaviour can be considered a bug in Cnchi.

  • @Sunsearcher

    Wonder, maybe this behaviour can be considered a bug in Cnchi.

    It’s possible, of course. What bugs me is that nobody else is having this problem (at least nobody reported it).

    Just curious, please answer this:

    • ISO version (minimal or standard and date)
    • Cnchi version

    Thanks!

  • @karasu See first post
    antergos-2015.06.03-x86_64.iso, 0.8.137
    $ sha1sum antergos-2015.06.03-x86_64.iso
    74ca33e135eb184710f02154a8005f067030a1ed

    What also is weird, is that after a few hours I can’t boot from the USB stick. The live desktop modifies itself such that it can’t boot any more (also never had this issue with any Linux distro).

    The only changes I do when I try to install is in the installer I set the switch to install Cinnamon instead of the default GNOME and to install LibreOffice.

    I’ll try to reinstall the iso on USB stick, then first unmount the sda and try to install. Will report.

    edit
    It says “/dev/sda1 not mounted” (so it’s not mounted, as expected, but the log says it’s mounted)

    BTW: I installed the iso using $ sudo dd bs=4M if=antergos-2015.06.03-x86_64.iso of=/dev/sdb && sync

    Something is very weird, could be the USB stick, Antergos or the DN2820FYKH NUC.

    I also get a crash when I boot before the login, it says something like “oops something went wrong”, then it reloads and I can log in.

  • I recorded a vid: http://www.file-upload.net/download-10695321/MyMovie.mp4.html
    On the first try after booting from the USB stick, as far as I remember, the first error I get is always this: “Can’t create download package list …”. Then when I try again (without rebooting), I get the errors mentioned above.

  • @Sunsearcher A reboot is necessary after a failed installation attempt. If you do not reboot, it is very unlikely that your install will be successful in the second attempt. If you could post the log after a failure occurs that will be helpful. Thanks.lm

  • Here comes a story with a bit of success:
    So I tried it today again and after the first try/boot it started to install but then I remembered that I didn’t change the language, so I reboot. Then I had try to install it again for approx. 10 times because it failed each time (hanged itself multiple times even in the boot, saying e.g. “(1 of 3) rebuilding journal …”, “(2 of 3) …”, “(3 of 3) …” and again “(1 of 3) …” and so on (never happened before), black screen after clicking on “antergos” login button (only mouse cursor visible (also never happened before). Then after many retries it worked, Cnchi launched, and the installation worked (took 10-15min) and I can login, but I forget to change the DE from GNOME to Cinnamon. So, did the installation work just because I didn’t select Cinnamon? I don’t know. Don’t want to try this again, it’s annoying enough. Then I tried to install Cinnamon afterwards: $ sudo pacman -S cinnamon, and after installation I can select it in the login menu, but after login I get a blank desktop (no menu, no taskbars) with just the default green-bluish triangles wallpaper. My question now is how to install cinnamon?

    Since the Cinnamon installation (pacman -S cinnamon) didn’t work (the blank screen after login), then maybe the installation from the USB-stick when selecting Cinnamon instead of the default GNOME would also have failed (because of some packages missing). Maybe someone with this NUC and unannoyed constitution wants to try it.

  • i HAD A LOT OF TROUBLE with various USB sticks. keep trying until you find a good one, and as well use CFdisk when formatting it seems to work better than using Gparted in the Antergos live CD. I have had trouble installing just Base and adding my own stuff on top. So I went with the XFCE stock environment that comes with Antergos.

  • This post is deleted!
  • Can log in again

    Yoshiserry, I hope it’s the USB stick but I never had any problems with this stick. I didn’t format the stick (not needed: http://antergos.com/wiki/install/create-a-live-usb), just did: sudo dd bs=4M if=antergos-2015.06.03-x86_64.iso of=/dev/sdb && sync. Or what do you mean by CFdisk? Antergos is basically an installer for Arch Linux (with some extra things) and the installer itself, Cnchi, does all the formatting for you, no manual CFdisk commands needed, as with e.g. Arch.

    So, can anyone answer if sudo pacman -S cinnamon is the correct way to install cinnamon? because as mentioned this doesn’t work for me and when installing Cinnamon no USB stick was involved/connected to the NUC. Unfortunately I don’t have another stick to test. I can make a vid of that mentioned blank Cinnamon desktop that comes up after login.
    I’m not too excited but I’ll be forced to switch to Ubuntu if I can’t get Cinnamon running.

  • I tried cnchi-dev --force and the installer updated to 0.8.144-1 but still the same error: http://pastebin.com/Ei5nUEX2

  • Hi,

    I disabled the mirror that was causing your issue so you should be able to complete installation now. Sorry about the trouble!

  • While the installation continued much further (0.8.137 is not fixed though, maybe time for an update there too as not everyone knows of cnchi-dev --force and it’s of course not a proper fix), I get this now: http://pastebin.com/NurnDVKM , https://imgur.com/xGKdwSb

  • @Sunsearcher I’m not even sure where or how –force got added onto the cnchi-dev command. It’s not an argument expected by the command so it is simply ignored. We have not been referring people to the cnchi-dev command because we implemented its functionality into the ISO so it doesn’t need to be called manually. It looks like the cnchi update I pushed had not made it to the mirror closest to you at the time you installed. It should definitely be available now. It’s version 0.8.151 i f I recall correctly.

    Cheers!

  • I’m not sure what you mean by

    It looks like the cnchi update I pushed had not made it to the mirror closest to you at the time you installed. It should definitely be available now. It’s version 0.8.151 i f I recall correctly.

    but when I started cnchi-dev it was already version 0.8.151, as you can see from the log and image I provided.

  • Tried it today again, the installation continued even further but still another error: http://www.file-upload.net/download-10716802/cnchi.log.html (1.2MB) , https://imgur.com/XNTxAqQ

  • it seems there is another bug with cnchi once the installation failed you cannot start the installation procedure again you have to restart and start over,
    i did use the cnchi in the installer didn’t update it and worked fine

Posts 48Views 12129
Log in to reply