• Unable to add keyboard layout?


    Hello,
    I’m learning Russian and I’m trying to add Russian as a second keyboard layout. But when I try to add it settings doesn’t recognise it as a language/format/input source :rage:.
    Please help me!

    Kind Regards,
    Jens

  • @jens-van-der-veen To what DE are you trying to add Russian?

  • @just GNOME 3.16

  • @jens-van-der-veen Этот текст написан по-русски в Гноме 3.16 (= This text is written in Russian in Gnome 3.16). So there should be no issues with adding it.

    Could you please be a bit more specific, describing the problem(s) you encounter? The OP is quite generic.

  • @just I press add language/format/input source and when I try to enter a language it doesn’t recognise it. Screenshot from 2015-06-12 13-46-11.png

  • @mrjenskay OK, I see…

    • If the language is not listed in Region & Language --> Formats (Russian in your case), it may be a problem to add it from GUI. As you can see, I’m using Ireland formats.

    gnome-russian-1.png

    • But can you at least add Russian as an Input Source (keyboard)? It is needed if you want to write in Russian.

    • To be able to read Russian text, some fonts with cyrillic characters must be installed.

  • @mrjenskay Anyway, there’s not a problem at all to enable / add any locale you want to Gnome’s GUI - with some commands in terminal. If you aren’t afraid of using it, we can do it in 2 minutes.

  • Yeah I’m not afraid.
    Lets do this!

    thanks btw

  • @just I can’t enable a keyboard layout. Thats the problem. Screenshot from 2015-06-12 16-55-30.png

  • @mrjenskay said:


    Lets do this!

    First of all, we need to enable in Arch (Gnome in your case) some additional locale(s). All work is done in terminal. We will issue two simple commands and will use the nano text editor. Let’s go.

    1. Open the Terminal

    2. In the terminal, issue the command sudo nano /etc/locale.gen. After you’ve entered your password, the nano editor will open, with /etc/locale.gen text file within it.

    3. You’ll see a very long list of locales (lines), known in Arch. Almost all of them start with the hash character # in the 1st position - the lines are commented out (ignored).

    4. We’re interested only in locales that have UTF-8 qualifier. Ignore all others.

    5. For safety, use only Up/Down-Arrow keys to scroll the text.

    6. As you’re interested mainly in Russian, scroll down until you see the line that reads #ru_RU.UTF-8 UTF-8. Uncomment it, by deleting the initial # character. The line should read ru_RU.UTF-8 UTF-8 now.

    7. If it is commented out, uncomment the en_US.UTF-8 UTF-8 locale as well. It’s wise to have English (US) locale explicitely enabled.

    8. If you was installing Gnome with your national locale, different from English (US), it should be already uncommented. Check it.

    9. Uncomment any other locale(s) you wish to see in Gnome’s GUI.

    10. Now we must exit from nano, saving all the changes.

    11. This is done with the following keys; press them in sequence, exactly as you read it here: Ctrl X y Enter

    12. We’re back in terminal at the bash prompt.

    13. Finally, issue the command sudo locale-gen. You’ll see the list of all enabled locales, similar to this one (those are my languages):

      $ sudo locale-gen
      [sudo] password for just: *********
      Generating locales...
        en_IE.UTF-8... done
        en_US.UTF-8... done
        fi-FI.UTF-8... done
        it_IT.UTF-8... done
        ru_RU.UTF-8... done
      Generation complete.
      $ 
      
    14. Exit from terminal (close it) by hitting Ctrl+D.

    15. Done.

    No reboot, no logout-login are needed. Simply open Gnome’s Settings. In Region & Language you should see all enabled locales now.

    This was the first step - enabling additional locales.

    If you still don’t see Russian keyboard, or don’t have Russian fonts, we’ll add them later.

newb1 layout7 keyboard45 Posts 10Views 4150
Log in to reply