• Sporadic Mouse Crashes / Freezes that occur at login


    My mouse and even sometimes keyboards crash at the very beginning of the session. Antergos and lightDM boot up nicely but the mouse doesn’t move.

    Checking xsession-error, I got these two lightlocker related error messages:
    light-locker: Fatal IO error 11 (Resource temporarily unavailable) on X server

    and

    Couldn’t register with accessibility bus: Did not receive a reply. Possible causes include: the remote application did not send a reply, the message bus security policy blocked the reply, the reply timeout expired, or the network connection was broken.

    A bundle of various log files that I’ve gathered during the crash (before logging into lightdm and after) has been appended at the end of this post.

    I’ve ran both lightdm and gdm since installing antergos. I never had a mouse crash with gdm. The mouse crash has occured on other machines I’ve ran antergos as well. At some point the mouse crashes were happening one reboot out of 3 or 4 but they’re alot more sporadic adter a few updates. Try to kill X from terminal did not do anything. Nor restarting lightdm. Nor turning off and turning on mouse service using systemctl.

    I have a Dell Alienware m11x r2 laptop.

    Here are the logs:
    mouse crash logs bundle.zip

  • I don’t have time to go through all of them but from what I’ve looked at thus far, you have some shell extensions that are causing problems when gnome-shell starts. I recommend disabling any extensions that have not been updated since the release of GNOME 3.16. (if they weren’t updated then they will cause problems).

    Cheers!

  • I’ll give that a go. Thanks.

  • You’re welcome :smile: Let us know how it goes!

mouse41 xorg22 mouse crash4 xserver5 crashes8 Posts 4Views 940
Log in to reply