• Gigabyte 990fxa-ud3 onboard ethernet and usb3 issues


    Hello,
    Last December I built a desktop for myself that uses the motherboard I specified in the title. I had searched for a solution but all I found was setting iommu to disabled in the bios and setting iommu to soft in the kernel and that got usb 3 working. I forgot how to do that since I have switched to antergos and I was wondering how I could get both usb3 and onboard Ethernet working. What my network interface in gnome says when I plug in an Ethernet cable connecting to my router just keeps displaying “connecting” and never establishes a connection .Also let me know how to get any system logs related to Ethernet.

    Thanks,
    Tom

  • All system logs are aggregated into the system journal. There are instructions for obtaining the logs posted in the top level of each category of the Technical Issues section of the forum. Post your journal here after attempted to connect your network.

    Cheers!

  • "This board is not directly compatible with Linux, specifically the built-in Ethernet. In order for it to work you must enable IOMMU in BIOS, but disable IOMMU on the linux kernel command line with “iommu=soft”. Without this all will appear working, but you will have absolutely no connectivity. This bug / compatibility issue affects all revisions past 1.1 that have the new UEFI BIOS."
    From here

  • @The-Kel said:

    "This board is not directly compatible with Linux, specifically the built-in Ethernet. In order for it to work you must enable IOMMU in BIOS, but disable IOMMU on the linux kernel command line with “iommu=soft”. Without this all will appear working, but you will have absolutely no connectivity. This bug / compatibility issue affects all revisions past 1.1 that have the new UEFI BIOS."
    From here

    So I did do that and I still have the same issue. What I did was I went to /etc/default/ and I edited the grub file and set the default setting to “iommu=soft” instead of the uuid that was there. I saved the original grub file incase I needed to revert back to it.

    @lots.0.logs said:

    All system logs are aggregated into the system journal. There are instructions for obtaining the logs posted in the top level of each category of the Technical Issues section of the forum. Post your journal here after attempted to connect your network.

    Cheers!

    For some reason when I checked the xsession-errors file nothing was there so instead I ran journalctl and I copied the result into a pastebin: http://pastebin.com/J5sMPPLj
    Hopefully that helps.

    Thanks,
    Tom

  • Looks like you did it wrong, just restore the original grub file (/etc/default/grub) and add this at the end of it:

    # Disable iommu
    GRUB_CMDLINE_LINUX=“iommu=soft”

    Then run this command to rebuild grub:

    sudo grub-mkconfig -o /boot/grub/grub.cfg

    And that should do it

  • @The-Kel said:

    Looks like you did it wrong, just restore the original grub file (/etc/default/grub) and add this at the end of it:

    # Disable iommu
    GRUB_CMDLINE_LINUX=“iommu=soft”

    Then run this command to rebuild grub:

    sudo grub-mkconfig -o /boot/grub/grub.cfg

    And that should do it

    I did that and what happened was the ethernet finally showed to be connected but wouldn’t load anything. I tried to go to a website without wifi on and the website wouldn’t load. And usb 3.0 still won’t work.

  • I googled your problem and found a lot of information:
    Make sure that the IOMMU controller it’s enabled
    xHCI handoff - Enabled EHCI handoff - Enabled IOMMU controller - Enabled
    Don’t forget to disable UEFI and change all boot options to “Legacy Only”.
    also someone said that you should use “iommu=pt” instead of “iommu=soft"
    From here
    Also Here says:
    Go to your Bios “supr” or del” when you turn on your computer, and when in Bios look for “network stack” and set it to “enable.” (also tells you to install the realtek driver)
    Here says:
    Do you have IOMMU enabled in the BIOS? Try booting with “amd_iommu=on” appended to the boot options.

  • @The-Kel said:

    I googled your problem and found a lot of information:
    Make sure that the IOMMU controller it’s enabled
    xHCI handoff - Enabled EHCI handoff - Enabled IOMMU controller - Enabled
    Don’t forget to disable UEFI and change all boot options to “Legacy Only”.
    also someone said that you should use “iommu=pt” instead of “iommu=soft"
    From here
    Also Here says:
    Go to your Bios “supr” or del” when you turn on your computer, and when in Bios look for “network stack” and set it to “enable.” (also tells you to install the realtek driver)
    Here says:
    Do you have IOMMU enabled in the BIOS? Try booting with “amd_iommu=on” appended to the boot options.

    I did all of that. I however could not install the realtek driver. When I attempted to install I got this:

    Check old driver and unload it.
    rmmod r8169
    Build the module and install
    make[2]: *** No rule to make target ‘clean’. Stop.
    make[1]: *** [clean] Error 2
    make: *** [clean] Error 2

    Also usb 3.0 still doesn’t seem to work.

990fxa-ud31 ethernet11 Posts 8Views 2956
Log in to reply