• Booting from USB results in black screen (GTX 970)


    I ran antergos in Virtual Box, and I fell in love instantly. I really want this to become my primary distro. So, any help to solve my problem would be fabulous. :)

    My motherboard is GA-X99-UD4. My GPU is NVIDIA GTX 970.

    I installed the antergos ISO (not the minimal one) to my USB drive from Windows 7. I booted from the USB drive. It brings up the menu system. I choose the top option offered me from antergos. (I can’t remember the exact wording. Boot UEFI USB or whatever.)

    The system takes a while doing lots of things. It gives me lots of OK messages (similar to how it looked booting from a VM). Then I get pages upon pages of nouveau output. None of the output looks bad in any way; it’s just a bunch of hex values. After doing this (for about a minute), the screen just goes black (as if about to enter the GUI) and never does anything from there. I let it sit all through dinner, and the situation never improved.

    How do I even begin to diagnose this issue? Is my GPU too new? Can I launch the install using the latest NVIDIA binary somehow? My motherboard has no video output; I don’t know if I can launch it using “Intel graphics” or whatnot. Would a picture of the nouveau output be of any help?

    (EDIT) I’m doing some searching around. I started stumbling upon more useful information by moving away from any specific distro. It seems GTX 970/980 presents problems for just about any distro’s installation. I need to have the latest driver in place for the display to work.

  • Hi,

    Unfortunately the latest NVIDIA cards are not supported by the opensource drivers yet. The developers don’t have access to the data they need to implement support. We have been considering how we might include both on the ISO. Though so far we have not had much success. You can install them yourself. Are you connected to the web via ethernet? (That makes the process a lot easier on the command line)

    1. When the boot screen appears, add the following boot command (just begin typing when the screen appears):
    systemd.unit=multi-user.target
    
    1. That should bring you to a login prompt. Log in using the username root and then press enter for the password.
    2. Now run these commands:
    pacman -Syy nvidia nvidia-utils nvidia-libgl
    # It will ask you if you want to handle a conflict..you should choose  "Yes"
    systemctl isolate emergency.target
    modprobe -r nouveau
    pacman -Rccn xf86-video-nouveau
    modprobe -a nvidia
    depmod -a
    systemctl isolate graphical.target
    

    Now, just keep in mind that its not a sure thing that this will work. There are more than a few reasons why it may fail. However, its the only method that has any chance while using the current iso images. Let me know how it goes!

    Best Regards,
    Dustin

  • This post is deleted!
  • I successfully got to the command-line interface as root! I am attempting the commands you put forth now…

    Entering “modprobe -r nouveau” gives me "FATAL: Module nouveau is in use."
    Entering “modprobe -a nvidia” gives me “ERROR: could not insert ‘nvidia’: No such device”

    But the removal of xf86-video-nouveau succeeded.

  • I revised the commands. Try them (in the order I have them listed). Let me know how it goes.

  • Do I press Enter for maintenance mode when it prompts me to?

    I got the same result. It won’t touch nouveau while it is “in use”.

    On a side note, I did fire up Chakra OS, and it worked out of the box thanks to an option to start up using “non free” software. I strongly dislike KDE, and I dislike that Chakra uses a forked repo. So, anything to get antergos up and running would be great. XD

  • Have you tried the Minimal ISO? It does not require hardware accelerated graphics so you should be able to boot to the GUI. It might be low resolution but at least you can do the install. Afterwards you can swap nouveau for nvidia drivers and reboot. A reboot is needed for it to work properly which is why its not working for you on the ISO (if you reboot you lose the changes and end back up where you started)

  • No, I haven’t! I will do that right away. I hope that works.

    UPDATE – So far so good! I actually got a high-res GUI… but my mouse cursor is invisible! D=

    Seriously, I’m so close… Why is my mouse missing? I can tell UI elements are reacting to my mouse’s position. There’s just no arrow.

    UPDATE 2 – Well, I’m impatient, so I muscled my way through the installer with an invisible cursor. Go me. You should probably look into that. XD

    I am preparing to reboot, remove nouveau and install nvidia. Here goes nothing.

    UPDATE 3 – I am happy to report that I posting this from my working Antergos install! I was able to get to the CLI, install the driver, etc. Now, my desktop environment is up and running. All three monitors work. I have Twitch streaming on one. I am happy. :)

    systemd.unit=multi-user.target
    

    That’s what saved the day ultimately. I’ve never known about this, and it let me handle the drivers.

  • this can be solved by switching to igpu in the mobo and then installing normally

    I went into my mobo setup amd switched primary display from pcie to igfx, installer worked fine after this, obviously you have to replug your monitor into the mobo after restart

  • Same problem here, I try with normal ISO and minimal. After selecting NVIDIA fallback mode (systemd.unit=multi-user.target), a error appears, saying that “vmlinux” or something, was not found.

  • @Rearis disable secure boot should solve this error inside efi/bios or from inside a windows installation.

    [updates once a week] = [90% less problems]
    [Li{u}n//u//{i}x] since 1988 - overcoming failure means success
    http://kamprad.net/howto-installing-antergos/
    https://forum.antergos.com/topic/1883/how-to-include-system-logs-when-asking-for-help

gtx 9703 nvidia98 Posts 11Views 4485
Log in to reply